Update to version 1.0.4

This commit is contained in:
Marian Csontos 2023-04-28 16:41:15 +02:00
parent 8d2c47ae1c
commit db577ef350
5 changed files with 37 additions and 75 deletions

2
.gitignore vendored
View File

@ -41,3 +41,5 @@
/dmpd090-vendor3.tar.gz
/v1.0.2.tar.gz
/dmpd102-vendor.tar.gz
/v1.0.4.tar.gz
/dmpd104-vendor.tar.gz

View File

@ -1,31 +1,30 @@
From 3d67b5c78f350db25e028112105014b09c2b34b3 Mon Sep 17 00:00:00 2001
From a6afd3ee7c9b5a6ab2906c827464acceb75123b2 Mon Sep 17 00:00:00 2001
From: Marian Csontos <mcsontos@redhat.com>
Date: Wed, 22 Feb 2023 18:07:57 +0100
Date: Wed, 22 Mar 2023 09:42:15 +0100
Subject: [PATCH] Tweak cargo.toml to work with vendor directory
Mock works offline, cargo would try to download the files from github.
So cargo vendor has to be run first, and then change the Cargo.toml to
make mock happy.
---
Cargo.lock | 2 +-
Cargo.toml | 3 ++-
2 files changed, 3 insertions(+), 2 deletions(-)
Cargo.toml | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/Cargo.lock b/Cargo.lock
index 4ff194a7..a4a56d75 100644
--- a/Cargo.lock
+++ b/Cargo.lock
@@ -973,7 +973,7 @@ checksum = "222a222a5bfe1bba4a77b45ec488a741b3cb8872e5e499451fd7d0129c9c7c3d"
[[package]]
name = "thinp"
-version = "0.1.0"
+version = "1.0.2"
dependencies = [
"anyhow",
"atty",
diff --git a/Cargo.toml b/Cargo.toml
index 94c8e5b3..6f6912ec 100644
index 135ba5f8..cbb73ec1 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -29,7 +29,8 @@ quick-xml = "0.23.1"
@@ -11,7 +11,8 @@ anyhow = "1.0"
base64 = "0.20"
byteorder = "1.4"
clap = "3.2"
-crc32c = { git = "https://github.com/zowens/crc32c", branch = "master" }
+#crc32c = { git = "https://github.com/zowens/crc32c", branch = "master" }
+crc32c = "0.6"
data-encoding = "2.3"
exitcode = "1.1.2"
fixedbitset = "0.4"
@@ -28,7 +29,8 @@ quick-xml = "0.23.1"
rand = "0.8"
rangemap = "1.1"
roaring = "0.10"
@ -36,5 +35,5 @@ index 94c8e5b3..6f6912ec 100644
threadpool = "1.8"
thiserror = "1.0"
--
2.39.1
2.40.1

View File

@ -1,30 +0,0 @@
From 26571db5911e6a85e13965d0359799537ac4ce54 Mon Sep 17 00:00:00 2001
From: Marian Csontos <mcsontos@redhat.com>
Date: Thu, 23 Feb 2023 12:11:16 +0100
Subject: [PATCH] Fix paths
Use PREFIX instead of DESTDIR. DESTDIR is used for things like BUILDROOT
---
Makefile | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/Makefile b/Makefile
index 0286000b..92c6d325 100644
--- a/Makefile
+++ b/Makefile
@@ -6,9 +6,9 @@ PDATA_TOOLS=\
$(PDATA_TOOLS):
$(V) cargo build --release
-DESTDIR:=/usr
-BINDIR:=$(DESTDIR)/sbin
-DATADIR:=$(DESTDIR)/share
+PREFIX:=/usr
+BINDIR:=$(DESTDIR)$(PREFIX)/sbin
+DATADIR:=$(DESTDIR)$(PREFIX)/share
MANPATH:=$(DATADIR)/man
STRIP:=strip
--
2.39.2

View File

@ -9,25 +9,22 @@
Summary: Device-mapper Persistent Data Tools
Name: device-mapper-persistent-data
Version: 1.0.2
Version: 1.0.4
Release: 1%{?dist}%{?release_suffix}
License: GPLv3+
#ExcludeArch: %%{ix86}
URL: https://github.com/jthornber/thin-provisioning-tools
#Source0: https://github.com/jthornber/thin-provisioning-tools/archive/thin-provisioning-tools-%%{version}.tar.gz
Source0: https://github.com/jthornber/thin-provisioning-tools/archive/v%{version}%{?version_suffix}.tar.gz
Source1: dmpd102-vendor.tar.gz
#Patch0: device-mapper-persistent-data-avoid-strip.patch
Source1: dmpd104-vendor.tar.gz
Patch1: 0001-Tweak-cargo.toml-to-work-with-vendor-directory.patch
Patch2: 0002-Fix-paths.patch
BuildRequires: expat-devel, libaio-devel, libstdc++-devel, boost-devel, gcc-c++
Requires: expat
%ifarch %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: rust >= 1.35
BuildRequires: cargo
%endif
BuildRequires: make
# FIXME: Remove this!
BuildRequires: rust-gdb
%description
thin-provisioning-tools contains check,dump,restore,repair,rmap
@ -38,9 +35,7 @@ are included and era check, dump, restore and invalidate to manage
snapshot eras
%prep
%setup -q -n thin-provisioning-tools-%{version}%{?version_suffix}
%ifarch %{rust_arches}
%patch1 -p1 -b .toml_update
%autosetup -p1 -n thin-provisioning-tools-%{version}%{?version_suffix}
#%%cargo_prep
#%%cargo_generate_buildrequires
tar xf %{SOURCE1}
@ -53,10 +48,6 @@ replace-with = "vendored-sources"
directory = "vendor"
END
%endif
#%%patch0 -p1 -b .avoid_strip
%patch2 -p1 -b .backup2
# NOTE: patch 15 is above at the rust setup
echo %{version}-%{release} > VERSION
%generate_buildrequires
@ -67,7 +58,9 @@ echo %{version}-%{release} > VERSION
%if %{with check}
%check
# FIXME: Reenable testing!
%cargo_test
#cargo test --test thin_shrink -- --nocapture --test-threads=1
%endif
%install
@ -94,10 +87,8 @@ make DESTDIR=%{buildroot} MANDIR=%{_mandir} install
%{_mandir}/man8/thin_restore.8.gz
%{_mandir}/man8/thin_rmap.8.gz
%{_mandir}/man8/thin_trim.8.gz
%ifarch %{rust_arches}
%{_mandir}/man8/thin_metadata_pack.8.gz
%{_mandir}/man8/thin_metadata_unpack.8.gz
%endif
%{_sbindir}/pdata_tools
%{_sbindir}/cache_check
%{_sbindir}/cache_dump
@ -118,16 +109,16 @@ make DESTDIR=%{buildroot} MANDIR=%{_mandir} install
%{_sbindir}/thin_restore
%{_sbindir}/thin_rmap
%{_sbindir}/thin_trim
%ifarch %{rust_arches}
%{_sbindir}/thin_metadata_pack
%{_sbindir}/thin_metadata_unpack
%endif
#% {_sbindir}/thin_show_duplicates
%changelog
* Wed Feb 22 2023 Marian Csontos <mcsontos@redhat.com> - 1.0.2-1
- Update to latest upstream release 1.0.2.
- Complete rewrite in rust.
* Fri Apr 28 2023 Marian Csontos <mcsontos@redhat.com> - 1.0.4-1
- Update to latest upstream release 1.0.4.
* Wed Mar 22 2023 Marian Csontos <mcsontos@redhat.com> - 1.0.3-1
- Update to latest upstream release 1.0.3.
* Sun Feb 05 2023 Fabio Valentini <decathorpe@gmail.com> - 0.9.0-10
- Rebuild for fixed frame pointer compiler flags in Rust RPM macros.

View File

@ -1,2 +1,2 @@
SHA512 (v1.0.2.tar.gz) = f5401631f0d10cb0fbd8e4b2979b38d2dc42621de558ffb23b2bcc12f1b7fead49ffa8b143af61227917edce9abc7b5a48c94036ae74c035a181661f82e80ed1
SHA512 (dmpd102-vendor.tar.gz) = bc50c456d2fea1ab4db21d30f66a967bee51b33b5f2435740551b6ad290f8286a14dbadb998b9913900aa71eb2a7ccd01c3e4618937fd67aa7fe8b4591039a15
SHA512 (v1.0.4.tar.gz) = a6700ea26dd24e8285d85e58f9016dccca071d21b20650f8a39e523e6f0394891e57615caaad4c16290961e170fe4ab4bec9ae38bc06dcc9ddac9114a0374034
SHA512 (dmpd104-vendor.tar.gz) = d14a10fdbe1535b64c1911878da1be8dce3ce5e89c66fc0648e2a9c3e5e27b4874a99eee17175bf88e2d0c7dfa68382ba6746de3563feb28d6e070beae394f65