Update dmpd to upstream version 1.0.9
Resolves: RHEL-19246
This commit is contained in:
parent
fb7da57375
commit
b0973dc39e
2
.gitignore
vendored
2
.gitignore
vendored
@ -45,3 +45,5 @@
|
||||
/dmpd105-vendor.tar.gz
|
||||
/v1.0.6.tar.gz
|
||||
/dmpd106-vendor.tar.gz
|
||||
/v1.0.9.tar.gz
|
||||
/dmpd109-vendor.tar.gz
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 732ff5861a1525944a927439d1c075ac269788ce Mon Sep 17 00:00:00 2001
|
||||
From 0d5347bd771e960294cd0c2f083d96448613ab9c Mon Sep 17 00:00:00 2001
|
||||
From: Marian Csontos <mcsontos@redhat.com>
|
||||
Date: Thu, 27 Jul 2023 11:37:01 +0200
|
||||
Subject: [PATCH] Tweak cargo.toml to work with vendor directory
|
||||
@ -7,24 +7,16 @@ Mock works offline, cargo would try to download the files from github.
|
||||
So cargo vendor has to be run first, and then change the Cargo.toml to
|
||||
make mock happy.
|
||||
---
|
||||
Cargo.toml | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
Cargo.toml | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Cargo.toml b/Cargo.toml
|
||||
index c2b496ac..562c40d3 100644
|
||||
index 500345a4..d4aa38a6 100644
|
||||
--- a/Cargo.toml
|
||||
+++ b/Cargo.toml
|
||||
@@ -11,6 +11,7 @@ anyhow = "1.0"
|
||||
base64 = "0.21"
|
||||
byteorder = "1.4"
|
||||
clap = { version = "4.3", default-features = false, features = ["std", "help", "usage", "error-context", "suggestions"] }
|
||||
+#crc32c = { git = "https://github.com/zowens/crc32c", branch = "master" }
|
||||
crc32c = "0.6"
|
||||
data-encoding = "2.4"
|
||||
exitcode = "1.1.2"
|
||||
@@ -27,7 +28,8 @@ quick-xml = "0.29"
|
||||
@@ -27,7 +27,8 @@ quick-xml = "0.29"
|
||||
rand = "0.8"
|
||||
rangemap = "1.3"
|
||||
rangemap = "1.4"
|
||||
roaring = "0.10"
|
||||
-rio = { git = "https://github.com/jthornber/rio", branch = "master", optional = true }
|
||||
+#rio = { git = "https://github.com/jthornber/rio", branch = "master", optional = true }
|
||||
@ -33,5 +25,5 @@ index c2b496ac..562c40d3 100644
|
||||
threadpool = "1.8"
|
||||
thiserror = "1.0"
|
||||
--
|
||||
2.41.0
|
||||
2.43.0
|
||||
|
||||
|
@ -9,13 +9,13 @@
|
||||
|
||||
Summary: Device-mapper Persistent Data Tools
|
||||
Name: device-mapper-persistent-data
|
||||
Version: 1.0.6
|
||||
Version: 1.0.9
|
||||
Release: 1%{?dist}%{?release_suffix}
|
||||
License: GPLv3+
|
||||
URL: https://github.com/jthornber/thin-provisioning-tools
|
||||
#Source0: https://github.com/jthornber/thin-provisioning-tools/archive/thin-provisioning-tools-%%{version}.tar.gz
|
||||
Source0: https://github.com/jthornber/thin-provisioning-tools/archive/v%{version}%{?version_suffix}.tar.gz
|
||||
Source1: dmpd106-vendor.tar.gz
|
||||
Source1: dmpd109-vendor.tar.gz
|
||||
Patch1: 0001-Tweak-cargo.toml-to-work-with-vendor-directory.patch
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
@ -54,7 +54,8 @@ echo %{version}-%{release} > VERSION
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
RUST_BACKTRACE=1 %cargo_test || true
|
||||
#RUST_BACKTRACE=1 %%cargo_test || true
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%install
|
||||
@ -108,6 +109,9 @@ make DESTDIR=%{buildroot} MANDIR=%{_mandir} install
|
||||
#% {_sbindir}/thin_show_duplicates
|
||||
|
||||
%changelog
|
||||
* Wed Dec 13 2023 Marian Csontos <mcsontos@redhat.com> - 1.0.9-1
|
||||
- Update to latest upstream release 1.0.9.
|
||||
|
||||
* Wed Aug 09 2023 Marian Csontos <mcsontos@redhat.com> - 1.0.6-1
|
||||
- Update to latest upstream release 1.0.6.
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (v1.0.6.tar.gz) = b6a778048315fa83b8ffae797a406facd2be1552516f96abd0da5d02892be73f27c54e4e0a674b2f0253aa6fcdac187fc40d7a455eddfb25bc30f55a5e435b00
|
||||
SHA512 (dmpd106-vendor.tar.gz) = df7d77c83e6c6d3843ea61a0f0bfd414d0eef404a21046f04bd56f764f20cb33b3807b1606cf9eb6e2ee3fd0d5311b3582defbcf61692f3d10c4cd70769625d1
|
||||
SHA512 (v1.0.9.tar.gz) = c7d137b82cce4286d43f49af039f8026d7d7746e96affebc82e8243173ba9a014e3b462fc4b55850067ecfbcc6113c49f009c1285e272a4d64455715d11a9da1
|
||||
SHA512 (dmpd109-vendor.tar.gz) = f2a581da80e4137c6ecab9237587ec42141fdfe8c1bfae2ab5b431b64c100ea6c65cfadbbdd10d665101364731d7c5e61780490b9cfd5231df3f463483890747
|
||||
|
Loading…
Reference in New Issue
Block a user