New upstream release v0.6.0.
This commit is contained in:
parent
bcbdabcaa4
commit
8579281e34
11
device-mapper-persistent-data-avoid-strip.patch
Normal file
11
device-mapper-persistent-data-avoid-strip.patch
Normal file
@ -0,0 +1,11 @@
|
||||
diff -purN thin-provisioning-tools-0.6.0.orig/Makefile.in thin-provisioning-tools-0.6.0.new/Makefile.in
|
||||
--- thin-provisioning-tools-0.6.0.orig/Makefile.in 2016-01-20 16:43:21.000000000 +0100
|
||||
+++ thin-provisioning-tools-0.6.0.new/Makefile.in 2016-01-20 17:26:11.943664295 +0100
|
||||
@@ -174,7 +174,6 @@ distclean: clean
|
||||
install: bin/pdata_tools
|
||||
$(INSTALL_DIR) $(BINDIR)
|
||||
$(INSTALL_PROGRAM) bin/pdata_tools $(BINDIR)
|
||||
- $(STRIP) $(BINDIR)/pdata_tools
|
||||
ln -s -f pdata_tools $(BINDIR)/cache_check
|
||||
ln -s -f pdata_tools $(BINDIR)/cache_dump
|
||||
ln -s -f pdata_tools $(BINDIR)/cache_metadata_size
|
@ -1,36 +0,0 @@
|
||||
VERSION | 2 +-
|
||||
caching/cache_check.cc | 7 ++++---
|
||||
2 files changed, 5 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/VERSION b/VERSION
|
||||
index cb0c939..7d85683 100644
|
||||
--- a/VERSION
|
||||
+++ b/VERSION
|
||||
@@ -1 +1 @@
|
||||
-0.5.2
|
||||
+0.5.4
|
||||
diff --git a/caching/cache_check.cc b/caching/cache_check.cc
|
||||
index 005159e..9bd34be 100644
|
||||
--- a/caching/cache_check.cc
|
||||
+++ b/caching/cache_check.cc
|
||||
@@ -220,7 +220,9 @@ namespace {
|
||||
write_superblock(bm, sb);
|
||||
}
|
||||
|
||||
- error_state metadata_check(block_manager<>::ptr bm, flags const &fs) {
|
||||
+ error_state metadata_check(string const &path, flags const &fs) {
|
||||
+ block_manager<>::ptr bm = open_bm(path, block_manager<>::READ_ONLY);
|
||||
+
|
||||
nested_output out(cerr, 2);
|
||||
if (fs.quiet_)
|
||||
out.disable();
|
||||
@@ -295,8 +297,7 @@ namespace {
|
||||
throw runtime_error(msg.str());
|
||||
}
|
||||
|
||||
- block_manager<>::ptr bm = open_bm(path, block_manager<>::READ_ONLY);
|
||||
- err = metadata_check(bm, fs);
|
||||
+ err = metadata_check(path, fs);
|
||||
|
||||
bool success = false;
|
||||
|
@ -12,6 +12,7 @@ Source0: https://github.com/jthornber/thin-provisioning-tools/archive/thin-provi
|
||||
# Source1: https://github.com/jthornber/thin-provisioning-tools/archive/v%{version}.tar.gz
|
||||
Patch0: device-mapper-persistent-data-document-clear-needs-check-flag.patch
|
||||
Patch1: device-mapper-persistent-data-add-era_restore-and-cache_metadata_size-man-pages.patch
|
||||
Patch2: device-mapper-persistent-data-avoid-strip.patch
|
||||
|
||||
BuildRequires: autoconf, expat-devel, libaio-devel, libstdc++-devel, boost-devel
|
||||
Requires: expat
|
||||
@ -28,6 +29,7 @@ snapshot eras
|
||||
%setup -q -n thin-provisioning-tools-%{version}
|
||||
%patch0 -p1 -b .clear_needs_check_flag
|
||||
%patch1 -p1 -b .man_pages
|
||||
%patch2 -p1 -b .avoid_strip
|
||||
echo %{version}-%{release} > VERSION
|
||||
|
||||
%build
|
||||
@ -52,6 +54,7 @@ make DESTDIR=%{buildroot} MANDIR=%{_mandir} install
|
||||
%{_mandir}/man8/thin_check.8.gz
|
||||
%{_mandir}/man8/thin_delta.8.gz
|
||||
%{_mandir}/man8/thin_dump.8.gz
|
||||
%{_mandir}/man8/thin_ls.8.gz
|
||||
%{_mandir}/man8/thin_metadata_size.8.gz
|
||||
%{_mandir}/man8/thin_restore.8.gz
|
||||
%{_mandir}/man8/thin_repair.8.gz
|
||||
@ -70,6 +73,7 @@ make DESTDIR=%{buildroot} MANDIR=%{_mandir} install
|
||||
%{_sbindir}/thin_check
|
||||
%{_sbindir}/thin_delta
|
||||
%{_sbindir}/thin_dump
|
||||
%{_sbindir}/thin_ls
|
||||
%{_sbindir}/thin_metadata_size
|
||||
%{_sbindir}/thin_restore
|
||||
%{_sbindir}/thin_repair
|
||||
|
Loading…
Reference in New Issue
Block a user