parent
85c2481314
commit
36c78f225a
42
0001-all-Fix-resource-leaks.patch
Normal file
42
0001-all-Fix-resource-leaks.patch
Normal file
@ -0,0 +1,42 @@
|
||||
From 48676b9f1aac63f8a30ed8061b6e719929b82c98 Mon Sep 17 00:00:00 2001
|
||||
From: Ming-Hung Tsai <mtsai@redhat.com>
|
||||
Date: Wed, 28 Apr 2021 10:34:16 +0800
|
||||
Subject: [PATCH 01/10] [all] Fix resource leaks
|
||||
|
||||
---
|
||||
base/file_utils.cc | 4 +++-
|
||||
thin-provisioning/cache_stream.cc | 2 +-
|
||||
2 files changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/base/file_utils.cc b/base/file_utils.cc
|
||||
index e4f3722..8253660 100644
|
||||
--- a/base/file_utils.cc
|
||||
+++ b/base/file_utils.cc
|
||||
@@ -155,8 +155,10 @@ file_utils::zero_superblock(std::string const &path)
|
||||
throw runtime_error("out of memory");
|
||||
|
||||
memset(buffer, 0, SUPERBLOCK_SIZE);
|
||||
- if (::write(fd.fd_, buffer, SUPERBLOCK_SIZE) != SUPERBLOCK_SIZE)
|
||||
+ if (::write(fd.fd_, buffer, SUPERBLOCK_SIZE) != SUPERBLOCK_SIZE) {
|
||||
+ free(buffer);
|
||||
throw runtime_error("couldn't zero superblock");
|
||||
+ }
|
||||
}
|
||||
|
||||
//----------------------------------------------------------------
|
||||
diff --git a/thin-provisioning/cache_stream.cc b/thin-provisioning/cache_stream.cc
|
||||
index 002b6ba..73b01b4 100644
|
||||
--- a/thin-provisioning/cache_stream.cc
|
||||
+++ b/thin-provisioning/cache_stream.cc
|
||||
@@ -62,7 +62,7 @@ chunk const &
|
||||
cache_stream::get()
|
||||
{
|
||||
chunk_wrapper *w = new chunk_wrapper(*this);
|
||||
- return w->c_;
|
||||
+ return w->c_; // wrapper will get freed by the put method
|
||||
}
|
||||
|
||||
void
|
||||
--
|
||||
1.8.3.1
|
||||
|
26
0002-thin_show_metadata-Fix-out-of-bounds-access.patch
Normal file
26
0002-thin_show_metadata-Fix-out-of-bounds-access.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From 691a0237809b5364117446a8a9b0cceeb0a747c1 Mon Sep 17 00:00:00 2001
|
||||
From: Ming-Hung Tsai <mtsai@redhat.com>
|
||||
Date: Tue, 1 Jun 2021 11:24:11 +0800
|
||||
Subject: [PATCH 02/10] [thin_show_metadata] Fix out-of-bounds access
|
||||
|
||||
---
|
||||
thin-provisioning/thin_show_metadata.cc | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/thin-provisioning/thin_show_metadata.cc b/thin-provisioning/thin_show_metadata.cc
|
||||
index bdbab3f..dbc7a80 100644
|
||||
--- a/thin-provisioning/thin_show_metadata.cc
|
||||
+++ b/thin-provisioning/thin_show_metadata.cc
|
||||
@@ -206,7 +206,8 @@ namespace {
|
||||
|
||||
void run() {
|
||||
auto line_length = 80;
|
||||
- for (block_address b = 0; b < 2000; b++) {
|
||||
+ block_address nr_blocks = std::min<block_address>(2000, bm_.get_nr_blocks());
|
||||
+ for (block_address b = 0; b < nr_blocks; b++) {
|
||||
block_manager::read_ref rr = bm_.read_lock(b);
|
||||
|
||||
if (!(b % line_length)) {
|
||||
--
|
||||
1.8.3.1
|
||||
|
25
0003-build-Fix-customized-emitter-linkage.patch
Normal file
25
0003-build-Fix-customized-emitter-linkage.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From 65369d88610069ba7bbd011b00af19523638b0fb Mon Sep 17 00:00:00 2001
|
||||
From: Ming-Hung Tsai <mtsai@redhat.com>
|
||||
Date: Tue, 1 Jun 2021 13:32:26 +0800
|
||||
Subject: [PATCH 03/10] [build] Fix customized emitter linkage
|
||||
|
||||
---
|
||||
contrib/Makefile.in | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/contrib/Makefile.in b/contrib/Makefile.in
|
||||
index 038c41c..7192258 100644
|
||||
--- a/contrib/Makefile.in
|
||||
+++ b/contrib/Makefile.in
|
||||
@@ -18,7 +18,7 @@ contrib/%.a: contrib/%.o
|
||||
$(V)echo " [AR] $@"
|
||||
$(V)$(AR) rcs $@ $^
|
||||
|
||||
-contrib/%.so: contrib/%.a
|
||||
+contrib/%.so: contrib/%.o
|
||||
$(V)echo " [LD] $@"
|
||||
$(V)$(CC) -shared -Wl,-soname,$@ -o $@ $<
|
||||
|
||||
--
|
||||
1.8.3.1
|
||||
|
139
0004-thin_dump-Fix-leaked-shared-object-handle.patch
Normal file
139
0004-thin_dump-Fix-leaked-shared-object-handle.patch
Normal file
@ -0,0 +1,139 @@
|
||||
From 7fbd79cab2e548eb388bc782dd39f1cde027173b Mon Sep 17 00:00:00 2001
|
||||
From: Ming-Hung Tsai <mtsai@redhat.com>
|
||||
Date: Tue, 1 Jun 2021 23:37:36 +0800
|
||||
Subject: [PATCH 04/10] [thin_dump] Fix leaked shared object handle
|
||||
|
||||
---
|
||||
thin-provisioning/shared_library_emitter.cc | 113 ++++++++++++++++++++++++----
|
||||
1 file changed, 100 insertions(+), 13 deletions(-)
|
||||
|
||||
diff --git a/thin-provisioning/shared_library_emitter.cc b/thin-provisioning/shared_library_emitter.cc
|
||||
index 58f12d2..2e845f3 100644
|
||||
--- a/thin-provisioning/shared_library_emitter.cc
|
||||
+++ b/thin-provisioning/shared_library_emitter.cc
|
||||
@@ -8,22 +8,109 @@ using namespace thin_provisioning;
|
||||
|
||||
//----------------------------------------------------------------
|
||||
|
||||
-emitter::ptr
|
||||
-thin_provisioning::create_custom_emitter(string const &shared_lib, ostream &out)
|
||||
-{
|
||||
- emitter::ptr (*create_fn)(ostream &out);
|
||||
- void *handle = dlopen(shared_lib.c_str(), RTLD_LAZY);
|
||||
- if (!handle)
|
||||
- throw runtime_error(dlerror());
|
||||
+struct shared_object {
|
||||
+public:
|
||||
+ shared_object(const char *shared_lib) {
|
||||
+ handle_ = dlopen(shared_lib, RTLD_LAZY);
|
||||
+ if (!handle_)
|
||||
+ throw runtime_error(dlerror());
|
||||
+
|
||||
+ dlerror(); // Clear any existing error
|
||||
+ }
|
||||
+
|
||||
+ virtual ~shared_object() {
|
||||
+ dlclose(handle_);
|
||||
+ }
|
||||
+
|
||||
+ void *get_symbol(const char *symbol) {
|
||||
+ void *sym = dlsym(handle_, symbol);
|
||||
+
|
||||
+ char *error = dlerror();
|
||||
+ if (error)
|
||||
+ throw runtime_error(error);
|
||||
+
|
||||
+ return sym;
|
||||
+ }
|
||||
+
|
||||
+ void *handle_;
|
||||
+};
|
||||
+
|
||||
+class shared_emitter : public emitter {
|
||||
+public:
|
||||
+ shared_emitter(const char *shared_lib, ostream &out): sobj_(shared_lib) {
|
||||
+ emitter::ptr (*create_fn)(ostream &out);
|
||||
+ create_fn = reinterpret_cast<emitter::ptr (*)(ostream &)>(
|
||||
+ sobj_.get_symbol("create_emitter"));
|
||||
+ inner_ = create_fn(out);
|
||||
+ }
|
||||
+
|
||||
+ virtual ~shared_emitter() {
|
||||
+ }
|
||||
+
|
||||
+ void begin_superblock(std::string const &uuid,
|
||||
+ uint64_t time,
|
||||
+ uint64_t trans_id,
|
||||
+ boost::optional<uint32_t> flags,
|
||||
+ boost::optional<uint32_t> version,
|
||||
+ uint32_t data_block_size,
|
||||
+ uint64_t nr_data_blocks,
|
||||
+ boost::optional<uint64_t> metadata_snap) {
|
||||
+ inner_->begin_superblock(uuid,
|
||||
+ time,
|
||||
+ trans_id,
|
||||
+ flags,
|
||||
+ version,
|
||||
+ data_block_size,
|
||||
+ nr_data_blocks,
|
||||
+ metadata_snap);
|
||||
+ }
|
||||
|
||||
- dlerror(); // Clear any existing error
|
||||
- create_fn = reinterpret_cast<emitter::ptr (*)(ostream &)>(dlsym(handle, "create_emitter"));
|
||||
+ void end_superblock() {
|
||||
+ inner_->end_superblock();
|
||||
+ }
|
||||
|
||||
- char *error = dlerror();
|
||||
- if (error)
|
||||
- throw runtime_error(error);
|
||||
+ void begin_device(uint32_t dev_id,
|
||||
+ uint64_t mapped_blocks,
|
||||
+ uint64_t trans_id,
|
||||
+ uint64_t creation_time,
|
||||
+ uint64_t snap_time) {
|
||||
+ inner_->begin_device(dev_id, mapped_blocks, trans_id, creation_time, snap_time);
|
||||
+ }
|
||||
|
||||
- return create_fn(out);
|
||||
+ void end_device() {
|
||||
+ inner_->end_device();
|
||||
+ }
|
||||
+
|
||||
+ void begin_named_mapping(std::string const &name) {
|
||||
+ inner_->begin_named_mapping(name);
|
||||
+ }
|
||||
+
|
||||
+ void end_named_mapping() {
|
||||
+ inner_->end_named_mapping();
|
||||
+ }
|
||||
+
|
||||
+ void identifier(std::string const &name) {
|
||||
+ inner_->identifier(name);
|
||||
+ }
|
||||
+
|
||||
+ void range_map(uint64_t origin_begin, uint64_t data_begin, uint32_t time, uint64_t len) {
|
||||
+ inner_->range_map(origin_begin, data_begin, time, len);
|
||||
+ }
|
||||
+
|
||||
+ void single_map(uint64_t origin_block, uint64_t data_block, uint32_t time) {
|
||||
+ inner_->single_map(origin_block, data_block, time);
|
||||
+ }
|
||||
+
|
||||
+ shared_object sobj_;
|
||||
+ emitter::ptr inner_;
|
||||
+};
|
||||
+
|
||||
+//----------------------------------------------------------------
|
||||
+
|
||||
+emitter::ptr
|
||||
+thin_provisioning::create_custom_emitter(string const &shared_lib, ostream &out)
|
||||
+{
|
||||
+ return emitter::ptr(new shared_emitter(shared_lib.c_str(), out));
|
||||
}
|
||||
|
||||
//----------------------------------------------------------------
|
||||
--
|
||||
1.8.3.1
|
||||
|
52
0005-thin_show_duplicates-Fix-potential-errors.patch
Normal file
52
0005-thin_show_duplicates-Fix-potential-errors.patch
Normal file
@ -0,0 +1,52 @@
|
||||
From 32de33be68f3892698d492b9ab8f21f9186b3f4c Mon Sep 17 00:00:00 2001
|
||||
From: Ming-Hung Tsai <mtsai@redhat.com>
|
||||
Date: Wed, 2 Jun 2021 01:23:13 +0800
|
||||
Subject: [PATCH 05/10] [thin_show_duplicates] Fix potential errors
|
||||
|
||||
- Fix error if no --block-sector provided
|
||||
- Fix errors on pools without mappings, or zero-length file
|
||||
---
|
||||
thin-provisioning/thin_show_duplicates.cc | 8 ++++++--
|
||||
1 file changed, 6 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/thin-provisioning/thin_show_duplicates.cc b/thin-provisioning/thin_show_duplicates.cc
|
||||
index b1eebb7..f7354eb 100644
|
||||
--- a/thin-provisioning/thin_show_duplicates.cc
|
||||
+++ b/thin-provisioning/thin_show_duplicates.cc
|
||||
@@ -56,7 +56,7 @@ using namespace thin_provisioning;
|
||||
|
||||
namespace {
|
||||
bool factor_of(block_address f, block_address n) {
|
||||
- return (n % f) == 0;
|
||||
+ return f && (n % f) == 0;
|
||||
}
|
||||
|
||||
uint64_t parse_int(string const &str, string const &desc) {
|
||||
@@ -132,11 +132,15 @@ namespace {
|
||||
class duplicate_detector {
|
||||
public:
|
||||
void scan_with_variable_sized_chunks(chunk_stream &stream) {
|
||||
+ if (!stream.size())
|
||||
+ return;
|
||||
variable_chunk_stream vstream(stream, 4096);
|
||||
scan(vstream);
|
||||
}
|
||||
|
||||
void scan_with_fixed_sized_chunks(chunk_stream &stream, block_address chunk_size) {
|
||||
+ if (!stream.size())
|
||||
+ return;
|
||||
fixed_chunk_stream fstream(stream, chunk_size);
|
||||
scan(fstream);
|
||||
}
|
||||
@@ -222,7 +226,7 @@ namespace {
|
||||
if (fs.content_based_chunks)
|
||||
detector.scan_with_variable_sized_chunks(pstream);
|
||||
else {
|
||||
- if (*fs.block_size) {
|
||||
+ if (!!fs.block_size) {
|
||||
if (factor_of(*fs.block_size, block_size))
|
||||
block_size = *fs.block_size;
|
||||
else
|
||||
--
|
||||
1.8.3.1
|
||||
|
33
0006-thin_metadata_size-Fix-potential-string-overflow.patch
Normal file
33
0006-thin_metadata_size-Fix-potential-string-overflow.patch
Normal file
@ -0,0 +1,33 @@
|
||||
From 35e96e07c956a501cb8a12f5b873db173bb09179 Mon Sep 17 00:00:00 2001
|
||||
From: Ming-Hung Tsai <mtsai@redhat.com>
|
||||
Date: Wed, 2 Jun 2021 11:39:01 +0800
|
||||
Subject: [PATCH 06/10] [thin_metadata_size] Fix potential string overflow
|
||||
|
||||
---
|
||||
thin-provisioning/thin_metadata_size.cc | 10 +++++++---
|
||||
1 file changed, 7 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/thin-provisioning/thin_metadata_size.cc b/thin-provisioning/thin_metadata_size.cc
|
||||
index b6a5718..f14696c 100644
|
||||
--- a/thin-provisioning/thin_metadata_size.cc
|
||||
+++ b/thin-provisioning/thin_metadata_size.cc
|
||||
@@ -192,9 +192,13 @@ static void printf_aligned(struct global *g, char const *a, char const *b, char
|
||||
{
|
||||
char buf[80];
|
||||
|
||||
- strcpy(buf, b);
|
||||
- if (units)
|
||||
- strcat(buf, mandatory ? "{" :"["), strcat(buf, g->unit.chars), strcat(buf, mandatory ? "}" : "]");
|
||||
+ if (units) {
|
||||
+ char left_bracket = mandatory ? '{' : '[';
|
||||
+ char right_bracket = mandatory ? '}' : ']';
|
||||
+ snprintf(buf, 80, "%s%c%s%c", b, left_bracket, g->unit.chars, right_bracket);
|
||||
+ } else {
|
||||
+ snprintf(buf, 80, "%s", b);
|
||||
+ }
|
||||
|
||||
printf("\t%-4s%-44s%s\n", a, buf, c);
|
||||
}
|
||||
--
|
||||
1.8.3.1
|
||||
|
83
0007-all-Fix-uninitialized-class-members.patch
Normal file
83
0007-all-Fix-uninitialized-class-members.patch
Normal file
@ -0,0 +1,83 @@
|
||||
From f1e404c33ad14f6784aa1926ae75fa49e614748e Mon Sep 17 00:00:00 2001
|
||||
From: Ming-Hung Tsai <mtsai@redhat.com>
|
||||
Date: Wed, 2 Jun 2021 12:14:34 +0800
|
||||
Subject: [PATCH 07/10] [all] Fix uninitialized class members
|
||||
|
||||
---
|
||||
era/restore_emitter.cc | 1 +
|
||||
thin-provisioning/metadata_dumper.cc | 10 +++++++---
|
||||
thin-provisioning/thin_delta.cc | 4 +++-
|
||||
3 files changed, 11 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/era/restore_emitter.cc b/era/restore_emitter.cc
|
||||
index c09fa66..7fbac7d 100644
|
||||
--- a/era/restore_emitter.cc
|
||||
+++ b/era/restore_emitter.cc
|
||||
@@ -14,6 +14,7 @@ namespace {
|
||||
: md_(md),
|
||||
in_superblock_(false),
|
||||
in_writeset_(false),
|
||||
+ era_(0),
|
||||
in_era_array_(false) {
|
||||
}
|
||||
|
||||
diff --git a/thin-provisioning/metadata_dumper.cc b/thin-provisioning/metadata_dumper.cc
|
||||
index 4feb40f..665c762 100644
|
||||
--- a/thin-provisioning/metadata_dumper.cc
|
||||
+++ b/thin-provisioning/metadata_dumper.cc
|
||||
@@ -180,7 +180,7 @@ namespace {
|
||||
// This is about classifying and summarising btree nodes. The use of a btree
|
||||
// node may not be obvious when inspecting it in isolation. But more information
|
||||
// may be gleaned by examining child and sibling nodes.
|
||||
-//
|
||||
+//
|
||||
// So the process is:
|
||||
// - scan every metadata block, summarising it's potential uses.
|
||||
// - repeatedly iterate those summaries until we can glean no more useful information.
|
||||
@@ -474,7 +474,7 @@ namespace {
|
||||
node_info get_internal_info(block_manager::read_ref &rr) {
|
||||
node_info info;
|
||||
info.b = rr.get_location();
|
||||
-
|
||||
+
|
||||
// values refer to blocks, so we should have infos for them.
|
||||
auto n = to_node<block_traits>(rr);
|
||||
::uint64_t key_low = 0;
|
||||
@@ -524,7 +524,7 @@ namespace {
|
||||
node_info info;
|
||||
info.b = rr.get_location();
|
||||
|
||||
- auto vsize = to_cpu<uint32_t>(hdr.value_size);
|
||||
+ auto vsize = to_cpu<uint32_t>(hdr.value_size);
|
||||
info.values = to_cpu<uint32_t>(hdr.nr_entries);
|
||||
|
||||
if (vsize == sizeof(device_details_traits::disk_type)) {
|
||||
@@ -645,6 +645,10 @@ namespace {
|
||||
public:
|
||||
mapping_emit_visitor(emitter::ptr e)
|
||||
: e_(e),
|
||||
+ origin_start_(0),
|
||||
+ dest_start_(0),
|
||||
+ time_(0),
|
||||
+ len_(0),
|
||||
in_range_(false) {
|
||||
}
|
||||
|
||||
diff --git a/thin-provisioning/thin_delta.cc b/thin-provisioning/thin_delta.cc
|
||||
index 5b31608..ee48dea 100644
|
||||
--- a/thin-provisioning/thin_delta.cc
|
||||
+++ b/thin-provisioning/thin_delta.cc
|
||||
@@ -259,7 +259,9 @@ namespace local {
|
||||
class simple_emitter : public diff_emitter {
|
||||
public:
|
||||
simple_emitter(indented_stream &out)
|
||||
- : diff_emitter(out) {
|
||||
+ : diff_emitter(out),
|
||||
+ vbegin_(0),
|
||||
+ vend_(0) {
|
||||
}
|
||||
|
||||
void left_only(uint64_t vbegin, uint64_t dbegin, uint64_t len) {
|
||||
--
|
||||
1.8.3.1
|
||||
|
88
0008-thin_dump-Fix-warnings-on-potential-NULL-pointer.patch
Normal file
88
0008-thin_dump-Fix-warnings-on-potential-NULL-pointer.patch
Normal file
@ -0,0 +1,88 @@
|
||||
From 5d79a5c944d05f71425d3156597a2a61c5f2ab9a Mon Sep 17 00:00:00 2001
|
||||
From: Ming-Hung Tsai <mtsai@redhat.com>
|
||||
Date: Wed, 2 Jun 2021 13:08:47 +0800
|
||||
Subject: [PATCH 08/10] [thin_dump] Fix warnings on potential NULL pointer
|
||||
|
||||
---
|
||||
base/application.cc | 8 +++++++-
|
||||
base/application.h | 2 +-
|
||||
thin-provisioning/thin_dump.cc | 16 ++--------------
|
||||
3 files changed, 10 insertions(+), 16 deletions(-)
|
||||
|
||||
diff --git a/base/application.cc b/base/application.cc
|
||||
index 61338ff..dbd55a5 100644
|
||||
--- a/base/application.cc
|
||||
+++ b/base/application.cc
|
||||
@@ -25,8 +25,14 @@ command::die(string const &msg)
|
||||
}
|
||||
|
||||
::uint64_t
|
||||
-command::parse_uint64(string const &str, string const &desc)
|
||||
+command::parse_uint64(char const *str, char const *desc)
|
||||
{
|
||||
+ if (!str) {
|
||||
+ ostringstream out;
|
||||
+ out << "Couldn't parse " << desc << ": NULL";
|
||||
+ die(out.str());
|
||||
+ }
|
||||
+
|
||||
try {
|
||||
// FIXME: check trailing garbage is handled
|
||||
return lexical_cast<::uint64_t>(str);
|
||||
diff --git a/base/application.h b/base/application.h
|
||||
index b799eaf..f071533 100644
|
||||
--- a/base/application.h
|
||||
+++ b/base/application.h
|
||||
@@ -19,7 +19,7 @@ namespace base {
|
||||
virtual ~command() {}
|
||||
|
||||
void die(std::string const &msg);
|
||||
- uint64_t parse_uint64(std::string const &str, std::string const &desc);
|
||||
+ uint64_t parse_uint64(char const *str, char const *desc);
|
||||
|
||||
|
||||
virtual void usage(std::ostream &out) const = 0;
|
||||
diff --git a/thin-provisioning/thin_dump.cc b/thin-provisioning/thin_dump.cc
|
||||
index 74cfa91..c0e73e6 100644
|
||||
--- a/thin-provisioning/thin_dump.cc
|
||||
+++ b/thin-provisioning/thin_dump.cc
|
||||
@@ -143,7 +143,6 @@ thin_dump_cmd::run(int argc, char **argv)
|
||||
int c;
|
||||
char const *output = NULL;
|
||||
const char shortopts[] = "hm::o:f:rV";
|
||||
- char *end_ptr;
|
||||
block_address metadata_snap = 0;
|
||||
::uint64_t dev_id;
|
||||
struct flags flags;
|
||||
@@ -181,13 +180,7 @@ thin_dump_cmd::run(int argc, char **argv)
|
||||
flags.use_metadata_snap = true;
|
||||
if (optarg) {
|
||||
// FIXME: deprecate this option
|
||||
- metadata_snap = strtoull(optarg, &end_ptr, 10);
|
||||
- if (end_ptr == optarg) {
|
||||
- cerr << "couldn't parse <metadata-snap>" << endl;
|
||||
- usage(cerr);
|
||||
- return 1;
|
||||
- }
|
||||
-
|
||||
+ metadata_snap = parse_uint64(optarg, "metadata-snap");
|
||||
flags.snap_location = metadata_snap;
|
||||
}
|
||||
break;
|
||||
@@ -197,12 +190,7 @@ thin_dump_cmd::run(int argc, char **argv)
|
||||
break;
|
||||
|
||||
case 1:
|
||||
- dev_id = strtoull(optarg, &end_ptr, 10);
|
||||
- if (end_ptr == optarg) {
|
||||
- cerr << "couldn't parse <dev-id>\n";
|
||||
- usage(cerr);
|
||||
- return 1;
|
||||
- }
|
||||
+ dev_id = parse_uint64(optarg, "dev-id");
|
||||
flags.opts.select_dev(dev_id);
|
||||
break;
|
||||
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -0,0 +1,52 @@
|
||||
From 1c50c406ddda77f4c0b20e7bf3cc985e84526f51 Mon Sep 17 00:00:00 2001
|
||||
From: Ming-Hung Tsai <mtsai@redhat.com>
|
||||
Date: Wed, 2 Jun 2021 13:14:30 +0800
|
||||
Subject: [PATCH 09/10] [build] Remove unused sources from the regular build
|
||||
|
||||
---
|
||||
Makefile.in | 9 ++++-----
|
||||
1 file changed, 4 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/Makefile.in b/Makefile.in
|
||||
index b1fd4aa..9b13001 100644
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -96,10 +96,7 @@ SOURCE=\
|
||||
persistent-data/transaction_manager.cc \
|
||||
persistent-data/validators.cc \
|
||||
thin-provisioning/commands.cc \
|
||||
- thin-provisioning/cache_stream.cc \
|
||||
- thin-provisioning/chunk_stream.cc \
|
||||
thin-provisioning/device_tree.cc \
|
||||
- thin-provisioning/fixed_chunk_stream.cc \
|
||||
thin-provisioning/human_readable_format.cc \
|
||||
thin-provisioning/mapping_tree.cc \
|
||||
thin-provisioning/metadata.cc \
|
||||
@@ -107,7 +104,6 @@ SOURCE=\
|
||||
thin-provisioning/metadata_counter.cc \
|
||||
thin-provisioning/metadata_dumper.cc \
|
||||
thin-provisioning/override_emitter.cc \
|
||||
- thin-provisioning/pool_stream.cc \
|
||||
thin-provisioning/restore_emitter.cc \
|
||||
thin-provisioning/rmap_visitor.cc \
|
||||
thin-provisioning/superblock.cc \
|
||||
@@ -124,7 +120,11 @@ SOURCE=\
|
||||
thin-provisioning/xml_format.cc
|
||||
|
||||
DEVTOOLS_SOURCE=\
|
||||
+ thin-provisioning/cache_stream.cc \
|
||||
+ thin-provisioning/chunk_stream.cc \
|
||||
thin-provisioning/damage_generator.cc \
|
||||
+ thin-provisioning/fixed_chunk_stream.cc \
|
||||
+ thin-provisioning/pool_stream.cc \
|
||||
thin-provisioning/thin_journal.cc \
|
||||
thin-provisioning/thin_journal_check.cc \
|
||||
thin-provisioning/thin_ll_dump.cc \
|
||||
@@ -374,4 +374,3 @@ test: functional-test unit-test
|
||||
endif
|
||||
|
||||
-include $(DEPEND_FILES)
|
||||
-
|
||||
--
|
||||
1.8.3.1
|
||||
|
51
0010-all-Remove-unreachable-code.patch
Normal file
51
0010-all-Remove-unreachable-code.patch
Normal file
@ -0,0 +1,51 @@
|
||||
From 9e94a4349186f7353e0d7b536b46bfa4df2483d0 Mon Sep 17 00:00:00 2001
|
||||
From: Ming-Hung Tsai <mtsai@redhat.com>
|
||||
Date: Wed, 2 Jun 2021 14:59:29 +0800
|
||||
Subject: [PATCH 10/10] [all] Remove unreachable code
|
||||
|
||||
---
|
||||
block-cache/io_engine.cc | 3 ---
|
||||
caching/hint_array.cc | 6 ------
|
||||
2 files changed, 9 deletions(-)
|
||||
|
||||
diff --git a/block-cache/io_engine.cc b/block-cache/io_engine.cc
|
||||
index 2fe4082..0158723 100644
|
||||
--- a/block-cache/io_engine.cc
|
||||
+++ b/block-cache/io_engine.cc
|
||||
@@ -174,9 +174,6 @@ aio_engine::wait_(timespec *ts)
|
||||
cbs_.free(cb);
|
||||
return optional<wait_result>(make_pair(false, context));
|
||||
}
|
||||
-
|
||||
- // shouldn't get here
|
||||
- return optional<wait_result>(make_pair(false, 0));
|
||||
}
|
||||
|
||||
struct timespec
|
||||
diff --git a/caching/hint_array.cc b/caching/hint_array.cc
|
||||
index 6514968..e133c5c 100644
|
||||
--- a/caching/hint_array.cc
|
||||
+++ b/caching/hint_array.cc
|
||||
@@ -56,9 +56,6 @@ namespace {
|
||||
default:
|
||||
throw runtime_error("invalid hint width");
|
||||
}
|
||||
-
|
||||
- // never get here
|
||||
- return std::shared_ptr<array_base>();
|
||||
}
|
||||
|
||||
//--------------------------------
|
||||
@@ -93,9 +90,6 @@ namespace {
|
||||
default:
|
||||
throw runtime_error("invalid hint width");
|
||||
}
|
||||
-
|
||||
- // never get here
|
||||
- return std::shared_ptr<array_base>();
|
||||
}
|
||||
|
||||
//--------------------------------
|
||||
--
|
||||
1.8.3.1
|
||||
|
24
0011-file_utils-Fix-resource-leak.patch
Normal file
24
0011-file_utils-Fix-resource-leak.patch
Normal file
@ -0,0 +1,24 @@
|
||||
From 677fa789e4136dbdd589c1e65efc7cdaad7506ac Mon Sep 17 00:00:00 2001
|
||||
From: Ming-Hung Tsai <mtsai@redhat.com>
|
||||
Date: Fri, 4 Jun 2021 21:37:02 +0800
|
||||
Subject: [PATCH 1/2] [file_utils] Fix resource leak
|
||||
|
||||
---
|
||||
base/file_utils.cc | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/base/file_utils.cc b/base/file_utils.cc
|
||||
index 8253660..e6095f7 100644
|
||||
--- a/base/file_utils.cc
|
||||
+++ b/base/file_utils.cc
|
||||
@@ -159,6 +159,7 @@ file_utils::zero_superblock(std::string const &path)
|
||||
free(buffer);
|
||||
throw runtime_error("couldn't zero superblock");
|
||||
}
|
||||
+ free(buffer);
|
||||
}
|
||||
|
||||
//----------------------------------------------------------------
|
||||
--
|
||||
1.8.3.1
|
||||
|
224
0012-thin_delta-Clean-up-duplicated-code.patch
Normal file
224
0012-thin_delta-Clean-up-duplicated-code.patch
Normal file
@ -0,0 +1,224 @@
|
||||
From 2e755c67064c0157e646acfa57fbcc738905f7d4 Mon Sep 17 00:00:00 2001
|
||||
From: Ming-Hung Tsai <mtsai@redhat.com>
|
||||
Date: Tue, 20 Oct 2020 15:18:06 +0800
|
||||
Subject: [PATCH 2/2] [thin_delta] Clean up duplicated code
|
||||
|
||||
---
|
||||
thin-provisioning/thin_delta.cc | 105 ++++++++++++----------------------------
|
||||
1 file changed, 31 insertions(+), 74 deletions(-)
|
||||
|
||||
diff --git a/thin-provisioning/thin_delta.cc b/thin-provisioning/thin_delta.cc
|
||||
index ee48dea..2ff3e69 100644
|
||||
--- a/thin-provisioning/thin_delta.cc
|
||||
+++ b/thin-provisioning/thin_delta.cc
|
||||
@@ -22,47 +22,7 @@ using namespace thin_provisioning;
|
||||
|
||||
//----------------------------------------------------------------
|
||||
|
||||
-namespace local {
|
||||
- class application {
|
||||
- public:
|
||||
- application(string const &cmd)
|
||||
- : cmd_(cmd) {
|
||||
- }
|
||||
-
|
||||
- void usage(ostream &out) {
|
||||
- out << "Usage: " << cmd_ << " [options] <device or file>\n"
|
||||
- << "Options:\n"
|
||||
- << " {--thin1, --snap1}\n"
|
||||
- << " {--thin2, --snap2}\n"
|
||||
- << " {-m, --metadata-snap} [block#]\n"
|
||||
- << " {--verbose}\n"
|
||||
- << " {-h|--help}\n"
|
||||
- << " {-V|--version}" << endl;
|
||||
- }
|
||||
-
|
||||
- void die(string const &msg) {
|
||||
- cerr << msg << endl;
|
||||
- usage(cerr);
|
||||
- exit(1);
|
||||
- }
|
||||
-
|
||||
- uint64_t parse_int(string const &str, string const &desc) {
|
||||
- try {
|
||||
- return boost::lexical_cast<uint64_t>(str);
|
||||
-
|
||||
- } catch (...) {
|
||||
- ostringstream out;
|
||||
- out << "Couldn't parse " << desc << ": '" << str << "'";
|
||||
- die(out.str());
|
||||
- }
|
||||
-
|
||||
- return 0; // never get here
|
||||
- }
|
||||
-
|
||||
- private:
|
||||
- string cmd_;
|
||||
- };
|
||||
-
|
||||
+namespace {
|
||||
struct flags {
|
||||
flags()
|
||||
: verbose(false),
|
||||
@@ -96,13 +56,6 @@ namespace local {
|
||||
uint64_t vbegin_, dbegin_, len_;
|
||||
};
|
||||
|
||||
- ostream &operator <<(ostream &out, mapping const &m) {
|
||||
- out << "mapping[vbegin = " << m.vbegin_
|
||||
- << ", dbegin = " << m.dbegin_
|
||||
- << ", len = " << m.len_ << "]";
|
||||
- return out;
|
||||
- }
|
||||
-
|
||||
//--------------------------------
|
||||
|
||||
template <typename Container>
|
||||
@@ -542,7 +495,7 @@ namespace local {
|
||||
out << "</diff>\n";
|
||||
}
|
||||
|
||||
- void delta_(application &app, flags const &fs) {
|
||||
+ void delta_(flags const &fs) {
|
||||
mapping_recorder mr1;
|
||||
mapping_recorder mr2;
|
||||
damage_visitor damage_v;
|
||||
@@ -560,7 +513,7 @@ namespace local {
|
||||
if (!snap1_root) {
|
||||
ostringstream out;
|
||||
out << "Unable to find mapping tree for snap1 (" << *fs.snap1 << ")";
|
||||
- app.die(out.str());
|
||||
+ throw std::runtime_error(out.str());
|
||||
}
|
||||
|
||||
single_mapping_tree snap1(*md->tm_, *snap1_root,
|
||||
@@ -572,7 +525,7 @@ namespace local {
|
||||
if (!snap2_root) {
|
||||
ostringstream out;
|
||||
out << "Unable to find mapping tree for snap2 (" << *fs.snap2 << ")";
|
||||
- app.die(out.str());
|
||||
+ throw std::runtime_error(out.str());
|
||||
}
|
||||
|
||||
single_mapping_tree snap2(*md->tm_, *snap2_root,
|
||||
@@ -609,12 +562,12 @@ namespace local {
|
||||
end_superblock(is);
|
||||
}
|
||||
|
||||
- int delta(application &app, flags const &fs) {
|
||||
+ int delta(flags const &fs) {
|
||||
try {
|
||||
- delta_(app, fs);
|
||||
+ delta_(fs);
|
||||
} catch (exception const &e) {
|
||||
- app.die(e.what());
|
||||
- return 1; // never get here
|
||||
+ cerr << e.what() << endl;
|
||||
+ return 1;
|
||||
}
|
||||
|
||||
return 0;
|
||||
@@ -633,27 +586,31 @@ thin_delta_cmd::thin_delta_cmd()
|
||||
void
|
||||
thin_delta_cmd::usage(std::ostream &out) const
|
||||
{
|
||||
- // FIXME: finish
|
||||
+ out << "Usage: " << get_name() << " [options] <device or file>\n"
|
||||
+ << "Options:\n"
|
||||
+ << " {--thin1, --snap1}\n"
|
||||
+ << " {--thin2, --snap2}\n"
|
||||
+ << " {-m, --metadata-snap} [block#]\n"
|
||||
+ << " {--verbose}\n"
|
||||
+ << " {-h|--help}\n"
|
||||
+ << " {-V|--version}" << endl;
|
||||
}
|
||||
|
||||
int
|
||||
thin_delta_cmd::run(int argc, char **argv)
|
||||
{
|
||||
- using namespace local;
|
||||
-
|
||||
int c;
|
||||
flags fs;
|
||||
- local::application app(basename(argv[0]));
|
||||
|
||||
char const shortopts[] = "hVm::";
|
||||
option const longopts[] = {
|
||||
{ "help", no_argument, NULL, 'h' },
|
||||
+ { "metadata-snap", optional_argument, NULL, 'm' },
|
||||
{ "version", no_argument, NULL, 'V' },
|
||||
{ "thin1", required_argument, NULL, 1 },
|
||||
{ "snap1", required_argument, NULL, 1 },
|
||||
{ "thin2", required_argument, NULL, 2 },
|
||||
{ "snap2", required_argument, NULL, 2 },
|
||||
- { "metadata-snap", optional_argument, NULL, 'm' },
|
||||
{ "verbose", no_argument, NULL, 4 },
|
||||
{ NULL, no_argument, NULL, 0 }
|
||||
};
|
||||
@@ -661,25 +618,25 @@ thin_delta_cmd::run(int argc, char **argv)
|
||||
while ((c = getopt_long(argc, argv, shortopts, longopts, NULL)) != -1) {
|
||||
switch (c) {
|
||||
case 'h':
|
||||
- app.usage(cout);
|
||||
+ usage(cout);
|
||||
return 0;
|
||||
|
||||
+ case 'm':
|
||||
+ fs.use_metadata_snap = true;
|
||||
+ if (optarg)
|
||||
+ fs.metadata_snap = parse_uint64(optarg, "metadata snapshot block");
|
||||
+ break;
|
||||
+
|
||||
case 'V':
|
||||
cout << THIN_PROVISIONING_TOOLS_VERSION << endl;
|
||||
return 0;
|
||||
|
||||
case 1:
|
||||
- fs.snap1 = app.parse_int(optarg, "thin id 1");
|
||||
+ fs.snap1 = parse_uint64(optarg, "thin id 1");
|
||||
break;
|
||||
|
||||
case 2:
|
||||
- fs.snap2 = app.parse_int(optarg, "thin id 2");
|
||||
- break;
|
||||
-
|
||||
- case 'm':
|
||||
- fs.use_metadata_snap = true;
|
||||
- if (optarg)
|
||||
- fs.metadata_snap = app.parse_int(optarg, "metadata snapshot block");
|
||||
+ fs.snap2 = parse_uint64(optarg, "thin id 2");
|
||||
break;
|
||||
|
||||
case 4:
|
||||
@@ -687,23 +644,23 @@ thin_delta_cmd::run(int argc, char **argv)
|
||||
break;
|
||||
|
||||
default:
|
||||
- app.usage(cerr);
|
||||
+ usage(cerr);
|
||||
return 1;
|
||||
}
|
||||
}
|
||||
|
||||
if (argc == optind)
|
||||
- app.die("No input device provided.");
|
||||
+ die("No input device provided.");
|
||||
else
|
||||
fs.dev = argv[optind];
|
||||
|
||||
if (!fs.snap1)
|
||||
- app.die("--snap1 not specified.");
|
||||
+ die("--snap1 not specified.");
|
||||
|
||||
if (!fs.snap2)
|
||||
- app.die("--snap2 not specified.");
|
||||
+ die("--snap2 not specified.");
|
||||
|
||||
- return delta(app, fs);
|
||||
+ return delta(fs);
|
||||
}
|
||||
|
||||
//----------------------------------------------------------------
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -8,7 +8,7 @@
|
||||
Summary: Device-mapper Persistent Data Tools
|
||||
Name: device-mapper-persistent-data
|
||||
Version: 0.9.0
|
||||
Release: 4%{?dist}%{?release_suffix}
|
||||
Release: 5%{?dist}%{?release_suffix}
|
||||
License: GPLv3+
|
||||
URL: https://github.com/jthornber/thin-provisioning-tools
|
||||
#Source0: https://github.com/jthornber/thin-provisioning-tools/archive/thin-provisioning-tools-%%{version}.tar.gz
|
||||
@ -16,11 +16,28 @@ Source0: https://github.com/jthornber/thin-provisioning-tools/archive/v%{version
|
||||
Source1: dmpd090-vendor2.tar.gz
|
||||
Patch0: device-mapper-persistent-data-avoid-strip.patch
|
||||
Patch1: 0001-Update-dependencies.patch
|
||||
# BZ 1938705:
|
||||
Patch2: 0001-all-Fix-resource-leaks.patch
|
||||
Patch3: 0002-thin_show_metadata-Fix-out-of-bounds-access.patch
|
||||
Patch4: 0003-build-Fix-customized-emitter-linkage.patch
|
||||
Patch5: 0004-thin_dump-Fix-leaked-shared-object-handle.patch
|
||||
Patch6: 0005-thin_show_duplicates-Fix-potential-errors.patch
|
||||
Patch7: 0006-thin_metadata_size-Fix-potential-string-overflow.patch
|
||||
Patch8: 0007-all-Fix-uninitialized-class-members.patch
|
||||
Patch9: 0008-thin_dump-Fix-warnings-on-potential-NULL-pointer.patch
|
||||
Patch10: 0009-build-Remove-unused-sources-from-the-regular-build.patch
|
||||
Patch11: 0010-all-Remove-unreachable-code.patch
|
||||
Patch12: 0011-file_utils-Fix-resource-leak.patch
|
||||
Patch13: 0012-thin_delta-Clean-up-duplicated-code.patch
|
||||
|
||||
BuildRequires: autoconf, expat-devel, libaio-devel, libstdc++-devel, boost-devel, gcc-c++
|
||||
Requires: expat
|
||||
%ifarch %{rust_arches}
|
||||
%if 0%{?rhel}
|
||||
BuildRequires: rust-packaging
|
||||
%else
|
||||
BuildRequires: rust-packaging
|
||||
%endif
|
||||
BuildRequires: rust >= 1.35
|
||||
BuildRequires: cargo
|
||||
%endif
|
||||
@ -52,9 +69,25 @@ directory = "vendor"
|
||||
END
|
||||
%endif
|
||||
%patch0 -p1 -b .avoid_strip
|
||||
%patch2 -p1 -b .backup2
|
||||
%patch3 -p1 -b .backup3
|
||||
%patch4 -p1 -b .backup4
|
||||
%patch5 -p1 -b .backup5
|
||||
%patch6 -p1 -b .backup6
|
||||
%patch7 -p1 -b .backup7
|
||||
%patch8 -p1 -b .backup8
|
||||
%patch9 -p1 -b .backup9
|
||||
%patch10 -p1 -b .backup10
|
||||
%patch11 -p1 -b .backup11
|
||||
%patch12 -p1 -b .backup12
|
||||
%patch13 -p1 -b .backup13
|
||||
echo %{version}-%{release} > VERSION
|
||||
|
||||
%if 0%{?rhel}
|
||||
true
|
||||
%else
|
||||
%generate_buildrequires
|
||||
%endif
|
||||
|
||||
%build
|
||||
autoconf
|
||||
@ -124,6 +157,9 @@ make DESTDIR=%{buildroot} MANDIR=%{_mandir} install-rust-tools
|
||||
#% {_sbindir}/thin_show_duplicates
|
||||
|
||||
%changelog
|
||||
* Mon Jun 07 2021 Marian Csontos <mcsontos@redhat.com> - 0.9.0-5
|
||||
- Fix important issues found by static analysis.
|
||||
|
||||
* Thu Apr 15 2021 Mohan Boddu <mboddu@redhat.com> - 0.9.0-4
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user