d1207a7795
Updated to latest upstrem 0.4.9 code: multipath-tools-130222 (git commit id: 67b82ad6fe280caa1770025a6bb8110b633fa136) Refresh 0001-RH-dont_start_with_no_config.patch Modify 0002-RH-multipath.rules.patch Modify 0003-RH-Make-build-system-RH-Fedora-friendly.patch Refresh 0004-RH-multipathd-blacklist-all-by-default.patch Refresh 0005-RH-add-mpathconf.patch Refresh 0006-RH-add-find-multipaths.patch Add 0008-RH-revert-partition-changes.patch Rename 0008-RH-RHEL5-style-partitions.patch to 0009-RH-RHEL5-style-partitions.patch Rename 0009-RH-dont-remove-map-on-enomem.patch to 0010-RH-dont-remove-map-on-enomem.patch Rename 0010-RH-deprecate-uid-gid-mode.patch to 0011-RH-deprecate-uid-gid-mode.patch Rename 0013-RH-kpartx-msg.patch to 0012-RH-kpartx-msg.patch Rename 0035-RHBZ-883981-cleanup-rpmdiff-issues.patch to 0013-RHBZ-883981-cleanup-rpmdiff-issues.patch Rename 0039-RH-handle-other-sector-sizes.patch to 0014-RH-handle-other-sector-sizes.patch Rename 0040-RH-fix-output-buffer.patch to 0015-RH-fix-output-buffer.patch Add 0016-RH-dont-print-ghost-messages.patch Add 0017-RH-fix-sigusr1.patch * Actually this fixes a number of issues related to signals Rename 0018-RH-remove-config-dups.patch to 0018-RH-fix-factorize.patch * just the part that isn't upstream Add 0019-RH-fix-sockets.patch * makes abstract multipathd a cli sockets use the correct name. Set find_multipaths in the default config
110 lines
4.7 KiB
Diff
110 lines
4.7 KiB
Diff
From f5e11246063b07d6dce6d37d3b74662475baa981 Mon Sep 17 00:00:00 2001
|
|
From: Fabio M. Di Nitto <fdinitto@redhat.com>
|
|
Date: Thu, 15 Oct 2009 04:39:27 +0200
|
|
Subject: [PATCH 08/12] RH: Make build system RH/Fedora friendly
|
|
|
|
Signed-off-by: Fabio M. Di Nitto <fdinitto@redhat.com>
|
|
---
|
|
:100644 100644 7ec25d5... 06fb625... M Makefile.inc
|
|
:100644 100644 21e4ad4... 06d79c0... M kpartx/Makefile
|
|
:100644 100644 32d9ef5... 25e1483... M multipathd/Makefile
|
|
Makefile.inc | 2 +-
|
|
kpartx/Makefile | 10 +++++-----
|
|
libmpathpersist/Makefile | 7 ++-----
|
|
libmultipath/Makefile | 2 ++
|
|
multipathd/Makefile | 1 +
|
|
5 files changed, 11 insertions(+), 11 deletions(-)
|
|
|
|
Index: multipath-tools-130222/Makefile.inc
|
|
===================================================================
|
|
--- multipath-tools-130222.orig/Makefile.inc
|
|
+++ multipath-tools-130222/Makefile.inc
|
|
@@ -29,7 +29,7 @@ multipathdir = $(TOPDIR)/libmultipath
|
|
mandir = $(prefix)/usr/share/man/man8
|
|
man5dir = $(prefix)/usr/share/man/man5
|
|
man3dir = $(prefix)/usr/share/man/man3
|
|
-rcdir = $(prefix)/etc/init.d
|
|
+rcdir = $(prefix)/etc/rc.d/init.d
|
|
syslibdir = $(prefix)/$(LIB)
|
|
libdir = $(prefix)/$(LIB)/multipath
|
|
unitdir = $(prefix)/lib/systemd/system
|
|
Index: multipath-tools-130222/kpartx/Makefile
|
|
===================================================================
|
|
--- multipath-tools-130222.orig/kpartx/Makefile
|
|
+++ multipath-tools-130222/kpartx/Makefile
|
|
@@ -26,17 +26,17 @@ $(EXEC): $(OBJS)
|
|
install: $(EXEC) $(EXEC).8
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(bindir)
|
|
$(INSTALL_PROGRAM) -m 755 $(EXEC) $(DESTDIR)$(bindir)
|
|
- $(INSTALL_PROGRAM) -d $(DESTDIR)$(libudevdir)
|
|
- $(INSTALL_PROGRAM) -m 755 kpartx_id $(DESTDIR)$(libudevdir)
|
|
- $(INSTALL_PROGRAM) -d $(DESTDIR)/etc/udev/rules.d
|
|
- $(INSTALL_PROGRAM) -m 644 kpartx.rules $(DESTDIR)/etc/udev/rules.d/
|
|
+# $(INSTALL_PROGRAM) -d $(DESTDIR)$(libudevdir)
|
|
+# $(INSTALL_PROGRAM) -m 755 kpartx_id $(DESTDIR)$(libudevdir)
|
|
+# $(INSTALL_PROGRAM) -d $(DESTDIR)/etc/udev/rules.d
|
|
+# $(INSTALL_PROGRAM) -m 644 kpartx.rules $(DESTDIR)/etc/udev/rules.d/
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(mandir)
|
|
$(INSTALL_PROGRAM) -m 644 $(EXEC).8.gz $(DESTDIR)$(mandir)
|
|
|
|
uninstall:
|
|
rm -f $(DESTDIR)$(bindir)/$(EXEC)
|
|
rm -f $(DESTDIR)$(mandir)/$(EXEC).8.gz
|
|
- rm -f $(DESTDIR)$(libudevdir)/kpartx_id
|
|
+# rm -f $(DESTDIR)$(libudevdir)/kpartx_id
|
|
|
|
clean:
|
|
rm -f core *.o $(EXEC) *.gz
|
|
Index: multipath-tools-130222/multipathd/Makefile
|
|
===================================================================
|
|
--- multipath-tools-130222.orig/multipathd/Makefile
|
|
+++ multipath-tools-130222/multipathd/Makefile
|
|
@@ -35,6 +35,7 @@ install:
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(bindir)
|
|
$(INSTALL_PROGRAM) -m 755 $(EXEC) $(DESTDIR)$(bindir)
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(rcdir)
|
|
+ $(INSTALL_PROGRAM) -m 755 multipathd.init.redhat $(DESTDIR)$(rcdir)/$(EXEC)
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(unitdir)
|
|
$(INSTALL_PROGRAM) -m 644 $(EXEC).service $(DESTDIR)$(unitdir)
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(mandir)
|
|
Index: multipath-tools-130222/libmultipath/Makefile
|
|
===================================================================
|
|
--- multipath-tools-130222.orig/libmultipath/Makefile
|
|
+++ multipath-tools-130222/libmultipath/Makefile
|
|
@@ -46,9 +46,11 @@ install:
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(syslibdir)
|
|
$(INSTALL_PROGRAM) -m 755 $(LIBS) $(DESTDIR)$(syslibdir)/$(LIBS)
|
|
$(INSTALL_PROGRAM) -m 755 -d $(DESTDIR)$(libdir)
|
|
+ ln -sf $(LIBS) $(DESTDIR)$(syslibdir)/$(DEVLIB)
|
|
|
|
uninstall:
|
|
rm -f $(DESTDIR)$(syslibdir)/$(LIBS)
|
|
+ rm -f $(DESTDIR)$(syslibdir)/$(DEVLIB)
|
|
|
|
clean:
|
|
rm -f core *.a *.o *.gz *.so *.so.*
|
|
Index: multipath-tools-130222/libmpathpersist/Makefile
|
|
===================================================================
|
|
--- multipath-tools-130222.orig/libmpathpersist/Makefile
|
|
+++ multipath-tools-130222/libmpathpersist/Makefile
|
|
@@ -28,17 +28,14 @@ $(LIBS):
|
|
install: $(LIBS)
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(syslibdir)
|
|
$(INSTALL_PROGRAM) -m 755 $(LIBS) $(DESTDIR)$(syslibdir)/$(LIBS)
|
|
- $(INSTALL_PROGRAM) -m 755 -d $(DESTDIR)$(syslibdir)
|
|
$(INSTALL_PROGRAM) -m 755 -d $(DESTDIR)$(man3dir)
|
|
- $(INSTALL_PROGRAM) -m 755 -d $(DESTDIR)/usr/include/
|
|
- $(INSTALL_PROGRAM) -m 755 -d $(DESTDIR)/usr/share/doc/mpathpersist/
|
|
- ln -sf $(DESTDIR)$(syslibdir)/$(LIBS) $(DESTDIR)$(syslibdir)/$(DEVLIB)
|
|
+ ln -sf $(LIBS) $(DESTDIR)$(syslibdir)/$(DEVLIB)
|
|
install -m 644 mpath_persistent_reserve_in.3.gz $(DESTDIR)$(man3dir)
|
|
install -m 644 mpath_persistent_reserve_out.3.gz $(DESTDIR)$(man3dir)
|
|
- install -m 644 mpath_persist.h $(DESTDIR)/usr/include/
|
|
|
|
uninstall:
|
|
rm -f $(DESTDIR)$(syslibdir)/$(LIBS)
|
|
+ rm -f $(DESTDIR)$(syslibdir)/$(DEVLIB)
|
|
rm $(DESTDIR)$(mandir)/mpath_persistent_reserve_in.3.gz
|
|
rm $(DESTDIR)$(mandir)/mpath_persistent_reserve_out.3.gz
|
|
|