2b0cd7cceb
Rebased on top of Martin Wilck's queue of ACKed upstream commits * https://github.com/openSUSE/multipath-tools/tree/upstream-queue * All previous patches have been reordered, with the exception of 0011-libdmmp-Add-support-for-upcoming-json-c-0.14.0.patch which has been replaced with 0029-fix-boolean-value-with-json-c-0.14.patch Modify 0054-RH-add-mpathconf.patch * remove default enable_foreign and property blacklist_exceptions settings, and deal with the builtin default change from 0031-libmultipath-set-enable_foreign-to-NONE-by-default.patch. Fixes bz #1853668 Add 0048-Makefile.inc-trim-extra-information-from-systemd-ver.patch Add 0049-kpartx-fix-Wsign-compare-error.patch * The above two patches have been submitted upstream
84 lines
2.7 KiB
Diff
84 lines
2.7 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Martin Wilck <mwilck@suse.com>
|
|
Date: Tue, 12 May 2020 16:46:15 +0200
|
|
Subject: [PATCH] libmultipath: move libsg into libmultipath
|
|
|
|
sg_read() is called from readsector0 and emc_clariion. Move it
|
|
to libmultipath/, where all common code resides.
|
|
|
|
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
|
---
|
|
libmultipath/Makefile | 3 ++-
|
|
libmultipath/checkers/Makefile | 6 +++---
|
|
libmultipath/{checkers => }/libsg.c | 0
|
|
libmultipath/{checkers => }/libsg.h | 0
|
|
libmultipath/prioritizers/Makefile | 2 +-
|
|
5 files changed, 6 insertions(+), 5 deletions(-)
|
|
rename libmultipath/{checkers => }/libsg.c (100%)
|
|
rename libmultipath/{checkers => }/libsg.h (100%)
|
|
|
|
diff --git a/libmultipath/Makefile b/libmultipath/Makefile
|
|
index ad690a49..f19b7ad2 100644
|
|
--- a/libmultipath/Makefile
|
|
+++ b/libmultipath/Makefile
|
|
@@ -47,7 +47,8 @@ OBJS = memory.o parser.o vector.o devmapper.o callout.o \
|
|
switchgroup.o uxsock.o print.o alias.o log_pthread.o \
|
|
log.o configure.o structs_vec.o sysfs.o prio.o checkers.o \
|
|
lock.o file.o wwids.o prioritizers/alua_rtpg.o prkey.o \
|
|
- io_err_stat.o dm-generic.o generic.o foreign.o nvme-lib.o
|
|
+ io_err_stat.o dm-generic.o generic.o foreign.o nvme-lib.o \
|
|
+ libsg.o
|
|
|
|
all: $(LIBS)
|
|
|
|
diff --git a/libmultipath/checkers/Makefile b/libmultipath/checkers/Makefile
|
|
index 02caea64..01c04510 100644
|
|
--- a/libmultipath/checkers/Makefile
|
|
+++ b/libmultipath/checkers/Makefile
|
|
@@ -17,10 +17,10 @@ LIBS= \
|
|
|
|
all: $(LIBS)
|
|
|
|
-libcheckdirectio.so: libsg.o directio.o
|
|
+libcheckdirectio.so: directio.o
|
|
$(CC) $(LDFLAGS) $(SHARED_FLAGS) -o $@ $^ -laio
|
|
|
|
-libcheck%.so: libsg.o %.o
|
|
+libcheck%.so: %.o
|
|
$(CC) $(LDFLAGS) $(SHARED_FLAGS) -o $@ $^
|
|
|
|
install:
|
|
@@ -32,7 +32,7 @@ uninstall:
|
|
clean: dep_clean
|
|
$(RM) core *.a *.o *.gz *.so
|
|
|
|
-OBJS := $(LIBS:libcheck%.so=%.o) libsg.o directio.o
|
|
+OBJS := $(LIBS:libcheck%.so=%.o)
|
|
.SECONDARY: $(OBJS)
|
|
|
|
include $(wildcard $(OBJS:.o=.d))
|
|
diff --git a/libmultipath/checkers/libsg.c b/libmultipath/libsg.c
|
|
similarity index 100%
|
|
rename from libmultipath/checkers/libsg.c
|
|
rename to libmultipath/libsg.c
|
|
diff --git a/libmultipath/checkers/libsg.h b/libmultipath/libsg.h
|
|
similarity index 100%
|
|
rename from libmultipath/checkers/libsg.h
|
|
rename to libmultipath/libsg.h
|
|
diff --git a/libmultipath/prioritizers/Makefile b/libmultipath/prioritizers/Makefile
|
|
index 9d0fe03c..fc6e0e0c 100644
|
|
--- a/libmultipath/prioritizers/Makefile
|
|
+++ b/libmultipath/prioritizers/Makefile
|
|
@@ -28,7 +28,7 @@ endif
|
|
|
|
all: $(LIBS)
|
|
|
|
-libpriopath_latency.so: path_latency.o ../checkers/libsg.o
|
|
+libpriopath_latency.so: path_latency.o
|
|
$(CC) $(LDFLAGS) $(SHARED_FLAGS) -o $@ $^ -lm
|
|
|
|
libprio%.so: %.o
|
|
--
|
|
2.17.2
|
|
|