2b0cd7cceb
Rebased on top of Martin Wilck's queue of ACKed upstream commits * https://github.com/openSUSE/multipath-tools/tree/upstream-queue * All previous patches have been reordered, with the exception of 0011-libdmmp-Add-support-for-upcoming-json-c-0.14.0.patch which has been replaced with 0029-fix-boolean-value-with-json-c-0.14.patch Modify 0054-RH-add-mpathconf.patch * remove default enable_foreign and property blacklist_exceptions settings, and deal with the builtin default change from 0031-libmultipath-set-enable_foreign-to-NONE-by-default.patch. Fixes bz #1853668 Add 0048-Makefile.inc-trim-extra-information-from-systemd-ver.patch Add 0049-kpartx-fix-Wsign-compare-error.patch * The above two patches have been submitted upstream
33 lines
1.2 KiB
Diff
33 lines
1.2 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Martin Wilck <mwilck@suse.com>
|
|
Date: Mon, 11 May 2020 17:19:37 +0200
|
|
Subject: [PATCH] multipath-tools: Makefile.inc: set -Wno-error=clobbered
|
|
|
|
We need to ignore -Wclobbered because gcc has trouble dealing with glibc's
|
|
implementation of pthread_cleanup_push().
|
|
|
|
For some variants of gcc, -Wno-clobbered alone isn't enough if -Werror is also
|
|
set. Compilation with -Wno-error=clobbered works, though.
|
|
|
|
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
|
---
|
|
Makefile.inc | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile.inc b/Makefile.inc
|
|
index 671dd1ca..e7256e3a 100644
|
|
--- a/Makefile.inc
|
|
+++ b/Makefile.inc
|
|
@@ -91,7 +91,7 @@ TEST_CC_OPTION = $(shell \
|
|
|
|
STACKPROT := $(call TEST_CC_OPTION,-fstack-protector-strong,-fstack-protector)
|
|
ERROR_DISCARDED_QUALIFIERS := $(call TEST_CC_OPTION,-Werror=discarded-qualifiers,)
|
|
-WNOCLOBBERED := $(call TEST_CC_OPTION,-Wno-clobbered,)
|
|
+WNOCLOBBERED := $(call TEST_CC_OPTION,-Wno-clobbered -Wno-error=clobbered,)
|
|
|
|
OPTFLAGS := -O2 -g $(STACKPROT) --param=ssp-buffer-size=4
|
|
WARNFLAGS := -Werror -Wall -Wextra -Wformat=2 -Werror=implicit-int \
|
|
--
|
|
2.17.2
|
|
|