device-mapper-multipath/0010-RH-multipath-rules-udev-changes.patch
Benjamin Marzinski 814d7d2747 Refresh 0001-RH-queue-without-daemon.patch Refresh
0002-RH-path-checker.patch Modify
    0010-RH-multipath-rules-udev-changes.patch
Fix udev rules to use DM_SBIN_PATH when calling kpartx
install udev rules to /lib/udev/rules.d instead of /etc/udev/rules.d Modify
    0014-RH-add-hp_tur-checker.patch Add
    0003-for-upstream-default-configs.patch Add
    0016-RHBZ-554561-fix-init-error-msg.patch Add
    0017-RHBZ-554592-man-page-note.patch Add
    0018-RHBZ-554596-SUN-6540-config.patch Add
    0019-RHBZ-554598-fix-multipath-locking.patch Add
    0020-RHBZ-554605-fix-manual-failover.patch Add
    0021-RHBZ-548874-add-find-multipaths.patch
Added find_multipaths multipath.conf option
Added /sbin/mpathconf for simple editting of multipath.conf Add
    0022-RHBZ-557845-RHEL5-style-partitions.patch
Make kpartx deal with logical partitions like it did in RHEL5. Don't create
    a dm-device for the extended partition itself. Create the logical
    partitions on top of the dm-device for the whole disk.
2010-01-23 01:39:39 +00:00

59 lines
2.4 KiB
Diff

From 5a43356b54c2672441ce67cd9602904a5df04117 Mon Sep 17 00:00:00 2001
From: Fabio M. Di Nitto <fdinitto@redhat.com>
Date: Mon, 19 Oct 2009 07:07:01 +0200
Subject: [PATCH 10/12] RH: multipath rules + udev changes
Signed-off-by: Fabio M. Di Nitto <fdinitto@redhat.com>
---
:100644 100644 ac97749... 064196d... M multipath/multipath.rules
multipath/Makefile | 6 +++---
multipath/multipath.rules | 18 +++++++++++-------
2 files changed, 14 insertions(+), 10 deletions(-)
Index: multipath-tools/multipath/multipath.rules
===================================================================
--- multipath-tools.orig/multipath/multipath.rules
+++ multipath-tools/multipath/multipath.rules
@@ -1,7 +1,11 @@
-#
-# udev rules for multipathing.
-# The persistent symlinks are created with the kpartx rules
-#
-
-# socket for uevents
-SUBSYSTEM=="block", RUN+="socket:/org/kernel/dm/multipath_event"
+# multipath wants the devmaps presented as meaninglful device names
+# so name them after their devmap name
+SUBSYSTEM!="block", GOTO="end_mpath"
+RUN+="socket:/org/kernel/dm/multipath_event"
+KERNEL!="dm-*", GOTO="end_mpath"
+ACTION!="change", GOTO="end_mpath"
+ENV{DM_SUSPENDED}=="1", GOTO="end_mpath"
+ENV{DM_UUID}!="mpath-?*", GOTO="end_mpath"
+ENV{DM_ACTION}=="PATH_FAILED", GOTO="end_mpath"
+RUN+="$env{DM_SBIN_PATH}/kpartx -a -p p $tempnode"
+LABEL="end_mpath"
Index: multipath-tools/multipath/Makefile
===================================================================
--- multipath-tools.orig/multipath/Makefile
+++ multipath-tools/multipath/Makefile
@@ -21,15 +21,15 @@ $(EXEC): $(OBJS)
install:
$(INSTALL_PROGRAM) -d $(DESTDIR)$(bindir)
$(INSTALL_PROGRAM) -m 755 $(EXEC) $(DESTDIR)$(bindir)/
- $(INSTALL_PROGRAM) -d $(DESTDIR)/etc/udev/rules.d
- $(INSTALL_PROGRAM) -m 644 multipath.rules $(DESTDIR)/etc/udev/rules.d/
+ $(INSTALL_PROGRAM) -d $(DESTDIR)/lib/udev/rules.d
+ $(INSTALL_PROGRAM) -m 644 multipath.rules $(DESTDIR)/lib/udev/rules.d/40-multipath.rules
$(INSTALL_PROGRAM) -d $(DESTDIR)$(mandir)
$(INSTALL_PROGRAM) -m 644 $(EXEC).8.gz $(DESTDIR)$(mandir)
$(INSTALL_PROGRAM) -d $(DESTDIR)$(man5dir)
$(INSTALL_PROGRAM) -m 644 $(EXEC).conf.5.gz $(DESTDIR)$(man5dir)
uninstall:
- rm $(DESTDIR)/etc/udev/rules.d/multipath.rules
+ rm $(DESTDIR)/lib/udev/rules.d/multipath.rules
rm $(DESTDIR)$(bindir)/$(EXEC)
rm $(DESTDIR)$(mandir)/$(EXEC).8.gz
rm $(DESTDIR)$(man5dir)/$(EXEC).conf.5.gz