e5eddaae1a
Update to the head of the upstream staging branch Rename redhat patches * Previous patches 0001-0012 are now patches 0041-0052 Add 0053-RH-Add-mpathcleanup.patch * add mpathcleanup program
67 lines
2.6 KiB
Diff
67 lines
2.6 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Benjamin Marzinski <bmarzins@redhat.com>
|
|
Date: Thu, 13 Apr 2017 07:22:23 -0500
|
|
Subject: [PATCH] RH: fixup udev rules for redhat
|
|
|
|
The multipath rules need to run after scsi_id is run. This means moving
|
|
them after 60-persistent-storage.rules for redhat. Redhat also uses a
|
|
different naming scheme for partitions than SuSE.
|
|
|
|
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
|
---
|
|
Makefile.inc | 4 ++--
|
|
kpartx/kpartx.rules | 2 +-
|
|
multipath/Makefile | 4 ++--
|
|
3 files changed, 5 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/Makefile.inc b/Makefile.inc
|
|
index 04bfa56e..62d3d5cc 100644
|
|
--- a/Makefile.inc
|
|
+++ b/Makefile.inc
|
|
@@ -34,9 +34,9 @@ endif
|
|
# Paths. All these can be overridden on the "make" command line.
|
|
prefix :=
|
|
# Prefix for binaries
|
|
-exec_prefix := $(prefix)
|
|
+exec_prefix := $(prefix)/usr
|
|
# Prefix for non-essential libraries (libdmmp)
|
|
-usr_prefix := $(prefix)
|
|
+usr_prefix := $(prefix)/usr
|
|
# Prefix for configfuration files (multipath.conf)
|
|
etc_prefix := $(prefix)
|
|
# Where to install systemd-related files. systemd is usually installed under /usr
|
|
diff --git a/kpartx/kpartx.rules b/kpartx/kpartx.rules
|
|
index 1969dee0..d2b28233 100644
|
|
--- a/kpartx/kpartx.rules
|
|
+++ b/kpartx/kpartx.rules
|
|
@@ -39,6 +39,6 @@ LABEL="mpath_kpartx_end"
|
|
GOTO="kpartx_end"
|
|
|
|
LABEL="run_kpartx"
|
|
-RUN+="/sbin/kpartx -un -p -part /dev/$name"
|
|
+RUN+="/sbin/kpartx -un /dev/$name"
|
|
|
|
LABEL="kpartx_end"
|
|
diff --git a/multipath/Makefile b/multipath/Makefile
|
|
index 68cb5ce7..f70e64ec 100644
|
|
--- a/multipath/Makefile
|
|
+++ b/multipath/Makefile
|
|
@@ -26,7 +26,7 @@ install:
|
|
$(Q)$(INSTALL_PROGRAM) -m 755 $(EXEC) $(DESTDIR)$(bindir)/
|
|
$(Q)$(INSTALL_PROGRAM) -d $(DESTDIR)$(udevrulesdir)
|
|
$(Q)$(INSTALL_PROGRAM) -m 644 11-dm-mpath.rules $(DESTDIR)$(udevrulesdir)
|
|
- $(Q)$(INSTALL_PROGRAM) -m 644 multipath.rules $(DESTDIR)$(udevrulesdir)/56-multipath.rules
|
|
+ $(Q)$(INSTALL_PROGRAM) -m 644 multipath.rules $(DESTDIR)$(udevrulesdir)/62-multipath.rules
|
|
$(Q)$(INSTALL_PROGRAM) -d $(DESTDIR)$(modulesloaddir)
|
|
$(Q)$(INSTALL_PROGRAM) -m 644 modules-load.conf $(DESTDIR)$(modulesloaddir)/multipath.conf
|
|
$(Q)$(INSTALL_PROGRAM) -d $(DESTDIR)$(tmpfilesdir)
|
|
@@ -46,7 +46,7 @@ uninstall:
|
|
$(Q)$(RM) $(DESTDIR)$(udevrulesdir)/11-dm-mpath.rules
|
|
$(Q)$(RM) $(DESTDIR)$(modulesloaddir)/multipath.conf
|
|
$(Q)$(RM) $(DESTDIR)$(modulesloaddir)/scsi_dh.conf
|
|
- $(Q)$(RM) $(DESTDIR)$(libudevdir)/rules.d/56-multipath.rules
|
|
+ $(Q)$(RM) $(DESTDIR)$(libudevdir)/rules.d/62-multipath.rules
|
|
$(Q)$(RM) $(DESTDIR)$(mandir)/man8/$(EXEC).8
|
|
$(Q)$(RM) $(DESTDIR)$(mandir)/man5/$(EXEC).conf.5
|
|
$(Q)$(RM) $(DESTDIR)$(tmpfilesdir)/multipath.conf
|