2b0cd7cceb
Rebased on top of Martin Wilck's queue of ACKed upstream commits * https://github.com/openSUSE/multipath-tools/tree/upstream-queue * All previous patches have been reordered, with the exception of 0011-libdmmp-Add-support-for-upcoming-json-c-0.14.0.patch which has been replaced with 0029-fix-boolean-value-with-json-c-0.14.patch Modify 0054-RH-add-mpathconf.patch * remove default enable_foreign and property blacklist_exceptions settings, and deal with the builtin default change from 0031-libmultipath-set-enable_foreign-to-NONE-by-default.patch. Fixes bz #1853668 Add 0048-Makefile.inc-trim-extra-information-from-systemd-ver.patch Add 0049-kpartx-fix-Wsign-compare-error.patch * The above two patches have been submitted upstream
34 lines
1022 B
Diff
34 lines
1022 B
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Martin Wilck <mwilck@suse.com>
|
|
Date: Mon, 11 May 2020 16:00:04 +0200
|
|
Subject: [PATCH] multipath-tools: Makefile.inc: allow user settings for
|
|
LDFLAGS
|
|
|
|
This allows e.g. setting LDFLAGS="-m32 -Wl,-b,elf32-i386" to compile
|
|
for a 32bit target on a 64bit system.
|
|
|
|
Note that, like CFLAGS, the variable needs to be set in the environment,
|
|
not on the "make" command line.
|
|
|
|
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
|
---
|
|
Makefile.inc | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile.inc b/Makefile.inc
|
|
index 7a59db85..671dd1ca 100644
|
|
--- a/Makefile.inc
|
|
+++ b/Makefile.inc
|
|
@@ -104,7 +104,7 @@ CFLAGS := $(CFLAGS) $(OPTFLAGS) $(WARNFLAGS) -pipe \
|
|
BIN_CFLAGS = -fPIE -DPIE
|
|
LIB_CFLAGS = -fPIC
|
|
SHARED_FLAGS = -shared
|
|
-LDFLAGS = -Wl,-z,relro -Wl,-z,now
|
|
+LDFLAGS := $(LDFLAGS) -Wl,-z,relro -Wl,-z,now
|
|
BIN_LDFLAGS = -pie
|
|
|
|
# Check whether a function with name $1 has been declared in header file $2.
|
|
--
|
|
2.17.2
|
|
|