c80b4a3ee2
Update Source to upstream version 0.8.2 * Previoud patches 0001-0020 & 0031 are included in this commit Rename files * Previous patches 0021-0032 are now patches 0012-0022 Add 0001-libmultipath-assign-variable-to-make-gcc-happy.patch Add 0002-libmutipath-don-t-close-fd-on-dm_lib_release.patch Add 0003-libmultipath-allow-force-reload-with-no-active-paths.patch Add 0004-libmpathpersist-depend-on-libmultipath.patch Add 0005-multipath-tools-Makefile-more-dependency-fixes-for-p.patch Add 0006-multipath-tools-Makefile.inc-set-Wno-error-clobbered.patch Add 0007-libmultipath-discovery.c-use-z-qualifier-for-size_t.patch Add 0008-libmultipath-eliminate-more-signed-unsigned-comparis.patch Add 0009-libmultipath-set_uint-fix-parsing-for-32bit.patch Add 0010-multipath-tools-Makefile-add-install-dependency.patch Add 0012-libmultipath-fix-condlog-NULL-argument-in-uevent_get.patch Add 0023-RH-work-around-gcc-10-format-truncation-issue.patch * The above 10 patches have been submitted upstream
34 lines
1.2 KiB
Diff
34 lines
1.2 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Martin Wilck <mwilck@suse.com>
|
|
Date: Tue, 12 May 2020 00:39:24 +0200
|
|
Subject: [PATCH] multipath-tools: Makefile.inc: set -Wno-error=clobbered
|
|
|
|
We need to ignore -Wclobbered because gcc has trouble dealing with glibc's
|
|
implementation of pthread_cleanup_push().
|
|
|
|
For some variants of gcc, -Wno-clobbered alone isn't enough if -Werror is also
|
|
set. Compilation with -Wno-error=clobbered works, though.
|
|
|
|
Signed-off-by: Martin Wilck <mwilck@suse.com>
|
|
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
|
---
|
|
Makefile.inc | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile.inc b/Makefile.inc
|
|
index d4d1e0dd..9060ac9b 100644
|
|
--- a/Makefile.inc
|
|
+++ b/Makefile.inc
|
|
@@ -91,7 +91,7 @@ TEST_CC_OPTION = $(shell \
|
|
|
|
STACKPROT := $(call TEST_CC_OPTION,-fstack-protector-strong,-fstack-protector)
|
|
ERROR_DISCARDED_QUALIFIERS := $(call TEST_CC_OPTION,-Werror=discarded-qualifiers,)
|
|
-WNOCLOBBERED := $(call TEST_CC_OPTION,-Wno-clobbered,)
|
|
+WNOCLOBBERED := $(call TEST_CC_OPTION,-Wno-clobbered -Wno-error=clobbered,)
|
|
|
|
OPTFLAGS = -O2 -g -pipe -Werror -Wall -Wextra -Wformat=2 -Werror=implicit-int \
|
|
-Werror=implicit-function-declaration -Werror=format-security \
|
|
--
|
|
2.17.2
|
|
|