device-mapper-multipath/0015-RH-use-rpm-optflags-if-present.patch
Benjamin Marzinski c79ce3480d device-mapper-multipath-0.7.7-4.gitef6d98b
Update Source to latest upstream commit
  * Previous patches 0001-0018 are included in this commit
Rename files
  * Previous patches 0019-0028 are now patches 0002-0003 & 0012-0019
Add 0001-libmultipath-remove-last-of-rbd-code.patch
Add 0004-mpathpersist-add-param-alltgpt-option.patch
  * mpathpersist now accepts --param-alltgpt
Add 0005-libmutipath-remove-unused-IDE-bus-type.patch
Add 0006-multipathd-add-new-protocol-path-wildcard.patch
  * multipathd show paths format now accepts %P for the path
  * protocol/transport
Add 0007-libmultipath-add-protocol-blacklist-option.patch
  * You can now use the "protocol" blacklist section parameter to
  * blacklist
    by protocol/transport
Add 0008-libmultipath-remove-_filter_-blacklist-functions.patch
Add 0009-multipath-tests-change-to-work-with-old-make-version.patch
Add 0010-multipath-tests-add-blacklist-tests.patch
Add 0011-mpathpersist-add-missing-param-rk-usage-info.patch
Refresh 0013-RH-Remove-the-property-blacklist-exception-builtin.patch
Modify 0016-RH-add-mpathconf.patch
  * improve usage message and man page
2018-07-17 14:55:00 -05:00

53 lines
1.9 KiB
Diff

From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: Benjamin Marzinski <bmarzins@redhat.com>
Date: Wed, 19 Apr 2017 06:10:01 -0500
Subject: [PATCH] RH: use rpm optflags if present
Use the passed in optflags when compiling as an RPM, and keep the
default flags as close as possible to the current fedora flags, while
still being generic.
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
---
Makefile.inc | 24 ++++++++++++++++--------
1 file changed, 16 insertions(+), 8 deletions(-)
diff --git a/Makefile.inc b/Makefile.inc
index 0b271ea..5ff69a3 100644
--- a/Makefile.inc
+++ b/Makefile.inc
@@ -85,14 +85,22 @@ TEST_CC_OPTION = $(shell \
echo "$(2)"; \
fi)
-STACKPROT := $(call TEST_CC_OPTION,-fstack-protector-strong,-fstack-protector)
-
-OPTFLAGS = -O2 -g -pipe -Wall -Wextra -Wformat=2 -Werror=implicit-int \
- -Werror=implicit-function-declaration -Werror=format-security \
- -Wno-sign-compare -Wno-unused-parameter -Wno-clobbered \
- -Werror=cast-qual -Werror=discarded-qualifiers \
- -Wp,-D_FORTIFY_SOURCE=2 $(STACKPROT) \
- --param=ssp-buffer-size=4
+ifndef RPM_OPT_FLAGS
+ STACKPROT := $(call TEST_CC_OPTION,-fstack-protector-strong,-fstack-protector)
+ OPTFLAGS = -O2 -g -pipe -Wall -Werror=format-security \
+ -Wp,-D_FORTIFY_SOURCE=2 -fexceptions \
+ $(STACKPROT) --param=ssp-buffer-size=4 \
+ -grecord-gcc-switches
+ ifeq ($(shell test -f /usr/lib/rpm/redhat/redhat-hardened-cc1 && echo 1),1)
+ OPTFLAGS += -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1
+ endif
+else
+ OPTFLAGS = $(RPM_OPT_FLAGS)
+endif
+OPTFLAGS += -Wextra -Wstrict-prototypes -Wformat=2 -Werror=implicit-int \
+ -Werror=implicit-function-declaration -Wno-sign-compare \
+ -Wno-unused-parameter -Werror=cast-qual \
+ -Werror=discarded-qualifiers
CFLAGS := $(OPTFLAGS) -DBIN_DIR=\"$(bindir)\" -DLIB_STRING=\"${LIB}\" -DRUN_DIR=\"${RUN}\" \
-MMD -MP $(CFLAGS)
--
2.7.4