device-mapper-multipath/0006-multipath-tools-Makefile.inc-more-compact-code-for-L.patch
Benjamin Marzinski c5432960d9 device-mapper-multipath-0.9.3-1
Update to the head of the upstream staging branch
  * Previous patches 0001-0042 are included in the source tarball
  * Patches 0001-0032 are from the upstream staging branch
Rename redhat patches
  * Previous patches 0043-0053 are now patches 0033-0043
Change back to using readline instead of libedit
  * The code the uses readline has been isolated from the code that
    is licensed gpl v2 only.
Add libmpathutil libraries to spec file
Add multipathc program to spec file
Add multipath.conf systemd tempfile configuration to spec file
Misc spec file cleanups
2022-11-16 14:11:59 -06:00

39 lines
1.2 KiB
Diff

From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: Martin Wilck <mwilck@suse.com>
Date: Thu, 27 Oct 2022 16:14:22 +0200
Subject: [PATCH] multipath-tools: Makefile.inc: more compact code for LIB
Use make's "if" function instead of a conditional.
Signed-off-by: Martin Wilck <mwilck@suse.com>
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
---
Makefile.inc | 7 +------
1 file changed, 1 insertion(+), 6 deletions(-)
diff --git a/Makefile.inc b/Makefile.inc
index b4ec647c..c39cec9b 100644
--- a/Makefile.inc
+++ b/Makefile.inc
@@ -28,12 +28,6 @@ ifeq ($(TOPDIR),)
TOPDIR = ..
endif
-ifeq ($(shell test -d /lib64 && echo 1),1)
- LIB=lib64
-else
- LIB=lib
-endif
-
ifeq ($(shell $(PKGCONFIG) --modversion libsystemd >/dev/null 2>&1 && echo 1), 1)
SYSTEMD = $(shell $(PKGCONFIG) --modversion libsystemd | awk '{print $$1}')
else
@@ -80,6 +74,7 @@ mpathutildir = $(TOPDIR)/libmpathutil
man8dir = $(usr_prefix)/share/man/man8
man5dir = $(usr_prefix)/share/man/man5
man3dir = $(usr_prefix)/share/man/man3
+LIB := $(if $(shell test -d /lib64 && echo 1),lib64,lib)
syslibdir = $(prefix)/$(LIB)
usrlibdir = $(usr_prefix)/$(LIB)
libdir = $(prefix)/$(LIB)/multipath