5bea53fe7e
Update Source to the latest upstream commit * Previous patches 0001-0006 are included in this commit * Previous patches 0007-0014 are now patches 0015-0022 Add 0001-libmultipath-fix-tur-checker-locking.patch * Fixed spinlock bug. posted upstream Add 0002-multipath-fix-DEF_TIMEOUT-use.patch * Add missing sec to ms conversion. posted upstream Add 0003-multipathd-remove-coalesce_paths-from-ev_add_map.patch * Remove unused code. posted upstream Add 0004-multipathd-remove-unused-configure-parameter.patch * Remove unused code. posted upstream Add 0005-Fix-set_no_path_retry-regression.patch * Fix issue with queueing and path addition. posted upstream Add 0006-multipathd-change-spurious-uevent-msg-priority.patch * Change message priority to Notice. posted upstream Add 0007-multipath-print-sysfs-state-in-fast-list-mode.patch * Show sysfs state correctly in fast list mode (-l). posted upstream Add 0008-libmultipath-move-remove_map-waiter-code-to-multipat.patch * Move code around. posted upstream Add 0009-move-waiter-code-from-libmultipath-to-multipathd.patch * Move code around. posted upstream Add 0010-call-start_waiter_thread-before-setup_multipath.patch * Fix race on multipath device creations. posted upstream Add 0011-libmultipath-add-helper-functions.patch * posted upstream Add 0012-multipathd-RFC-add-new-polling-dmevents-waiter-threa.patch * Add alternate method of getting dmevents, that doesn't require a thread per device. posted upstream Add 0013-libmultipath-condlog-log-to-stderr.patch * change condlog to log to stderr instead of stdout. posted upstream Add 0014-multipathd-fix-compiler-warning-for-uev_pathfail_che.patch * fix indentation issue. posted upstream
67 lines
2.3 KiB
Diff
67 lines
2.3 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Benjamin Marzinski <bmarzins@redhat.com>
|
|
Date: Thu, 13 Apr 2017 07:22:23 -0500
|
|
Subject: [PATCH] RH: fixup udev rules for redhat
|
|
|
|
The multipath rules need to run after scsi_id is run. This means moving
|
|
them after 60-persistent-storage.rules for redhat. Redhat also uses a
|
|
different naming scheme for partitions than SuSE.
|
|
|
|
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
|
---
|
|
Makefile.inc | 2 +-
|
|
kpartx/kpartx.rules | 2 +-
|
|
multipath/Makefile | 4 ++--
|
|
3 files changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/Makefile.inc b/Makefile.inc
|
|
index d953f5e..5145909 100644
|
|
--- a/Makefile.inc
|
|
+++ b/Makefile.inc
|
|
@@ -48,7 +48,7 @@ endif
|
|
prefix =
|
|
exec_prefix = $(prefix)
|
|
usr_prefix = $(prefix)
|
|
-bindir = $(exec_prefix)/sbin
|
|
+bindir = $(exec_prefix)/usr/sbin
|
|
libudevdir = $(prefix)/$(SYSTEMDPATH)/udev
|
|
udevrulesdir = $(libudevdir)/rules.d
|
|
multipathdir = $(TOPDIR)/libmultipath
|
|
diff --git a/kpartx/kpartx.rules b/kpartx/kpartx.rules
|
|
index 8f99049..8a3a171 100644
|
|
--- a/kpartx/kpartx.rules
|
|
+++ b/kpartx/kpartx.rules
|
|
@@ -32,6 +32,6 @@ LABEL="mpath_kpartx_end"
|
|
GOTO="kpartx_end"
|
|
|
|
LABEL="run_kpartx"
|
|
-RUN+="/sbin/kpartx -un -p -part /dev/$name"
|
|
+RUN+="/sbin/kpartx -un /dev/$name"
|
|
|
|
LABEL="kpartx_end"
|
|
diff --git a/multipath/Makefile b/multipath/Makefile
|
|
index 468c056..dda5565 100644
|
|
--- a/multipath/Makefile
|
|
+++ b/multipath/Makefile
|
|
@@ -24,7 +24,7 @@ install:
|
|
$(INSTALL_PROGRAM) -m 755 $(EXEC) $(DESTDIR)$(bindir)/
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(udevrulesdir)
|
|
$(INSTALL_PROGRAM) -m 644 11-dm-mpath.rules $(DESTDIR)$(udevrulesdir)
|
|
- $(INSTALL_PROGRAM) -m 644 $(EXEC).rules $(DESTDIR)$(libudevdir)/rules.d/56-multipath.rules
|
|
+ $(INSTALL_PROGRAM) -m 644 $(EXEC).rules $(DESTDIR)$(libudevdir)/rules.d/62-multipath.rules
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(man8dir)
|
|
$(INSTALL_PROGRAM) -m 644 $(EXEC).8.gz $(DESTDIR)$(man8dir)
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(man5dir)
|
|
@@ -33,7 +33,7 @@ install:
|
|
uninstall:
|
|
$(RM) $(DESTDIR)$(bindir)/$(EXEC)
|
|
$(RM) $(DESTDIR)$(udevrulesdir)/11-dm-mpath.rules
|
|
- $(RM) $(DESTDIR)$(libudevdir)/rules.d/56-multipath.rules
|
|
+ $(RM) $(DESTDIR)$(libudevdir)/rules.d/62-multipath.rules
|
|
$(RM) $(DESTDIR)$(man8dir)/$(EXEC).8.gz
|
|
$(RM) $(DESTDIR)$(man5dir)/$(EXEC).conf.5.gz
|
|
|
|
--
|
|
2.7.4
|
|
|