b05147c356
Change patch format to remove Git version * Patches 0001-0122 only have the patch format modified Update to the head of the upstream staging branch plus redhat patches * Patches 0123-0134 & 1036-0142 are from the upstream staging branch * Patches 0143-1046 have been submitted upstream * Patch 0156 is a Red Hat only patch. Red Hat udev rules set ID_SERIAL from 60-persistent-storage.rules instead of 55-scsi-sg3_id.rules. Multipath's parse_vpd_pg83() function needs to match the ID_SERIAL value from udev. Rename files * Previous patches 0123-0132 are now patches 1035 & 0147-0155
28 lines
951 B
Diff
28 lines
951 B
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Martin Wilck <mwilck@suse.com>
|
|
Date: Fri, 18 Dec 2020 23:11:47 +0100
|
|
Subject: [PATCH] multipath-tools tests: unversioned .so for valgrind tests
|
|
|
|
We need to the same thing for valgrind tests as we did in
|
|
448752f ("libmultipath: create separate .so for unit tests").
|
|
|
|
Reviewed-by: Benjamin Marzinski <bmarzins@redhat.com>
|
|
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
|
---
|
|
tests/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/tests/Makefile b/tests/Makefile
|
|
index 54da774e..50673fae 100644
|
|
--- a/tests/Makefile
|
|
+++ b/tests/Makefile
|
|
@@ -76,7 +76,7 @@ lib/libchecktur.so:
|
|
|
|
%.vgr: %-test lib/libchecktur.so
|
|
@echo == running valgrind for $< ==
|
|
- @LD_LIBRARY_PATH=$(multipathdir):$(mpathcmddir) \
|
|
+ @LD_LIBRARY_PATH=.:$(mpathcmddir) \
|
|
valgrind --leak-check=full --error-exitcode=128 ./$< >$@ 2>&1
|
|
|
|
OBJS = $(TESTS:%=%.o) $(HELPERS)
|