765b685946
statically link against it. Fixed an error with binding file and WWIDs that include spaces. Cleaned up the messages from the directio checker function. Fixed the udev rules. Fixed a regression in multipath.conf parsing Fixed 457530, 457589
69 lines
2.1 KiB
Diff
69 lines
2.1 KiB
Diff
Index: multipath-tools/libmultipath/Makefile
|
|
===================================================================
|
|
--- multipath-tools.orig/libmultipath/Makefile
|
|
+++ multipath-tools/libmultipath/Makefile
|
|
@@ -23,14 +23,15 @@ endif
|
|
all: $(LIBS)
|
|
|
|
$(LIBS): $(OBJS)
|
|
- $(CC) $(SHARED_FLAGS) $(CFLAGS) -o $@ $(OBJS)
|
|
+ $(CC) $(SHARED_FLAGS) -Wl,-soname,$@ $(CFLAGS) -o $@ $(OBJS)
|
|
|
|
install:
|
|
+ $(INSTALL_PROGRAM) -d $(DESTDIR)$(prefix)/lib
|
|
+ $(INSTALL_PROGRAM) -m 755 $(LIBS) $(DESTDIR)$(prefix)/lib/$(LIBS)
|
|
$(INSTALL_PROGRAM) -m 755 -d $(DESTDIR)$(libdir)
|
|
- $(INSTALL_PROGRAM) -m 755 $(LIBS) $(DESTDIR)$(libdir)/$(LIBS)
|
|
|
|
uninstall:
|
|
- rm -f $(DESTDIR)$(libdir)/$(LIBS)
|
|
+ rm -f $(DESTDIR)$(prefix)/lib/$(LIBS)
|
|
|
|
clean:
|
|
rm -f core *.a *.o *.gz *.so
|
|
Index: multipath-tools/multipath/Makefile
|
|
===================================================================
|
|
--- multipath-tools.orig/multipath/Makefile
|
|
+++ multipath-tools/multipath/Makefile
|
|
@@ -6,9 +6,8 @@ include ../Makefile.inc
|
|
|
|
OBJS = main.o
|
|
|
|
-CFLAGS += -I$(multipathdir) -Wl,-rpath,$(libdir)
|
|
-LDFLAGS += -lpthread -ldevmapper -laio -ldl \
|
|
- -lmultipath -L$(multipathdir)
|
|
+CFLAGS += -I$(multipathdir)
|
|
+LDFLAGS += -lpthread -ldevmapper -ldl -lmultipath -L$(multipathdir)
|
|
|
|
EXEC = multipath
|
|
|
|
Index: multipath-tools/multipathd/Makefile
|
|
===================================================================
|
|
--- multipath-tools.orig/multipathd/Makefile
|
|
+++ multipath-tools/multipathd/Makefile
|
|
@@ -5,8 +5,8 @@ include ../Makefile.inc
|
|
#
|
|
# basic flags setting
|
|
#
|
|
-CFLAGS += -I$(multipathdir) -Wl,-rpath,$(libdir)
|
|
-LDFLAGS += -lpthread -ldevmapper -lreadline -lncurses -laio -ldl \
|
|
+CFLAGS += -I$(multipathdir)
|
|
+LDFLAGS += -lpthread -ldevmapper -lreadline -lncurses -ldl \
|
|
-lmultipath -L$(multipathdir)
|
|
|
|
#
|
|
Index: multipath-tools/libmultipath/checkers/Makefile
|
|
===================================================================
|
|
--- multipath-tools.orig/libmultipath/checkers/Makefile
|
|
+++ multipath-tools/libmultipath/checkers/Makefile
|
|
@@ -17,6 +17,9 @@ CFLAGS += -I..
|
|
|
|
all: $(LIBS)
|
|
|
|
+libcheckdirectio.so: libsg.o directio.o
|
|
+ $(CC) $(SHARED_FLAGS) -o $@ $^ -laio
|
|
+
|
|
libcheck%.so: libsg.o %.o
|
|
$(CC) $(SHARED_FLAGS) -o $@ $^
|
|
|