91d375be4a
- Updated to latest upstrem 0.4.9 code: multipath-tools-120821.tgz (git commit id: 050b24b33d3c60e29f7820d2fb75e84a9edde528) * includes 0001-RH-remove_callout.patch, 0002-RH-add-wwids-file.patch, 0003-RH-add-followover.patch, 0004-RH-fix-cciss-names.patch - Add 0013-RH-kpartx-msg.patch - Modify 0002-RH-multipath.rules.patch * removed socket call from rules file
64 lines
2.6 KiB
Diff
64 lines
2.6 KiB
Diff
---
|
|
multipath/Makefile | 6 +++---
|
|
multipath/multipath.rules | 29 +++++++++++++++++++++++------
|
|
2 files changed, 26 insertions(+), 9 deletions(-)
|
|
|
|
Index: multipath-tools-120821/multipath/multipath.rules
|
|
===================================================================
|
|
--- multipath-tools-120821.orig/multipath/multipath.rules
|
|
+++ multipath-tools-120821/multipath/multipath.rules
|
|
@@ -1,7 +1,24 @@
|
|
-#
|
|
-# udev rules for multipathing.
|
|
-# The persistent symlinks are created with the kpartx rules
|
|
-#
|
|
+# multipath wants the devmaps presented as meaninglful device names
|
|
+# so name them after their devmap name
|
|
+SUBSYSTEM!="block", GOTO="end_mpath"
|
|
|
|
-# socket for uevents
|
|
-SUBSYSTEM=="block", RUN+="socket:/org/kernel/dm/multipath_event"
|
|
+ENV{MPATH_SBIN_PATH}="/sbin"
|
|
+TEST!="$env{MPATH_SBIN_PATH}/multipath", ENV{MPATH_SBIN_PATH}="/usr/sbin"
|
|
+
|
|
+ACTION=="add", ENV{DEVTYPE}!="partition", \
|
|
+ ENV{DM_MULTIPATH_DEVICE_PATH}!="1", \
|
|
+ TEST=="/etc/multipath.conf", \
|
|
+ PROGRAM=="$env{MPATH_SBIN_PATH}/multipath -c $tempnode", \
|
|
+ ENV{DM_MULTIPATH_DEVICE_PATH}="1"
|
|
+
|
|
+ENV{DM_MULTIPATH_DEVICE_PATH}=="1", ENV{DEVTYPE}!="partition", \
|
|
+ RUN+="/sbin/partx -d --nr 1-1024 $env{DEVNAME}"
|
|
+
|
|
+KERNEL!="dm-*", GOTO="end_mpath"
|
|
+ACTION!="change", GOTO="end_mpath"
|
|
+ENV{DM_UUID}=="mpath-?*|part[0-9]*-mpath-?*", OPTIONS+="link_priority=10"
|
|
+ENV{DM_UUID}!="mpath-?*", GOTO="end_mpath"
|
|
+ENV{DM_SUSPENDED}=="1", GOTO="end_mpath"
|
|
+ENV{DM_ACTION}=="PATH_FAILED", GOTO="end_mpath"
|
|
+RUN+="$env{MPATH_SBIN_PATH}/kpartx -a -p p $tempnode"
|
|
+LABEL="end_mpath"
|
|
Index: multipath-tools-120821/multipath/Makefile
|
|
===================================================================
|
|
--- multipath-tools-120821.orig/multipath/Makefile
|
|
+++ multipath-tools-120821/multipath/Makefile
|
|
@@ -21,15 +21,15 @@ $(EXEC): $(OBJS)
|
|
install:
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(bindir)
|
|
$(INSTALL_PROGRAM) -m 755 $(EXEC) $(DESTDIR)$(bindir)/
|
|
- $(INSTALL_PROGRAM) -d $(DESTDIR)/etc/udev/rules.d
|
|
- $(INSTALL_PROGRAM) -m 644 multipath.rules $(DESTDIR)/etc/udev/rules.d/
|
|
+ $(INSTALL_PROGRAM) -d $(DESTDIR)/lib/udev/rules.d
|
|
+ $(INSTALL_PROGRAM) -m 644 multipath.rules $(DESTDIR)/lib/udev/rules.d/62-multipath.rules
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(mandir)
|
|
$(INSTALL_PROGRAM) -m 644 $(EXEC).8.gz $(DESTDIR)$(mandir)
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(man5dir)
|
|
$(INSTALL_PROGRAM) -m 644 $(EXEC).conf.5.gz $(DESTDIR)$(man5dir)
|
|
|
|
uninstall:
|
|
- rm $(DESTDIR)/etc/udev/rules.d/multipath.rules
|
|
+ rm $(DESTDIR)/lib/udev/rules.d/62-multipath.rules
|
|
rm $(DESTDIR)$(bindir)/$(EXEC)
|
|
rm $(DESTDIR)$(mandir)/$(EXEC).8.gz
|
|
rm $(DESTDIR)$(man5dir)/$(EXEC).conf.5.gz
|