652daa1a21
Update source to upstream version 0.9.0 * Previous patches 0001-0005 are included in the commit. * This version deprecates multiple options: mutlipath_dir, config_dir, and getuid_callout, along with the "default_" prefixed alternate names for the default section parameters. Add patches from upstream staging branch * Patches 0001-0006 are from the upstream staging branch Rename redhat patches * Previous patches 0006-0016 are now patches 0007-0017
64 lines
2.4 KiB
Diff
64 lines
2.4 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Benjamin Marzinski <bmarzins@redhat.com>
|
|
Date: Thu, 13 Apr 2017 07:22:23 -0500
|
|
Subject: [PATCH] RH: fixup udev rules for redhat
|
|
|
|
The multipath rules need to run after scsi_id is run. This means moving
|
|
them after 60-persistent-storage.rules for redhat. Redhat also uses a
|
|
different naming scheme for partitions than SuSE.
|
|
|
|
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
|
---
|
|
Makefile.inc | 2 +-
|
|
kpartx/kpartx.rules | 2 +-
|
|
multipath/Makefile | 4 ++--
|
|
3 files changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/Makefile.inc b/Makefile.inc
|
|
index bcd2212a..40cfbd0c 100644
|
|
--- a/Makefile.inc
|
|
+++ b/Makefile.inc
|
|
@@ -76,7 +76,7 @@ endif
|
|
prefix =
|
|
exec_prefix = $(prefix)
|
|
usr_prefix = $(prefix)
|
|
-bindir = $(exec_prefix)/sbin
|
|
+bindir = $(exec_prefix)/usr/sbin
|
|
libudevdir = $(prefix)/$(SYSTEMDPATH)/udev
|
|
udevrulesdir = $(libudevdir)/rules.d
|
|
modulesloaddir = $(prefix)/$(SYSTEMDPATH)/modules-load.d
|
|
diff --git a/kpartx/kpartx.rules b/kpartx/kpartx.rules
|
|
index 1969dee0..d2b28233 100644
|
|
--- a/kpartx/kpartx.rules
|
|
+++ b/kpartx/kpartx.rules
|
|
@@ -39,6 +39,6 @@ LABEL="mpath_kpartx_end"
|
|
GOTO="kpartx_end"
|
|
|
|
LABEL="run_kpartx"
|
|
-RUN+="/sbin/kpartx -un -p -part /dev/$name"
|
|
+RUN+="/sbin/kpartx -un /dev/$name"
|
|
|
|
LABEL="kpartx_end"
|
|
diff --git a/multipath/Makefile b/multipath/Makefile
|
|
index bcb04533..d2b3fd82 100644
|
|
--- a/multipath/Makefile
|
|
+++ b/multipath/Makefile
|
|
@@ -23,7 +23,7 @@ install:
|
|
$(INSTALL_PROGRAM) -m 755 $(EXEC) $(DESTDIR)$(bindir)/
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(udevrulesdir)
|
|
$(INSTALL_PROGRAM) -m 644 11-dm-mpath.rules $(DESTDIR)$(udevrulesdir)
|
|
- $(INSTALL_PROGRAM) -m 644 $(EXEC).rules $(DESTDIR)$(udevrulesdir)/56-multipath.rules
|
|
+ $(INSTALL_PROGRAM) -m 644 $(EXEC).rules $(DESTDIR)$(udevrulesdir)/62-multipath.rules
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(modulesloaddir)
|
|
$(INSTALL_PROGRAM) -m 644 modules-load.conf $(DESTDIR)$(modulesloaddir)/multipath.conf
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(man8dir)
|
|
@@ -41,7 +41,7 @@ uninstall:
|
|
$(RM) $(DESTDIR)$(udevrulesdir)/11-dm-mpath.rules
|
|
$(RM) $(DESTDIR)$(modulesloaddir)/multipath.conf
|
|
$(RM) $(DESTDIR)$(modulesloaddir)/scsi_dh.conf
|
|
- $(RM) $(DESTDIR)$(libudevdir)/rules.d/56-multipath.rules
|
|
+ $(RM) $(DESTDIR)$(libudevdir)/rules.d/62-multipath.rules
|
|
$(RM) $(DESTDIR)$(man8dir)/$(EXEC).8
|
|
$(RM) $(DESTDIR)$(man5dir)/$(EXEC).conf.5
|
|
|