64b1cb0e21
Update Source to 0.7.7 * Previous patches 0001-0009 & 0018 are included in this commit Add upstream patches since 0.7.7 * patches 0001-0012 are from upstream commits since 0.7.7 Add 0015-mpathpersist-add-all_tg_pt-option.patch * add new all_tg_pt multpiath.conf option. posted upstream Add 0016-libmultipath-remove-rbd-code.patch * remove unused rbd code. posted upstream Add 0017-mpathpersist-fix-aptpl-support.patch * add ":aptpl" suffix for reservation_key to fix aptpl support. posted upstream Add 0018-multipath-don-t-check-timestamps-without-a-path.patch * fix multipath null dereference crash. posted upstream Add 0019-libmultipath-fix-detect-alua-corner-case.patch * fix alua detection with retain_hardware_handler set to off. posted upstream Add 0020-multipath-fix-setting-conf-version.patch * multipath wasn't setting the kernel version correctly. posted upstream Add 0028-RH-reset-default-find_mutipaths-value-to-off.patch * default to RHEL7 and older device detection style. Redhat specific, to keep customer experience the same. Rename files * Previous patches 0010-0011 are now patches 0013-0014 * Previous patches 0012-0017 & 0019 are now patches 0021-0027 Modify 0021-RH-fixup-udev-rules-for-redhat.patch * Fix spurious compile warning with redhat compile options
83 lines
2.8 KiB
Diff
83 lines
2.8 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Benjamin Marzinski <bmarzins@redhat.com>
|
|
Date: Thu, 13 Apr 2017 07:22:23 -0500
|
|
Subject: [PATCH] RH: fixup udev rules for redhat
|
|
|
|
The multipath rules need to run after scsi_id is run. This means moving
|
|
them after 60-persistent-storage.rules for redhat. Redhat also uses a
|
|
different naming scheme for partitions than SuSE. Also, there are some
|
|
false warnings that gcc throws because of the changed options. Fix these
|
|
too.
|
|
|
|
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
|
---
|
|
Makefile.inc | 2 +-
|
|
kpartx/kpartx.rules | 2 +-
|
|
multipath/Makefile | 4 ++--
|
|
multipath/main.c | 2 +-
|
|
4 files changed, 5 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/Makefile.inc b/Makefile.inc
|
|
index af2f5ba..0b271ea 100644
|
|
--- a/Makefile.inc
|
|
+++ b/Makefile.inc
|
|
@@ -51,7 +51,7 @@ endif
|
|
prefix =
|
|
exec_prefix = $(prefix)
|
|
usr_prefix = $(prefix)
|
|
-bindir = $(exec_prefix)/sbin
|
|
+bindir = $(exec_prefix)/usr/sbin
|
|
libudevdir = $(prefix)/$(SYSTEMDPATH)/udev
|
|
udevrulesdir = $(libudevdir)/rules.d
|
|
multipathdir = $(TOPDIR)/libmultipath
|
|
diff --git a/kpartx/kpartx.rules b/kpartx/kpartx.rules
|
|
index 8f99049..8a3a171 100644
|
|
--- a/kpartx/kpartx.rules
|
|
+++ b/kpartx/kpartx.rules
|
|
@@ -32,6 +32,6 @@ LABEL="mpath_kpartx_end"
|
|
GOTO="kpartx_end"
|
|
|
|
LABEL="run_kpartx"
|
|
-RUN+="/sbin/kpartx -un -p -part /dev/$name"
|
|
+RUN+="/sbin/kpartx -un /dev/$name"
|
|
|
|
LABEL="kpartx_end"
|
|
diff --git a/multipath/Makefile b/multipath/Makefile
|
|
index 0828a8f..b9bbb3c 100644
|
|
--- a/multipath/Makefile
|
|
+++ b/multipath/Makefile
|
|
@@ -24,7 +24,7 @@ install:
|
|
$(INSTALL_PROGRAM) -m 755 $(EXEC) $(DESTDIR)$(bindir)/
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(udevrulesdir)
|
|
$(INSTALL_PROGRAM) -m 644 11-dm-mpath.rules $(DESTDIR)$(udevrulesdir)
|
|
- $(INSTALL_PROGRAM) -m 644 $(EXEC).rules $(DESTDIR)$(libudevdir)/rules.d/56-multipath.rules
|
|
+ $(INSTALL_PROGRAM) -m 644 $(EXEC).rules $(DESTDIR)$(libudevdir)/rules.d/62-multipath.rules
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(man8dir)
|
|
$(INSTALL_PROGRAM) -m 644 $(EXEC).8.gz $(DESTDIR)$(man8dir)
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(man5dir)
|
|
@@ -33,7 +33,7 @@ install:
|
|
uninstall:
|
|
$(RM) $(DESTDIR)$(bindir)/$(EXEC)
|
|
$(RM) $(DESTDIR)$(udevrulesdir)/11-dm-mpath.rules
|
|
- $(RM) $(DESTDIR)$(libudevdir)/rules.d/56-multipath.rules
|
|
+ $(RM) $(DESTDIR)$(libudevdir)/rules.d/62-multipath.rules
|
|
$(RM) $(DESTDIR)$(man8dir)/$(EXEC).8.gz
|
|
$(RM) $(DESTDIR)$(man5dir)/$(EXEC).conf.5.gz
|
|
|
|
diff --git a/multipath/main.c b/multipath/main.c
|
|
index 3f0a6aa..6fdde03 100644
|
|
--- a/multipath/main.c
|
|
+++ b/multipath/main.c
|
|
@@ -389,7 +389,7 @@ static int find_multipaths_check_timeout(const struct path *pp, long tmo,
|
|
struct timespec now, ftimes[2], tdiff;
|
|
struct stat st;
|
|
long fd;
|
|
- int r, err, retries = 0;
|
|
+ int r, err = 0, retries = 0;
|
|
|
|
clock_gettime(CLOCK_REALTIME, &now);
|
|
|
|
--
|
|
2.7.4
|
|
|