c79ce3480d
Update Source to latest upstream commit * Previous patches 0001-0018 are included in this commit Rename files * Previous patches 0019-0028 are now patches 0002-0003 & 0012-0019 Add 0001-libmultipath-remove-last-of-rbd-code.patch Add 0004-mpathpersist-add-param-alltgpt-option.patch * mpathpersist now accepts --param-alltgpt Add 0005-libmutipath-remove-unused-IDE-bus-type.patch Add 0006-multipathd-add-new-protocol-path-wildcard.patch * multipathd show paths format now accepts %P for the path * protocol/transport Add 0007-libmultipath-add-protocol-blacklist-option.patch * You can now use the "protocol" blacklist section parameter to * blacklist by protocol/transport Add 0008-libmultipath-remove-_filter_-blacklist-functions.patch Add 0009-multipath-tests-change-to-work-with-old-make-version.patch Add 0010-multipath-tests-add-blacklist-tests.patch Add 0011-mpathpersist-add-missing-param-rk-usage-info.patch Refresh 0013-RH-Remove-the-property-blacklist-exception-builtin.patch Modify 0016-RH-add-mpathconf.patch * improve usage message and man page
29 lines
1.0 KiB
Diff
29 lines
1.0 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Benjamin Marzinski <bmarzins@redhat.com>
|
|
Date: Tue, 3 Jul 2018 19:59:33 -0500
|
|
Subject: [PATCH] multipath tests: change to work with old make versions
|
|
|
|
the $(file <) operation only works with make 4.2 and above. I tried
|
|
running the tests on an old machine and it failed. The $shell function
|
|
can do the same thing and multipath has been using that in its
|
|
Makefiles for a while.
|
|
|
|
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
|
---
|
|
tests/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/tests/Makefile b/tests/Makefile
|
|
index 78755ed..d293c87 100644
|
|
--- a/tests/Makefile
|
|
+++ b/tests/Makefile
|
|
@@ -51,4 +51,4 @@ COLON:=:
|
|
$(multipathdir)/libmultipath.so Makefile
|
|
$(CC) $(CFLAGS) -o $@ $(LDFLAGS) $< $($@_TESTDEPS) $($@_OBJDEPS) \
|
|
$(LIBDEPS) $($@_LIBDEPS) \
|
|
- $(file <$<.wrap) $(foreach dep,$($@_TESTDEPS),$(file <$(dep).wrap))
|
|
+ $(shell cat $<.wrap) $(foreach dep,$($@_TESTDEPS),$(shell cat $(dep).wrap))
|
|
--
|
|
2.7.4
|
|
|