50 lines
1.6 KiB
Diff
50 lines
1.6 KiB
Diff
Index: multipath-tools-080519/libmultipath/Makefile
|
|
===================================================================
|
|
--- multipath-tools-080519.orig/libmultipath/Makefile
|
|
+++ multipath-tools-080519/libmultipath/Makefile
|
|
@@ -23,14 +23,15 @@ endif
|
|
all: $(LIBS)
|
|
|
|
$(LIBS): $(OBJS)
|
|
- $(CC) $(SHARED_FLAGS) $(CFLAGS) -o $@ $(OBJS)
|
|
+ $(CC) $(SHARED_FLAGS) -Wl,-soname,$@ $(CFLAGS) -o $@ $(OBJS)
|
|
|
|
install:
|
|
+ $(INSTALL_PROGRAM) -d $(DESTDIR)$(prefix)/lib
|
|
+ $(INSTALL_PROGRAM) -m 755 $(LIBS) $(DESTDIR)$(prefix)/lib/$(LIBS)
|
|
$(INSTALL_PROGRAM) -m 755 -d $(DESTDIR)$(libdir)
|
|
- $(INSTALL_PROGRAM) -m 755 $(LIBS) $(DESTDIR)$(libdir)/$(LIBS)
|
|
|
|
uninstall:
|
|
- rm -f $(DESTDIR)$(libdir)/$(LIBS)
|
|
+ rm -f $(DESTDIR)$(prefix)/lib/$(LIBS)
|
|
|
|
clean:
|
|
rm -f core *.a *.o *.gz *.so
|
|
Index: multipath-tools-080519/multipath/Makefile
|
|
===================================================================
|
|
--- multipath-tools-080519.orig/multipath/Makefile
|
|
+++ multipath-tools-080519/multipath/Makefile
|
|
@@ -6,7 +6,7 @@ include ../Makefile.inc
|
|
|
|
OBJS = main.o
|
|
|
|
-CFLAGS += -I$(multipathdir) -Wl,-rpath,$(libdir)
|
|
+CFLAGS += -I$(multipathdir)
|
|
LDFLAGS += -lpthread -ldevmapper -laio -ldl \
|
|
-lmultipath -L$(multipathdir)
|
|
|
|
Index: multipath-tools-080519/multipathd/Makefile
|
|
===================================================================
|
|
--- multipath-tools-080519.orig/multipathd/Makefile
|
|
+++ multipath-tools-080519/multipathd/Makefile
|
|
@@ -5,7 +5,7 @@ include ../Makefile.inc
|
|
#
|
|
# basic flags setting
|
|
#
|
|
-CFLAGS += -I$(multipathdir) -Wl,-rpath,$(libdir)
|
|
+CFLAGS += -I$(multipathdir)
|
|
LDFLAGS += -lpthread -ldevmapper -lreadline -lncurses -laio -ldl \
|
|
-lmultipath -L$(multipathdir)
|
|
|