device-mapper-multipath/redhatification.patch
Benjamin Marzinski 685fcac1ef Updated to latest Upstream 0.4.8 code: multipath-tools-080519.tgz (git
commit id: 42704728855376d2f7da2de1967d7bc71bc54a2f)
2008-05-20 04:37:41 +00:00

700 lines
22 KiB
Diff

Index: multipath-tools-080519/libmultipath/defaults.h
===================================================================
--- multipath-tools-080519.orig/libmultipath/defaults.h
+++ multipath-tools-080519/libmultipath/defaults.h
@@ -1,4 +1,4 @@
-#define DEFAULT_GETUID "/lib/udev/scsi_id -g -u -s /block/%n"
+#define DEFAULT_GETUID "/sbin/scsi_id -g -u -s /block/%n"
#define DEFAULT_UDEVDIR "/dev"
#define DEFAULT_MULTIPATHDIR "/lib/multipath"
#define DEFAULT_SELECTOR "round-robin 0"
Index: multipath-tools-080519/libmultipath/hwtable.c
===================================================================
--- multipath-tools-080519.orig/libmultipath/hwtable.c
+++ multipath-tools-080519/libmultipath/hwtable.c
@@ -172,7 +172,7 @@ static struct hwentry default_hw[] = {
/* HP Smart Array */
.vendor = "HP",
.product = "LOGICAL VOLUME.*",
- .getuid = "/lib/udev/scsi_id -n -g -u -s /block/%n",
+ .getuid = "/sbin/scsi_id -n -g -u -s /block/%n",
.features = DEFAULT_FEATURES,
.hwhandler = DEFAULT_HWHANDLER,
.selector = DEFAULT_SELECTOR,
@@ -214,7 +214,7 @@ static struct hwentry default_hw[] = {
{
.vendor = "EMC",
.product = "SYMMETRIX",
- .getuid = "/lib/udev/scsi_id -g -u -ppre-spc3-83 -s /block/%n",
+ .getuid = "/sbin/scsi_id -g -u -ppre-spc3-83 -s /block/%n",
.features = DEFAULT_FEATURES,
.hwhandler = DEFAULT_HWHANDLER,
.selector = DEFAULT_SELECTOR,
@@ -485,7 +485,7 @@ static struct hwentry default_hw[] = {
.vendor = "IBM",
.product = "S/390 DASD ECKD",
.bl_product = "S/390.*",
- .getuid = "/sbin/dasdinfo -u -b %n",
+ .getuid = "/sbin/dasd_id /dev/%n",
.features = "1 queue_if_no_path",
.hwhandler = DEFAULT_HWHANDLER,
.selector = DEFAULT_SELECTOR,
@@ -705,6 +705,22 @@ static struct hwentry default_hw[] = {
.checker_name = RDAC,
.prio_name = PRIO_RDAC,
},
+ /* DELL arrays */
+ {
+ .vendor = "DELL",
+ .product = "MD3000",
+ .getuid = DEFAULT_GETUID,
+ .features = DEFAULT_FEATURES,
+ .hwhandler = "1 rdac",
+ .selector = DEFAULT_SELECTOR,
+ .pgpolicy = GROUP_BY_PRIO,
+ .pgfailback = -FAILBACK_MANUAL,
+ .rr_weight = RR_WEIGHT_NONE,
+ .no_path_retry = NO_PATH_RETRY_UNDEF,
+ .minio = DEFAULT_MINIO,
+ .checker_name = RDAC,
+ .prio_name = PRIO_RDAC,
+ },
/*
* EOL
*/
Index: multipath-tools-080519/multipath.conf.annotated
===================================================================
--- multipath-tools-080519.orig/multipath.conf.annotated
+++ multipath-tools-080519/multipath.conf.annotated
@@ -55,9 +55,9 @@
# # scope : multipath
# # desc : the default program and args to callout to obtain a unique
# # path identifier. Absolute path required
-# # default : /lib/udev/scsi_id -g -u -s
+# # default : /sbin/scsi_id -g -u -s
# #
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
#
# #
# # name : prio
@@ -336,7 +336,7 @@
# # desc : the program and args to callout to obtain a unique
# # path identifier. Absolute path required
# #
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
#
# #
# # name : path_selector
Index: multipath-tools-080519/multipath.conf.defaults
===================================================================
--- multipath-tools-080519.orig/multipath.conf.defaults
+++ multipath-tools-080519/multipath.conf.defaults
@@ -6,7 +6,7 @@
# polling_interval 5
# selector "round-robin 0"
# path_grouping_policy failover
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# prio const
# path_checker directio
# rr_min_io 1000
@@ -26,7 +26,7 @@
# device {
# vendor "APPLE*"
# product "Xserve RAID"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "0"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -39,7 +39,7 @@
# device {
# vendor "3PARdata"
# product "VV"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "0"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -52,7 +52,7 @@
# device {
# vendor "DEC"
# product "HSG80"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "1 queue_if_no_path"
# hardware_handler "1 hp-sw"
# path_selector "round-robin 0"
@@ -65,7 +65,7 @@
# device {
# vendor "HP"
# product "A6189A"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "0"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -79,7 +79,7 @@
# device {
# vendor "(COMPAQ|HP)"
# product "(MSA|HSV)1.0.*"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "1 queue_if_no_path"
# hardware_handler "1 hp-sw"
# path_selector "round-robin 0"
@@ -93,7 +93,7 @@
# device {
# vendor "HP"
# product "MSA VOLUME"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "0"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -123,7 +123,7 @@
# device {
# vendor "(COMPAQ|HP)"
# product "HSV1[01]1|HSV2[01]0|HSV300"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "0"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -138,7 +138,7 @@
# device {
# vendor "HP"
# product "MSA2[02]12*"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "0"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -153,7 +153,7 @@
# device {
# vendor "HP"
# product "LOGICAL VOLUME.*"
-# getuid_callout "/lib/udev/scsi_id -n -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -n -g -u -s /block/%n"
# features "0"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -168,7 +168,7 @@
# device {
# vendor "DDN"
# product "SAN DataDirector"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "0"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -181,7 +181,7 @@
# device {
# vendor "EMC"
# product "SYMMETRIX"
-# getuid_callout "/lib/udev/scsi_id -g -u -ppre-spc3-83 -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -ppre-spc3-83 -s /block/%n"
# features "0"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -195,7 +195,7 @@
# vendor "DGC"
# product ".*"
# product_blacklist "LUNZ"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# prio_callout "/sbin/mpath_prio_emc /dev/%n"
# features "1 queue_if_no_path"
# hardware_handler "1 emc"
@@ -211,7 +211,7 @@
# device {
# vendor "FSC"
# product "CentricStor"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "0"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -224,7 +224,7 @@
# device {
# vendor "(HITACHI|HP)"
# product "OPEN-.*"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "1 queue_if_no_path"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -237,7 +237,7 @@
# device {
# vendor "HITACHI"
# product "DF.*"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "1 queue_if_no_path"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -251,7 +251,7 @@
# device {
# vendor "IBM"
# product "ProFibre 4000R"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "0"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -264,7 +264,7 @@
# device {
# vendor "IBM"
# product "1722-600"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "1 queue_if_no_path"
# hardware_handler "1 rdac"
# path_selector "round-robin 0"
@@ -279,7 +279,7 @@
# device {
# vendor "IBM"
# product "1742"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "0"
# hardware_handler "1 rdac"
# path_selector "round-robin 0"
@@ -294,7 +294,7 @@
# device {
# vendor "IBM"
# product "1814"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "0"
# hardware_handler "1 rdac"
# path_selector "round-robin 0"
@@ -309,7 +309,7 @@
# device {
# vendor "IBM"
# product "1815"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "0"
# hardware_handler "1 rdac"
# path_selector "round-robin 0"
@@ -324,7 +324,7 @@
# device {
# vendor "IBM"
# product "3526"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "0"
# hardware_handler "1 rdac"
# path_selector "round-robin 0"
@@ -339,7 +339,7 @@
# device {
# vendor "IBM"
# product "3542"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "0"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -352,7 +352,7 @@
# device {
# vendor "IBM"
# product "2105(800|F20)"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "1 queue_if_no_path"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -365,7 +365,7 @@
# device {
# vendor "IBM"
# product "1750500"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "1 queue_if_no_path"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -379,7 +379,7 @@
# device {
# vendor "IBM"
# product "2107900"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "1 queue_if_no_path"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -392,7 +392,7 @@
# device {
# vendor "IBM"
# product "2145"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "1 queue_if_no_path"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -407,7 +407,7 @@
# vendor "IBM"
# product "S/390 DASD ECKD"
# product_blacklist "S/390.*"
-# getuid_callout "/sbin/dasdinfo -u -b %n"
+# getuid_callout "/sbin/dasd_id /dev/%n"
# features "1 queue_if_no_path"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -420,7 +420,7 @@
# device {
# vendor "NETAPP"
# product "LUN.*"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "1 queue_if_no_path"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -434,7 +434,7 @@
# device {
# vendor "IBM"
# product "Nseries.*"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "1 queue_if_no_path"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -448,7 +448,7 @@
# device {
# vendor "Pillar"
# product "Axiom.*"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "0"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -461,7 +461,7 @@
# device {
# vendor "SGI"
# product "TP9[13]00"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "0"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -474,7 +474,7 @@
# device {
# vendor "SGI"
# product "TP9[45]00"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "0"
# hardware_handler "1 rdac"
# path_selector "round-robin 0"
@@ -489,7 +489,7 @@
# device {
# vendor "SGI"
# product "IS.*"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "0"
# hardware_handler "1 rdac"
# path_selector "round-robin 0"
@@ -504,7 +504,7 @@
# device {
# vendor "STK"
# product "OPENstorage D280"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "0"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -518,7 +518,7 @@
# device {
# vendor "SUN"
# product "(StorEdge 3510|T4)"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "0"
# hardware_handler "0"
# path_selector "round-robin 0"
@@ -544,7 +544,7 @@
# device {
# vendor "SUN"
# product "CSM200_R"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "0"
# hardware_handler "1 rdac"
# path_selector "round-robin 0"
@@ -559,7 +559,7 @@
# device {
# vendor "SUN"
# product "LCSM100_F"
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# features "0"
# hardware_handler "1 rdac"
# path_selector "round-robin 0"
@@ -571,4 +571,18 @@
# path_checker rdac
# prio rdac
# }
+# device {
+# vendor "DELL"
+# product "MD3000"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
+# features "0"
+# hardware_handler "1 rdac"
+# path_selector "round-robin 0"
+# path_grouping_policy group_by_prio
+# failback manual
+# rr_weight uniform
+# rr_min_io 1000
+# path_checker rdac
+# prio rdac
+# }
#}
Index: multipath-tools-080519/multipath.conf.synthetic
===================================================================
--- multipath-tools-080519.orig/multipath.conf.synthetic
+++ multipath-tools-080519/multipath.conf.synthetic
@@ -7,7 +7,7 @@
# polling_interval 10
# selector "round-robin 0"
# path_grouping_policy multibus
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# prio const
# path_checker directio
# rr_min_io 100
@@ -52,7 +52,7 @@
# vendor "COMPAQ "
# product "HSV110 (C)COMPAQ"
# path_grouping_policy multibus
-# getuid_callout "/lib/udev/scsi_id -g -u -s /block/%n"
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
# path_checker directio
# path_selector "round-robin 0"
# hardware_handler "0"
Index: multipath-tools-080519/Makefile.inc
===================================================================
--- multipath-tools-080519.orig/Makefile.inc
+++ multipath-tools-080519/Makefile.inc
@@ -20,7 +20,7 @@ libudevdir = ${prefix}/lib/udev
multipathdir = $(TOPDIR)/libmultipath
mandir = $(prefix)/usr/share/man/man8
man5dir = $(prefix)/usr/share/man/man5
-rcdir = $(prefix)/etc/init.d
+rcdir = $(prefix)/etc/rc.d/init.d
libdir = $(prefix)/lib/multipath
GZIP = /bin/gzip -9 -c
Index: multipath-tools-080519/multipathd/Makefile
===================================================================
--- multipath-tools-080519.orig/multipathd/Makefile
+++ multipath-tools-080519/multipathd/Makefile
@@ -35,6 +35,7 @@ install:
$(INSTALL_PROGRAM) -d $(DESTDIR)$(bindir)
$(INSTALL_PROGRAM) -m 755 $(EXEC) $(DESTDIR)$(bindir)
$(INSTALL_PROGRAM) -d $(DESTDIR)$(rcdir)
+ $(INSTALL_PROGRAM) -m 755 multipathd.init.redhat $(DESTDIR)$(rcdir)/$(EXEC)
$(INSTALL_PROGRAM) -d $(DESTDIR)$(mandir)
$(INSTALL_PROGRAM) -m 644 $(EXEC).8.gz $(DESTDIR)$(mandir)
Index: multipath-tools-080519/multipathd/multipathd.init.redhat
===================================================================
--- multipath-tools-080519.orig/multipathd/multipathd.init.redhat
+++ multipath-tools-080519/multipathd/multipathd.init.redhat
@@ -1,13 +1,9 @@
#!/bin/bash
-
-#
-# /etc/rc.d/init.d/multipathd
#
-# Starts the multipath daemon
+# multipathd Starts the multipath daemon
#
# chkconfig: - 13 87
-# description: Manage device-mapper multipath devices
-# processname: multipathd
+# description: Manages device-mapper multipath devices
DAEMON=/sbin/multipathd
prog=`basename $DAEMON`
@@ -16,14 +12,8 @@ lockdir=/var/lock/subsys
sysconfig=/etc/sysconfig
-system=redhat
-
-if [ $system = redhat ]; then
- # Source function library.
- . $initdir/functions
-fi
+. $initdir/functions
-test -x $DAEMON || exit 0
test -r $sysconfig/$prog && . $sysconfig/$prog
RETVAL=0
@@ -33,6 +23,7 @@ RETVAL=0
#
start() {
+ test -x $DAEMON || exit 5
echo -n $"Starting $prog daemon: "
daemon $DAEMON
RETVAL=$?
@@ -74,7 +65,7 @@ reload)
restart)
restart
;;
-condrestart)
+condrestart|try-restart)
if [ -f $lockdir/$prog ]; then
restart
fi
@@ -85,7 +76,7 @@ status)
;;
*)
echo $"Usage: $0 {start|stop|status|restart|condrestart|reload}"
- RETVAL=1
+ RETVAL=2
esac
exit $RETVAL
Index: multipath-tools-080519/multipath/Makefile
===================================================================
--- multipath-tools-080519.orig/multipath/Makefile
+++ multipath-tools-080519/multipath/Makefile
@@ -28,6 +28,10 @@ install:
$(INSTALL_PROGRAM) -m 644 $(EXEC).8.gz $(DESTDIR)$(mandir)
$(INSTALL_PROGRAM) -d $(DESTDIR)$(man5dir)
$(INSTALL_PROGRAM) -m 644 $(EXEC).conf.5.gz $(DESTDIR)$(man5dir)
+ if [ ! -e $(DESTDIR)//etc/multipath.conf ]; then \
+ $(INSTALL_PROGRAM) -m 644 multipath.conf.redhat $(DESTDIR)/etc/multipath.conf; \
+ fi
+ $(INSTALL_PROGRAM) -d $(DESTDIR)/var/lib/multipath
uninstall:
rm $(DESTDIR)/etc/udev/rules.d/multipath.rules
Index: multipath-tools-080519/multipath/multipath.conf.redhat
===================================================================
--- /dev/null
+++ multipath-tools-080519/multipath/multipath.conf.redhat
@@ -0,0 +1,97 @@
+# This is a basic configuration file with some examples, for device mapper
+# multipath.
+# For a complete list of the default configuration values, see
+# /usr/share/doc/device-mapper-multipath-0.4.8/multipath.conf.defaults
+# For a list of configuration options with descriptions, see
+# /usr/share/doc/device-mapper-multipath-0.4.8/multipath.conf.annotated
+
+
+# Blacklist all devices by default. Remove this to enable multipathing
+# on the default devices.
+blacklist {
+ devnode "*"
+}
+
+## By default, devices with vendor = "IBM" and product = "S/390.*" are
+## blacklisted. To enable mulitpathing on these devies, uncomment the
+## following lines.
+#blacklist_exceptions {
+# device {
+# vendor "IBM"
+# product "S/390.*"
+# }
+#}
+
+## Use user friendly names, instead of using WWIDs as names.
+defaults {
+ user_friendly_names yes
+}
+##
+## Here is an example of how to configure some standard options.
+##
+#
+#defaults {
+# udev_dir /dev
+# polling_interval 10
+# selector "round-robin 0"
+# path_grouping_policy multibus
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
+# prio alua
+# path_checker readsector0
+# rr_min_io 100
+# max_fds 8192
+# rr_weight priorities
+# failback immediate
+# no_path_retry fail
+# user_friendly_names yes
+#}
+##
+## The wwid line in the following blacklist section is shown as an example
+## of how to blacklist devices by wwid. The 2 devnode lines are the
+## compiled in default blacklist. If you want to blacklist entire types
+## of devices, such as all scsi devices, you should use a devnode line.
+## However, if you want to blacklist specific devices, you should use
+## a wwid line. Since there is no guarantee that a specific device will
+## not change names on reboot (from /dev/sda to /dev/sdb for example)
+## devnode lines are not recommended for blacklisting specific devices.
+##
+#blacklist {
+# wwid 26353900f02796769
+# devnode "^(ram|raw|loop|fd|md|dm-|sr|scd|st)[0-9]*"
+# devnode "^hd[a-z]"
+#}
+#multipaths {
+# multipath {
+# wwid 3600508b4000156d700012000000b0000
+# alias yellow
+# path_grouping_policy multibus
+# path_checker readsector0
+# path_selector "round-robin 0"
+# failback manual
+# rr_weight priorities
+# no_path_retry 5
+# }
+# multipath {
+# wwid 1DEC_____321816758474
+# alias red
+# }
+#}
+#devices {
+# device {
+# vendor "COMPAQ "
+# product "HSV110 (C)COMPAQ"
+# path_grouping_policy multibus
+# getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
+# path_checker readsector0
+# path_selector "round-robin 0"
+# hardware_handler "0"
+# failback 15
+# rr_weight priorities
+# no_path_retry queue
+# }
+# device {
+# vendor "COMPAQ "
+# product "MSA1000 "
+# path_grouping_policy multibus
+# }
+#}
Index: multipath-tools-080519/kpartx/Makefile
===================================================================
--- multipath-tools-080519.orig/kpartx/Makefile
+++ multipath-tools-080519/kpartx/Makefile
@@ -20,10 +20,10 @@ $(EXEC): $(OBJS)
install: $(EXEC) $(EXEC).8
$(INSTALL_PROGRAM) -d $(DESTDIR)$(bindir)
$(INSTALL_PROGRAM) -m 755 $(EXEC) $(DESTDIR)$(bindir)
- $(INSTALL_PROGRAM) -d $(DESTDIR)$(libudevdir)
- $(INSTALL_PROGRAM) -m 755 kpartx_id $(DESTDIR)$(libudevdir)
- $(INSTALL_PROGRAM) -d $(DESTDIR)/etc/udev/rules.d
- $(INSTALL_PROGRAM) -m 644 kpartx.rules $(DESTDIR)/etc/udev/rules.d/
+# $(INSTALL_PROGRAM) -d $(DESTDIR)$(libudevdir)
+# $(INSTALL_PROGRAM) -m 755 kpartx_id $(DESTDIR)$(libudevdir)
+# $(INSTALL_PROGRAM) -d $(DESTDIR)/etc/udev/rules.d
+# $(INSTALL_PROGRAM) -m 644 kpartx.rules $(DESTDIR)/etc/udev/rules.d/
$(INSTALL_PROGRAM) -d $(DESTDIR)$(mandir)
$(INSTALL_PROGRAM) -m 644 $(EXEC).8.gz $(DESTDIR)$(mandir)