9abdc502cf
Rebased on top of additional commits staged for upstream * Previous patches 0048-0060 are now patches 0053-0054 & 0059-0069 Add 0048-libmultipath-add-device-to-hwtable.c.patch Add 0049-master-libmultipath-fix-use-after-free-when-iscsi-lo.patch Add 0050-libmultipath-warn-if-freeing-path-that-holds-mpp-hwe.patch Add 0051-libmultipath-warn-about-NULL-value-of-mpp-hwe.patch Add 0052-libmultipath-fix-mpp-hwe-handling-in-sync_paths.patch Add 0055-libmultipath-remove-code-duplication-in-path-countin.patch Add 0056-libmultipath-count-pending-paths-as-active-on-loads.patch Add 0057-libmultipath-deal-with-flushing-no-maps.patch Add 0058-multipath-deal-with-delegation-failures-correctly.patch Add 0070-multipath-add-libmpathvalid-library.patch * adds the libmpathvalid.so library to determine if devices are valid multipath paths. Add 0071-libmultipath-add-uid-failback-for-dasd-devices.patch Add 0072-libmultipath-add-ignore_udev_uid-option.patch
31 lines
999 B
Diff
31 lines
999 B
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Benjamin Marzinski <bmarzins@redhat.com>
|
|
Date: Mon, 6 Jul 2020 13:21:12 -0500
|
|
Subject: [PATCH] Makefile.inc: trim extra information from systemd version
|
|
|
|
Some systemd versions print extra information in the
|
|
"pkg-config --modversion" output, which confuses make. Trim this
|
|
off.
|
|
|
|
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
|
---
|
|
Makefile.inc | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile.inc b/Makefile.inc
|
|
index e7256e3a..8ea3352d 100644
|
|
--- a/Makefile.inc
|
|
+++ b/Makefile.inc
|
|
@@ -37,7 +37,7 @@ endif
|
|
|
|
ifndef SYSTEMD
|
|
ifeq ($(shell pkg-config --modversion libsystemd >/dev/null 2>&1 && echo 1), 1)
|
|
- SYSTEMD = $(shell pkg-config --modversion libsystemd)
|
|
+ SYSTEMD = $(shell pkg-config --modversion libsystemd | awk '{print $$1}')
|
|
else
|
|
ifeq ($(shell systemctl --version >/dev/null 2>&1 && echo 1), 1)
|
|
SYSTEMD = $(shell systemctl --version 2> /dev/null | \
|
|
--
|
|
2.17.2
|
|
|