2d373b6820
Update to the head of the upstream staging branch plus redhat patches * Patches 0016-0018 are from the upstream staging branch * Patches 0019-0024 have been submitted upstream Rename files * Previous patches 0016-0025 are now patches 0024-0033
116 lines
4.2 KiB
Diff
116 lines
4.2 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Xose Vazquez Perez <xose.vazquez@gmail.com>
|
|
Date: Sat, 22 May 2021 21:17:36 +0200
|
|
Subject: [PATCH] multipath-tools: Remove trailing/leading whitespaces
|
|
|
|
Cc: Martin Wilck <mwilck@suse.com>
|
|
Cc: Benjamin Marzinski <bmarzins@redhat.com>
|
|
Cc: Christophe Varoqui <christophe.varoqui@opensvc.com>
|
|
Cc: DM-DEVEL ML <dm-devel@redhat.com>
|
|
Signed-off-by: Xose Vazquez Perez <xose.vazquez@gmail.com>
|
|
Reviewed-by: Martin Wilck <mwilck@suse.com>"
|
|
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
|
---
|
|
Makefile.inc | 2 +-
|
|
libmultipath/configure.c | 2 +-
|
|
libmultipath/devmapper.c | 4 ++--
|
|
libmultipath/sysfs.c | 2 +-
|
|
multipath/multipath.8 | 2 +-
|
|
multipathd/cli_handlers.c | 2 +-
|
|
multipathd/main.c | 2 +-
|
|
7 files changed, 8 insertions(+), 8 deletions(-)
|
|
|
|
diff --git a/Makefile.inc b/Makefile.inc
|
|
index 91100a20..d0ec9b44 100644
|
|
--- a/Makefile.inc
|
|
+++ b/Makefile.inc
|
|
@@ -101,7 +101,7 @@ OPTFLAGS := -O2 -g $(STACKPROT) --param=ssp-buffer-size=4
|
|
WARNFLAGS := -Werror -Wall -Wextra -Wformat=2 $(WFORMATOVERFLOW) -Werror=implicit-int \
|
|
-Werror=implicit-function-declaration -Werror=format-security \
|
|
$(WNOCLOBBERED) -Werror=cast-qual $(ERROR_DISCARDED_QUALIFIERS)
|
|
-CPPFLAGS := -Wp,-D_FORTIFY_SOURCE=2
|
|
+CPPFLAGS := -Wp,-D_FORTIFY_SOURCE=2
|
|
CFLAGS := --std=gnu99 $(CFLAGS) $(OPTFLAGS) $(WARNFLAGS) -pipe \
|
|
-DBIN_DIR=\"$(bindir)\" -DLIB_STRING=\"${LIB}\" -DRUN_DIR=\"${RUN}\" \
|
|
-MMD -MP
|
|
diff --git a/libmultipath/configure.c b/libmultipath/configure.c
|
|
index 6ca1f4bb..a6ae3359 100644
|
|
--- a/libmultipath/configure.c
|
|
+++ b/libmultipath/configure.c
|
|
@@ -397,7 +397,7 @@ int setup_map(struct multipath *mpp, char *params, int params_size,
|
|
start_io_err_stat_thread(vecs);
|
|
|
|
n_paths = VECTOR_SIZE(mpp->paths);
|
|
- /*
|
|
+ /*
|
|
* assign paths to path groups -- start with no groups and all paths
|
|
* in mpp->paths
|
|
*/
|
|
diff --git a/libmultipath/devmapper.c b/libmultipath/devmapper.c
|
|
index 47a6d60e..945e625b 100644
|
|
--- a/libmultipath/devmapper.c
|
|
+++ b/libmultipath/devmapper.c
|
|
@@ -602,8 +602,8 @@ int dm_addmap_reload(struct multipath *mpp, char *params, int flush)
|
|
return r;
|
|
|
|
/* If the resume failed, dm will leave the device suspended, and
|
|
- * drop the new table, so doing a second resume will try using
|
|
- * the original table */
|
|
+ * drop the new table, so doing a second resume will try using
|
|
+ * the original table */
|
|
if (dm_is_suspended(mpp->alias))
|
|
dm_simplecmd(DM_DEVICE_RESUME, mpp->alias, !flush, 1,
|
|
udev_flags, 0);
|
|
diff --git a/libmultipath/sysfs.c b/libmultipath/sysfs.c
|
|
index 7a2af1ea..9ff145f2 100644
|
|
--- a/libmultipath/sysfs.c
|
|
+++ b/libmultipath/sysfs.c
|
|
@@ -358,7 +358,7 @@ bool sysfs_is_multipathed(struct path *pp, bool set_wwid)
|
|
strchop(pp->wwid);
|
|
}
|
|
}
|
|
- } else if (nr < 0)
|
|
+ } else if (nr < 0)
|
|
condlog(1, "%s: error reading from %s: %m",
|
|
__func__, pathbuf);
|
|
|
|
diff --git a/multipath/multipath.8 b/multipath/multipath.8
|
|
index 5b29a5d9..17df59f5 100644
|
|
--- a/multipath/multipath.8
|
|
+++ b/multipath/multipath.8
|
|
@@ -225,7 +225,7 @@ Dry run, do not create or update devmaps.
|
|
.TP
|
|
.B \-e
|
|
Enable all foreign libraries. This overrides the
|
|
-.I enable_foreign
|
|
+.I enable_foreign
|
|
option from \fBmultipath.conf(5)\fR.
|
|
.
|
|
.TP
|
|
diff --git a/multipathd/cli_handlers.c b/multipathd/cli_handlers.c
|
|
index 59d44b45..d70e1dbc 100644
|
|
--- a/multipathd/cli_handlers.c
|
|
+++ b/multipathd/cli_handlers.c
|
|
@@ -1215,7 +1215,7 @@ cli_reconfigure(void * v, char ** reply, int * len, void * data)
|
|
|
|
condlog(2, "reconfigure (operator)");
|
|
|
|
- rc = set_config_state(DAEMON_CONFIGURE);
|
|
+ rc = set_config_state(DAEMON_CONFIGURE);
|
|
if (rc == ETIMEDOUT) {
|
|
condlog(2, "timeout starting reconfiguration");
|
|
return 1;
|
|
diff --git a/multipathd/main.c b/multipathd/main.c
|
|
index 2251e02c..bdd629e7 100644
|
|
--- a/multipathd/main.c
|
|
+++ b/multipathd/main.c
|
|
@@ -2014,7 +2014,7 @@ static int check_path_reinstate_state(struct path * pp) {
|
|
|
|
/* If path became failed again or continue failed, should reset
|
|
* path san_path_err_forget_rate and path dis_reinstate_time to
|
|
- * start a new stable check.
|
|
+ * start a new stable check.
|
|
*/
|
|
if ((pp->state != PATH_UP) && (pp->state != PATH_GHOST) &&
|
|
(pp->state != PATH_DELAYED)) {
|