2b0cd7cceb
Rebased on top of Martin Wilck's queue of ACKed upstream commits * https://github.com/openSUSE/multipath-tools/tree/upstream-queue * All previous patches have been reordered, with the exception of 0011-libdmmp-Add-support-for-upcoming-json-c-0.14.0.patch which has been replaced with 0029-fix-boolean-value-with-json-c-0.14.patch Modify 0054-RH-add-mpathconf.patch * remove default enable_foreign and property blacklist_exceptions settings, and deal with the builtin default change from 0031-libmultipath-set-enable_foreign-to-NONE-by-default.patch. Fixes bz #1853668 Add 0048-Makefile.inc-trim-extra-information-from-systemd-ver.patch Add 0049-kpartx-fix-Wsign-compare-error.patch * The above two patches have been submitted upstream
31 lines
999 B
Diff
31 lines
999 B
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Benjamin Marzinski <bmarzins@redhat.com>
|
|
Date: Mon, 6 Jul 2020 13:21:12 -0500
|
|
Subject: [PATCH] Makefile.inc: trim extra information from systemd version
|
|
|
|
Some systemd versions print extra information in the
|
|
"pkg-config --modversion" output, which confuses make. Trim this
|
|
off.
|
|
|
|
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
|
---
|
|
Makefile.inc | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile.inc b/Makefile.inc
|
|
index e7256e3a..8ea3352d 100644
|
|
--- a/Makefile.inc
|
|
+++ b/Makefile.inc
|
|
@@ -37,7 +37,7 @@ endif
|
|
|
|
ifndef SYSTEMD
|
|
ifeq ($(shell pkg-config --modversion libsystemd >/dev/null 2>&1 && echo 1), 1)
|
|
- SYSTEMD = $(shell pkg-config --modversion libsystemd)
|
|
+ SYSTEMD = $(shell pkg-config --modversion libsystemd | awk '{print $$1}')
|
|
else
|
|
ifeq ($(shell systemctl --version >/dev/null 2>&1 && echo 1), 1)
|
|
SYSTEMD = $(shell systemctl --version 2> /dev/null | \
|
|
--
|
|
2.17.2
|
|
|