942c9b6ed8
Update Source to upstream version 0.8.2 * Previoud patches 0001-0017 & 0027 are included in this commit Rename files * Previous patches 0018-0026 & 0028 are not patches 0021-0030 Add 0001-libmultipath-make-vector_foreach_slot_backwards-work.patch Add 0002-libmultipath-add-marginal-paths-and-groups-infrastru.patch Add 0003-tests-add-path-grouping-policy-unit-tests.patch Add 0004-libmultipath-add-wrapper-function-around-pgpolicyfn.patch Add 0005-tests-update-pgpolicy-tests-to-work-with-group_paths.patch Add 0006-libmultipath-fix-double-free-in-pgpolicyfn-error-pat.patch Add 0007-libmultipath-consolidate-group_by_-functions.patch Add 0008-libmultipath-make-pgpolicyfn-take-a-paths-vector.patch Add 0009-libmultipath-make-group_paths-handle-marginal-paths.patch Add 0010-tests-add-tests-for-grouping-marginal-paths.patch Add 0011-libmultipath-add-marginal_pathgroups-config-option.patch Add 0012-libmutipath-deprecate-delay_-_checks.patch Add 0013-multipathd-use-marginal_pathgroups.patch Add 0014-multipath-update-man-pages.patch * The above 13 patches add the marinal_pathgroups option Add 0015-multipath.conf-add-enable_foreign-parameter.patch Add 0016-multipath.conf.5-document-foreign-library-support.patch * The above 2 patches add the enable_foreign option Add 0017-mpathpersist-remove-broken-unused-code.patch Add 0018-libmultipath-EMC-PowerMax-NVMe-device-config.patch Add 0019-mpathpersist-fix-leaks.patch Add 0020-libmultipath-fix-mpcontext-initialization.patch * The above 20 patches have been submitted upstream
54 lines
2.0 KiB
Diff
54 lines
2.0 KiB
Diff
From e08dd1d6abe62714c484b046a68c95c3803716dd Mon Sep 17 00:00:00 2001
|
|
From: Benjamin Marzinski <bmarzins@redhat.com>
|
|
Date: Wed, 19 Apr 2017 06:10:01 -0500
|
|
Subject: [PATCH] RH: use rpm optflags if present
|
|
|
|
Use the passed in optflags when compiling as an RPM, and keep the
|
|
default flags as close as possible to the current fedora flags, while
|
|
still being generic.
|
|
|
|
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
|
---
|
|
Makefile.inc | 24 ++++++++++++++++--------
|
|
1 file changed, 16 insertions(+), 8 deletions(-)
|
|
|
|
diff --git a/Makefile.inc b/Makefile.inc
|
|
index 2e8946ca..1b2f47a8 100644
|
|
--- a/Makefile.inc
|
|
+++ b/Makefile.inc
|
|
@@ -88,15 +88,23 @@ TEST_CC_OPTION = $(shell \
|
|
echo "$(2)"; \
|
|
fi)
|
|
|
|
-STACKPROT := $(call TEST_CC_OPTION,-fstack-protector-strong,-fstack-protector)
|
|
ERROR_DISCARDED_QUALIFIERS := $(call TEST_CC_OPTION,-Werror=discarded-qualifiers,)
|
|
-
|
|
-OPTFLAGS = -O2 -g -pipe -Wall -Wextra -Wformat=2 -Werror=implicit-int \
|
|
- -Werror=implicit-function-declaration -Werror=format-security \
|
|
- -Wno-sign-compare -Wno-unused-parameter -Wno-clobbered \
|
|
- -Werror=cast-qual $(ERROR_DISCARDED_QUALIFIERS) \
|
|
- -Wp,-D_FORTIFY_SOURCE=2 $(STACKPROT) \
|
|
- --param=ssp-buffer-size=4
|
|
+ifndef RPM_OPT_FLAGS
|
|
+ STACKPROT := $(call TEST_CC_OPTION,-fstack-protector-strong,-fstack-protector)
|
|
+ OPTFLAGS = -O2 -g -pipe -Wall -Werror=format-security \
|
|
+ -Wp,-D_FORTIFY_SOURCE=2 -fexceptions \
|
|
+ $(STACKPROT) --param=ssp-buffer-size=4 \
|
|
+ -grecord-gcc-switches
|
|
+ ifeq ($(shell test -f /usr/lib/rpm/redhat/redhat-hardened-cc1 && echo 1),1)
|
|
+ OPTFLAGS += -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1
|
|
+ endif
|
|
+else
|
|
+ OPTFLAGS = $(RPM_OPT_FLAGS)
|
|
+endif
|
|
+OPTFLAGS += -Wextra -Wstrict-prototypes -Wformat=2 -Werror=implicit-int \
|
|
+ -Werror=implicit-function-declaration -Wno-sign-compare \
|
|
+ -Wno-unused-parameter $(ERROR_DISCARDED_QUALIFIERS) \
|
|
+ -Werror=cast-qual
|
|
|
|
CFLAGS := $(OPTFLAGS) -DBIN_DIR=\"$(bindir)\" -DLIB_STRING=\"${LIB}\" -DRUN_DIR=\"${RUN}\" \
|
|
-MMD -MP $(CFLAGS)
|
|
--
|
|
2.17.2
|
|
|