34 lines
1.2 KiB
Diff
34 lines
1.2 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Martin Wilck <mwilck@suse.com>
|
|
Date: Tue, 12 May 2020 00:39:24 +0200
|
|
Subject: [PATCH] multipath-tools: Makefile.inc: set -Wno-error=clobbered
|
|
|
|
We need to ignore -Wclobbered because gcc has trouble dealing with glibc's
|
|
implementation of pthread_cleanup_push().
|
|
|
|
For some variants of gcc, -Wno-clobbered alone isn't enough if -Werror is also
|
|
set. Compilation with -Wno-error=clobbered works, though.
|
|
|
|
Signed-off-by: Martin Wilck <mwilck@suse.com>
|
|
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
|
---
|
|
Makefile.inc | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile.inc b/Makefile.inc
|
|
index d4d1e0dd..9060ac9b 100644
|
|
--- a/Makefile.inc
|
|
+++ b/Makefile.inc
|
|
@@ -91,7 +91,7 @@ TEST_CC_OPTION = $(shell \
|
|
|
|
STACKPROT := $(call TEST_CC_OPTION,-fstack-protector-strong,-fstack-protector)
|
|
ERROR_DISCARDED_QUALIFIERS := $(call TEST_CC_OPTION,-Werror=discarded-qualifiers,)
|
|
-WNOCLOBBERED := $(call TEST_CC_OPTION,-Wno-clobbered,)
|
|
+WNOCLOBBERED := $(call TEST_CC_OPTION,-Wno-clobbered -Wno-error=clobbered,)
|
|
|
|
OPTFLAGS = -O2 -g -pipe -Werror -Wall -Wextra -Wformat=2 -Werror=implicit-int \
|
|
-Werror=implicit-function-declaration -Werror=format-security \
|
|
--
|
|
2.17.2
|
|
|