19ddc43848
Update Source to upstream version 0.8.7 plus upstream staged commits * Previous patches 0011-0016 & 0018-0022 are included in the source tarball * Fixes bz#2017592 Rename files * Previous patches 0001-0010 are now patches 0013-0022 Modify 0018-RH-add-mpathconf.patch * merged with previous patch 0017 Add 0023-libmulitpath-add-section-name-to-invalid-keyword-out.patch * Fixes bz#1984303 Fix multipath_conf_syntax test to work with bz #1984303 Resolves: bz #1984303, #2017592
59 lines
2.4 KiB
Diff
59 lines
2.4 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Benjamin Marzinski <bmarzins@redhat.com>
|
|
Date: Wed, 19 Apr 2017 06:10:01 -0500
|
|
Subject: [PATCH] RH: use rpm optflags if present
|
|
|
|
Use the passed in optflags when compiling as an RPM, and keep the
|
|
default flags as close as possible to the current fedora flags, while
|
|
still being generic.
|
|
|
|
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
|
---
|
|
Makefile.inc | 24 ++++++++++++++++++------
|
|
1 file changed, 18 insertions(+), 6 deletions(-)
|
|
|
|
diff --git a/Makefile.inc b/Makefile.inc
|
|
index 2a75dc9c..db35feb6 100644
|
|
--- a/Makefile.inc
|
|
+++ b/Makefile.inc
|
|
@@ -92,16 +92,28 @@ TEST_CC_OPTION = $(shell \
|
|
echo "$(2)"; \
|
|
fi)
|
|
|
|
-STACKPROT := $(call TEST_CC_OPTION,-fstack-protector-strong,-fstack-protector)
|
|
ERROR_DISCARDED_QUALIFIERS := $(call TEST_CC_OPTION,-Werror=discarded-qualifiers,)
|
|
WNOCLOBBERED := $(call TEST_CC_OPTION,-Wno-clobbered -Wno-error=clobbered,)
|
|
WFORMATOVERFLOW := $(call TEST_CC_OPTION,-Wformat-overflow=2,)
|
|
|
|
-OPTFLAGS := -O2 -g $(STACKPROT) --param=ssp-buffer-size=4
|
|
-WARNFLAGS := -Werror -Wall -Wextra -Wformat=2 $(WFORMATOVERFLOW) -Werror=implicit-int \
|
|
+ifndef RPM_OPT_FLAGS
|
|
+ STACKPROT := $(call TEST_CC_OPTION,-fstack-protector-strong,-fstack-protector)
|
|
+ OPTFLAGS := -O2 -g -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions \
|
|
+ $(STACKPROT) -grecord-gcc-switches \
|
|
+ -fasynchronous-unwind-tables --param=ssp-buffer-size=4
|
|
+ ifeq ($(shell test -f /usr/lib/rpm/redhat/redhat-hardened-cc1 && echo 1),1)
|
|
+ OPTFLAGS += -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1
|
|
+ endif
|
|
+ ifeq ($(shell test -f /usr/lib/rpm/redhat/redhat-annobin-cc1 && echo 1),1)
|
|
+ OPTFLAGS += -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1
|
|
+ endif
|
|
+else
|
|
+ OPTFLAGS := $(RPM_OPT_FLAGS) --param=ssp-buffer-size=4
|
|
+endif
|
|
+WARNFLAGS := -Werror -Wextra -Wformat=2 $(WFORMATOVERFLOW) -Werror=implicit-int \
|
|
-Werror=implicit-function-declaration -Werror=format-security \
|
|
- $(WNOCLOBBERED) -Werror=cast-qual $(ERROR_DISCARDED_QUALIFIERS)
|
|
-CPPFLAGS := -Wp,-D_FORTIFY_SOURCE=2
|
|
+ $(WNOCLOBBERED) -Werror=cast-qual $(ERROR_DISCARDED_QUALIFIERS) \
|
|
+ -Wstrict-prototypes
|
|
CFLAGS := --std=gnu99 $(CFLAGS) $(OPTFLAGS) $(WARNFLAGS) -pipe \
|
|
-DBIN_DIR=\"$(bindir)\" -DLIB_STRING=\"${LIB}\" -DRUN_DIR=\"${RUN}\" \
|
|
-MMD -MP
|
|
@@ -139,4 +151,4 @@ check_file = $(shell \
|
|
|
|
%.o: %.c
|
|
@echo building $@ because of $?
|
|
- $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
|
|
+ $(CC) $(CFLAGS) -c -o $@ $<
|