c9012ec5b7
Modify 0004-RH-Remove-the-property-blacklist-exception-builtin.patch * update multipath.conf.5 man page to remove builtin listing Modify 0005-RH-don-t-start-without-a-config-file.patch * update multipathd.8 man page to note that a config file is necessary Modify 0007-RH-add-mpathconf.patch * add property blacklist-exception to default config file Add 0010-libmultipath-change-how-RADOS-checker-is-enabled.patch * Makefile now autodetects librados. Posted upstream Remove related RADOS option from spec file Add 0011-multipath-set-verbosity-to-default-during-config.patch * Allow multipath to print warning messages during configuration. Posted upstream Add 0012-mpath-skip-device-configs-without-vendor-product.patch * device entries without vendor/product were breaking configurations. Posted upsteam Add 0013-multipathd-fix-show-maps-json-crash.patch * multipathd crashed showing json output with no devices. Posted upstream
57 lines
1.5 KiB
Diff
57 lines
1.5 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Benjamin Marzinski <bmarzins@redhat.com>
|
|
Date: Fri, 26 May 2017 17:52:57 -0500
|
|
Subject: [PATCH] libmultipath: change how RADOS checker is enabled
|
|
|
|
Instead of making the user call "make", "make install" and "make clean"
|
|
with ENABLE_RADOS set correctly, have the makefile check if
|
|
/usr/include/rados/librados.h exists, just like it checks if specific
|
|
functions exist in a file.
|
|
|
|
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
|
---
|
|
Makefile.inc | 13 +++++++++++++
|
|
libmultipath/checkers/Makefile | 3 ++-
|
|
2 files changed, 15 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile.inc b/Makefile.inc
|
|
index ffcc8b6..ecac8eb 100644
|
|
--- a/Makefile.inc
|
|
+++ b/Makefile.inc
|
|
@@ -115,5 +115,18 @@ check_func = \
|
|
echo "$$found" \
|
|
)
|
|
|
|
+# Checker whether a file with name $1 exists
|
|
+check_file = $(shell \
|
|
+ if [ -f "$1" ]; then \
|
|
+ found=1; \
|
|
+ status="yes"; \
|
|
+ else \
|
|
+ found=0; \
|
|
+ status="no"; \
|
|
+ fi; \
|
|
+ echo 1>&2 "Checking if $1 exists ... $$status"; \
|
|
+ echo "$$found" \
|
|
+ )
|
|
+
|
|
%.o: %.c
|
|
$(CC) $(CFLAGS) -c -o $@ $<
|
|
diff --git a/libmultipath/checkers/Makefile b/libmultipath/checkers/Makefile
|
|
index 732ca9d..bce6b8b 100644
|
|
--- a/libmultipath/checkers/Makefile
|
|
+++ b/libmultipath/checkers/Makefile
|
|
@@ -14,7 +14,8 @@ LIBS= \
|
|
libcheckemc_clariion.so \
|
|
libcheckhp_sw.so \
|
|
libcheckrdac.so
|
|
-ifneq ($(ENABLE_RADOS),0)
|
|
+
|
|
+ifneq ($(call check_file,/usr/include/rados/librados.h),0)
|
|
LIBS += libcheckrbd.so
|
|
endif
|
|
|
|
--
|
|
2.7.4
|
|
|