a4bb435b33
- Update Source to the latest upstream commit - Add 0001-libmultipath-add-comment-about-resuming.patch * posted upstream - Add 0002-multipath-attempt-at-common-multipath.rules.patch * under discussion upstream - Add 0003-RH-fixup-udev-rules-for-redhat.patch * Redhat uses different udev rules that some other distros, so multipath has run at a different time. Not all upstream distros link /sbin and /usr/sbin either. - Add 0004-RH-Remove-the-property-blacklist-exception-builtin.patch * Allow multipath to be used on devices without multiple paths. NAK'ed upstream, but requested by Red Hat - Add 0005-RH-don-t-start-without-a-config-file.patch * Don't start multipath unless a config file exists. NAK'ed upstream, but requested by Red Hat - Add 0006-RH-use-rpm-optflags-if-present.patch * Make the build system fedora friendly - Add 0007-RH-add-mpathconf.patch * Add tool to help configure multipath with Red Hat defaults. - Add 0008-RH-add-wwids-from-kernel-cmdline-mpath.wwids-with-A.patch * Make multipath able to claim devices based on the kernel command line NAK'ed upstream but requested by Red Hat - Add 0009-RH-trigger-change-uevent-on-new-device-creation.patch * under discussion upstream
49 lines
1.7 KiB
Diff
49 lines
1.7 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Benjamin Marzinski <bmarzins@redhat.com>
|
|
Date: Wed, 19 Apr 2017 06:10:01 -0500
|
|
Subject: [PATCH] RH: use rpm optflags if present
|
|
|
|
Use the passed in optflags when compiling as an RPM, and keep the
|
|
default flags as close as possible to the current fedora flags, while
|
|
still being generic.
|
|
|
|
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
|
---
|
|
Makefile.inc | 20 +++++++++++++-------
|
|
1 file changed, 13 insertions(+), 7 deletions(-)
|
|
|
|
diff --git a/Makefile.inc b/Makefile.inc
|
|
index 2591fa9..ffcc8b6 100644
|
|
--- a/Makefile.inc
|
|
+++ b/Makefile.inc
|
|
@@ -80,13 +80,19 @@ TEST_CC_OPTION = $(shell \
|
|
echo "$(2)"; \
|
|
fi)
|
|
|
|
-STACKPROT := $(call TEST_CC_OPTION,-fstack-protector-strong,-fstack-protector)
|
|
-
|
|
-OPTFLAGS = -O2 -g -pipe -Wall -Wextra -Wformat=2 -Werror=implicit-int \
|
|
- -Werror=implicit-function-declaration -Werror=format-security \
|
|
- -Wno-sign-compare -Wno-unused-parameter -Wno-clobbered \
|
|
- -Wp,-D_FORTIFY_SOURCE=2 $(STACKPROT) \
|
|
- --param=ssp-buffer-size=4
|
|
+ifndef RPM_OPT_FLAGS
|
|
+ STACKPROT := $(call TEST_CC_OPTION,-fstack-protector-strong,-fstack-protector)
|
|
+ OPTFLAGS = -O2 -g -pipe -Wall -Werror=format-security \
|
|
+ -Wp,-D_FORTIFY_SOURCE=2 -fexceptions \
|
|
+ $(STACKPROT) --param=ssp-buffer-size=4 \
|
|
+ -grecord-gcc-switches
|
|
+ ifeq ($(shell test -f /usr/lib/rpm/redhat/redhat-hardened-cc1 && echo 1),1)
|
|
+ OPTFLAGS += -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1
|
|
+ endif
|
|
+endif
|
|
+OPTFLAGS += -Wextra -Wstrict-prototypes -Wformat=2 -Werror=implicit-int \
|
|
+ -Werror=implicit-function-declaration -Wno-sign-compare \
|
|
+ -Wno-unused-parameter
|
|
|
|
CFLAGS = $(OPTFLAGS) -DLIB_STRING=\"${LIB}\" -DRUN_DIR=\"${RUN}\"
|
|
BIN_CFLAGS = -fPIE -DPIE
|
|
--
|
|
2.7.4
|
|
|