c7ea1a3b8d
commit id: d678c139719d5631194b50e49f16ca97162ecd0f) moved multipath bindings file from /var/lib/multipath to /etc/multipath Fixed 354961, 432520
48 lines
1.9 KiB
Diff
48 lines
1.9 KiB
Diff
---
|
|
multipath/Makefile | 4 ++--
|
|
multipath/multipath.rules | 13 +++++++------
|
|
2 files changed, 9 insertions(+), 8 deletions(-)
|
|
|
|
Index: multipath-tools-090724/multipath/Makefile
|
|
===================================================================
|
|
--- multipath-tools-090724.orig/multipath/Makefile
|
|
+++ multipath-tools-090724/multipath/Makefile
|
|
@@ -22,7 +22,7 @@ install:
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(bindir)
|
|
$(INSTALL_PROGRAM) -m 755 $(EXEC) mpath_wait $(DESTDIR)$(bindir)/
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)/etc/udev/rules.d
|
|
- $(INSTALL_PROGRAM) -m 644 multipath.rules $(DESTDIR)/etc/udev/rules.d/
|
|
+ $(INSTALL_PROGRAM) -m 644 multipath.rules $(DESTDIR)/etc/udev/rules.d/40-multipath.rules
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(mandir)
|
|
$(INSTALL_PROGRAM) -m 644 $(EXEC).8.gz $(DESTDIR)$(mandir)
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(man5dir)
|
|
@@ -32,7 +32,7 @@ install:
|
|
fi
|
|
|
|
uninstall:
|
|
- rm $(DESTDIR)/etc/udev/rules.d/multipath.rules
|
|
+ rm $(DESTDIR)/etc/udev/rules.d/40-multipath.rules
|
|
rm $(DESTDIR)$(bindir)/$(EXEC)
|
|
rm $(DESTDIR)$(bindir)/mpath_wait
|
|
rm $(DESTDIR)$(mandir)/$(EXEC).8.gz
|
|
Index: multipath-tools-090724/multipath/multipath.rules
|
|
===================================================================
|
|
--- multipath-tools-090724.orig/multipath/multipath.rules
|
|
+++ multipath-tools-090724/multipath/multipath.rules
|
|
@@ -1,7 +1,8 @@
|
|
-#
|
|
-# udev rules for multipathing.
|
|
-# The persistent symlinks are created with the kpartx rules
|
|
-#
|
|
-
|
|
-# socket for uevents
|
|
-SUBSYSTEM=="block", RUN+="socket:/org/kernel/dm/multipath_event"
|
|
+# multipath wants the devmaps presented as meaninglful device names
|
|
+# so name them after their devmap name
|
|
+SUBSYSTEM!="block", GOTO="end_mpath"
|
|
+RUN+="socket:/org/kernel/dm/multipath_event"
|
|
+KERNEL!="dm-[0-9]*", GOTO="end_mpath"
|
|
+PROGRAM!="/sbin/mpath_wait %M %m", GOTO="end_mpath"
|
|
+ACTION=="add", RUN+="/sbin/dmsetup ls --target multipath --exec '/sbin/kpartx -a -p p' -j %M -m %m"
|
|
+LABEL="end_mpath"
|