device-mapper-multipath-0.8.7-2
Modify 0017-RH-use-rpm-optflags-if-present.patch * use RPM_LF_FLAGS Modify 0018-RH-add-mpathconf.patch * update default config to match multipath changes Modify 0022-RH-make-parse_vpd_pg83-match-scsi_id-output.patch * fix cmocka vpd tests Rename 0023-libmulitpath-add-section-name-to-invalid-keyword-out.patch to 0023-libmultipath-add-section-name-to-invalid-keyword-out.patch Resolves: bz#2017592
This commit is contained in:
parent
19ddc43848
commit
ef624c5d3e
@ -9,14 +9,14 @@ still being generic.
|
|||||||
|
|
||||||
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
||||||
---
|
---
|
||||||
Makefile.inc | 24 ++++++++++++++++++------
|
Makefile.inc | 26 +++++++++++++++++++-------
|
||||||
1 file changed, 18 insertions(+), 6 deletions(-)
|
1 file changed, 19 insertions(+), 7 deletions(-)
|
||||||
|
|
||||||
diff --git a/Makefile.inc b/Makefile.inc
|
diff --git a/Makefile.inc b/Makefile.inc
|
||||||
index 2a75dc9c..db35feb6 100644
|
index 2a75dc9c..5ac660de 100644
|
||||||
--- a/Makefile.inc
|
--- a/Makefile.inc
|
||||||
+++ b/Makefile.inc
|
+++ b/Makefile.inc
|
||||||
@@ -92,16 +92,28 @@ TEST_CC_OPTION = $(shell \
|
@@ -92,23 +92,35 @@ TEST_CC_OPTION = $(shell \
|
||||||
echo "$(2)"; \
|
echo "$(2)"; \
|
||||||
fi)
|
fi)
|
||||||
|
|
||||||
@ -50,6 +50,14 @@ index 2a75dc9c..db35feb6 100644
|
|||||||
CFLAGS := --std=gnu99 $(CFLAGS) $(OPTFLAGS) $(WARNFLAGS) -pipe \
|
CFLAGS := --std=gnu99 $(CFLAGS) $(OPTFLAGS) $(WARNFLAGS) -pipe \
|
||||||
-DBIN_DIR=\"$(bindir)\" -DLIB_STRING=\"${LIB}\" -DRUN_DIR=\"${RUN}\" \
|
-DBIN_DIR=\"$(bindir)\" -DLIB_STRING=\"${LIB}\" -DRUN_DIR=\"${RUN}\" \
|
||||||
-MMD -MP
|
-MMD -MP
|
||||||
|
BIN_CFLAGS = -fPIE -DPIE
|
||||||
|
LIB_CFLAGS = -fPIC
|
||||||
|
SHARED_FLAGS = -shared
|
||||||
|
-LDFLAGS := $(LDFLAGS) -Wl,-z,relro -Wl,-z,now -Wl,-z,defs
|
||||||
|
+LDFLAGS := $(LDFLAGS) $(RPM_LD_FLAGS) -Wl,-z,relro -Wl,-z,now -Wl,-z,defs
|
||||||
|
BIN_LDFLAGS = -pie
|
||||||
|
|
||||||
|
# Check whether a function with name $1 has been declared in header file $2.
|
||||||
@@ -139,4 +151,4 @@ check_file = $(shell \
|
@@ -139,4 +151,4 @@ check_file = $(shell \
|
||||||
|
|
||||||
%.o: %.c
|
%.o: %.c
|
||||||
|
@ -14,9 +14,9 @@ Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
|||||||
---
|
---
|
||||||
libmultipath/config.c | 2 +
|
libmultipath/config.c | 2 +
|
||||||
multipath/Makefile | 5 +
|
multipath/Makefile | 5 +
|
||||||
multipath/mpathconf | 561 ++++++++++++++++++++++++++++++++++++++++++
|
multipath/mpathconf | 556 ++++++++++++++++++++++++++++++++++++++++++
|
||||||
multipath/mpathconf.8 | 135 ++++++++++
|
multipath/mpathconf.8 | 135 ++++++++++
|
||||||
4 files changed, 703 insertions(+)
|
4 files changed, 698 insertions(+)
|
||||||
create mode 100644 multipath/mpathconf
|
create mode 100644 multipath/mpathconf
|
||||||
create mode 100644 multipath/mpathconf.8
|
create mode 100644 multipath/mpathconf.8
|
||||||
|
|
||||||
@ -69,10 +69,10 @@ index b9bbb3cf..e720c7f6 100644
|
|||||||
$(RM) core *.o $(EXEC) *.gz
|
$(RM) core *.o $(EXEC) *.gz
|
||||||
diff --git a/multipath/mpathconf b/multipath/mpathconf
|
diff --git a/multipath/mpathconf b/multipath/mpathconf
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 00000000..039b3e47
|
index 00000000..c00d2555
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/multipath/mpathconf
|
+++ b/multipath/mpathconf
|
||||||
@@ -0,0 +1,561 @@
|
@@ -0,0 +1,556 @@
|
||||||
+#!/bin/bash
|
+#!/bin/bash
|
||||||
+#
|
+#
|
||||||
+# Copyright (C) 2010 Red Hat, Inc. All rights reserved.
|
+# Copyright (C) 2010 Red Hat, Inc. All rights reserved.
|
||||||
@ -107,11 +107,6 @@ index 00000000..039b3e47
|
|||||||
+defaults {
|
+defaults {
|
||||||
+ user_friendly_names yes
|
+ user_friendly_names yes
|
||||||
+ find_multipaths yes
|
+ find_multipaths yes
|
||||||
+ enable_foreign \"^$\"
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+blacklist_exceptions {
|
|
||||||
+ property \"(SCSI_IDENT_|ID_WWN)\"
|
|
||||||
+}"
|
+}"
|
||||||
+
|
+
|
||||||
+CONFIGFILE="/etc/multipath.conf"
|
+CONFIGFILE="/etc/multipath.conf"
|
||||||
@ -130,7 +125,7 @@ index 00000000..039b3e47
|
|||||||
+ echo "Only allow certain wwids (instead of enable): --allow <WWID>"
|
+ echo "Only allow certain wwids (instead of enable): --allow <WWID>"
|
||||||
+ echo "Set user_friendly_names (Default y): --user_friendly_names <y|n>"
|
+ echo "Set user_friendly_names (Default y): --user_friendly_names <y|n>"
|
||||||
+ echo "Set find_multipaths (Default y): --find_multipaths <yes|no|strict|greedy|smart>"
|
+ echo "Set find_multipaths (Default y): --find_multipaths <yes|no|strict|greedy|smart>"
|
||||||
+ echo "Set default property blacklist (Default y): --property_blacklist <y|n>"
|
+ echo "Set default property blacklist (Default n): --property_blacklist <y|n>"
|
||||||
+ echo "Set enable_foreign to show foreign devices (Default n): --enable_foreign <y|n>"
|
+ echo "Set enable_foreign to show foreign devices (Default n): --enable_foreign <y|n>"
|
||||||
+ echo "Load the dm-multipath modules on enable (Default y): --with_module <y|n>"
|
+ echo "Load the dm-multipath modules on enable (Default y): --with_module <y|n>"
|
||||||
+ echo "start/stop/reload multipathd (Default n): --with_multipathd <y|n>"
|
+ echo "start/stop/reload multipathd (Default n): --with_multipathd <y|n>"
|
||||||
|
@ -10,7 +10,8 @@ that.
|
|||||||
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
||||||
---
|
---
|
||||||
libmultipath/discovery.c | 18 ++----------------
|
libmultipath/discovery.c | 18 ++----------------
|
||||||
1 file changed, 2 insertions(+), 16 deletions(-)
|
tests/vpd.c | 6 ++++++
|
||||||
|
2 files changed, 8 insertions(+), 16 deletions(-)
|
||||||
|
|
||||||
diff --git a/libmultipath/discovery.c b/libmultipath/discovery.c
|
diff --git a/libmultipath/discovery.c b/libmultipath/discovery.c
|
||||||
index f25fe9e3..6fb81c28 100644
|
index f25fe9e3..6fb81c28 100644
|
||||||
@ -49,3 +50,53 @@ index f25fe9e3..6fb81c28 100644
|
|||||||
case 0x1:
|
case 0x1:
|
||||||
/* T-10 Vendor ID: Prio 2 */
|
/* T-10 Vendor ID: Prio 2 */
|
||||||
if (prio < 2) {
|
if (prio < 2) {
|
||||||
|
diff --git a/tests/vpd.c b/tests/vpd.c
|
||||||
|
index 8e730d37..7bf7990f 100644
|
||||||
|
--- a/tests/vpd.c
|
||||||
|
+++ b/tests/vpd.c
|
||||||
|
@@ -230,11 +230,13 @@ static const char * const str_prefix[] = {
|
||||||
|
[STR_IQN] = "iqn.",
|
||||||
|
};
|
||||||
|
|
||||||
|
+#if 0
|
||||||
|
static const char byte0[] = {
|
||||||
|
[STR_EUI] = '2',
|
||||||
|
[STR_NAA] = '3',
|
||||||
|
[STR_IQN] = '8',
|
||||||
|
};
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
/**
|
||||||
|
* create_scsi_string_desc() - create a SCSI name string descriptor.
|
||||||
|
@@ -659,6 +661,7 @@ make_test_vpd_naa(2, 18);
|
||||||
|
make_test_vpd_naa(2, 17);
|
||||||
|
make_test_vpd_naa(2, 16);
|
||||||
|
|
||||||
|
+#if 0
|
||||||
|
/* SCSI Name string: EUI64, WWID size: 17 */
|
||||||
|
make_test_vpd_str(0, 20, 18)
|
||||||
|
make_test_vpd_str(0, 20, 17)
|
||||||
|
@@ -694,6 +697,7 @@ make_test_vpd_str(18, 20, 18)
|
||||||
|
make_test_vpd_str(18, 20, 17)
|
||||||
|
make_test_vpd_str(18, 20, 16)
|
||||||
|
make_test_vpd_str(18, 20, 15)
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
static int test_vpd(void)
|
||||||
|
{
|
||||||
|
@@ -767,6 +771,7 @@ static int test_vpd(void)
|
||||||
|
cmocka_unit_test(test_vpd_naa_2_18),
|
||||||
|
cmocka_unit_test(test_vpd_naa_2_17),
|
||||||
|
cmocka_unit_test(test_vpd_naa_2_16),
|
||||||
|
+/*
|
||||||
|
cmocka_unit_test(test_vpd_str_0_20_18),
|
||||||
|
cmocka_unit_test(test_vpd_str_0_20_17),
|
||||||
|
cmocka_unit_test(test_vpd_str_0_20_16),
|
||||||
|
@@ -791,6 +796,7 @@ static int test_vpd(void)
|
||||||
|
cmocka_unit_test(test_vpd_str_18_20_17),
|
||||||
|
cmocka_unit_test(test_vpd_str_18_20_16),
|
||||||
|
cmocka_unit_test(test_vpd_str_18_20_15),
|
||||||
|
+*/
|
||||||
|
};
|
||||||
|
return cmocka_run_group_tests(tests, setup, teardown);
|
||||||
|
}
|
||||||
|
@ -1,14 +1,14 @@
|
|||||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||||
From: Benjamin Marzinski <bmarzins@redhat.com>
|
From: Benjamin Marzinski <bmarzins@redhat.com>
|
||||||
Date: Thu, 23 Sep 2021 14:16:51 -0500
|
Date: Thu, 23 Sep 2021 14:16:51 -0500
|
||||||
Subject: [PATCH] libmulitpath: add section name to invalid keyword output
|
Subject: [PATCH] libmultipath: add section name to invalid keyword output
|
||||||
|
|
||||||
If users forget the closing brace for a section in multipath.conf,
|
If users forget the closing brace for a section in multipath.conf,
|
||||||
multipath has no way to detect that. When it sees the keyword at the
|
multipath has no way to detect that. When it sees the keyword at the
|
||||||
start of the next section, it will complain that there is an invalid
|
start of the next section, it will complain that there is an invalid
|
||||||
keyword, because that keyword doesn't belong in previous section (which
|
keyword, because that keyword doesn't belong in previous section (which
|
||||||
was never ended with a closing brace). This can confuse users. To make
|
was never ended with a closing brace). This can confuse users. To make
|
||||||
this easier to understand, when multipath prints and invalid keyword
|
this easier to understand, when multipath prints an invalid keyword
|
||||||
message, it now also prints the current section name, which can give
|
message, it now also prints the current section name, which can give
|
||||||
users a hint that they didn't end the previous section.
|
users a hint that they didn't end the previous section.
|
||||||
|
|
@ -1,6 +1,6 @@
|
|||||||
Name: device-mapper-multipath
|
Name: device-mapper-multipath
|
||||||
Version: 0.8.7
|
Version: 0.8.7
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Tools to manage multipath devices using device-mapper
|
Summary: Tools to manage multipath devices using device-mapper
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
URL: http://christophe.varoqui.free.fr/
|
URL: http://christophe.varoqui.free.fr/
|
||||||
@ -32,7 +32,7 @@ Patch0019: 0019-RH-add-wwids-from-kernel-cmdline-mpath.wwids-with-A.patch
|
|||||||
Patch0020: 0020-RH-reset-default-find_mutipaths-value-to-off.patch
|
Patch0020: 0020-RH-reset-default-find_mutipaths-value-to-off.patch
|
||||||
Patch0021: 0021-RH-attempt-to-get-ANA-info-via-sysfs-first.patch
|
Patch0021: 0021-RH-attempt-to-get-ANA-info-via-sysfs-first.patch
|
||||||
Patch0022: 0022-RH-make-parse_vpd_pg83-match-scsi_id-output.patch
|
Patch0022: 0022-RH-make-parse_vpd_pg83-match-scsi_id-output.patch
|
||||||
Patch0023: 0023-libmulitpath-add-section-name-to-invalid-keyword-out.patch
|
Patch0023: 0023-libmultipath-add-section-name-to-invalid-keyword-out.patch
|
||||||
|
|
||||||
# runtime
|
# runtime
|
||||||
Requires: %{name}-libs = %{version}-%{release}
|
Requires: %{name}-libs = %{version}-%{release}
|
||||||
@ -231,6 +231,17 @@ fi
|
|||||||
%{_pkgconfdir}/libdmmp.pc
|
%{_pkgconfdir}/libdmmp.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 08 2021 Benjamin Marzinski <bmarzins@redhat.com> - 0.8.7-2
|
||||||
|
- Modify 0017-RH-use-rpm-optflags-if-present.patch
|
||||||
|
* use RPM_LF_FLAGS
|
||||||
|
- Modify 0018-RH-add-mpathconf.patch
|
||||||
|
* update default config to match multipath changes
|
||||||
|
- Modify 0022-RH-make-parse_vpd_pg83-match-scsi_id-output.patch
|
||||||
|
* fix cmocka vpd tests
|
||||||
|
- Rename 0023-libmulitpath-add-section-name-to-invalid-keyword-out.patch to
|
||||||
|
0023-libmultipath-add-section-name-to-invalid-keyword-out.patch
|
||||||
|
- Resolves: bz#2017592
|
||||||
|
|
||||||
* Fri Oct 29 2021 Benjamin Marzinski <bmarzins@redhat.com> - 0.8.7-1
|
* Fri Oct 29 2021 Benjamin Marzinski <bmarzins@redhat.com> - 0.8.7-1
|
||||||
- Update Source to upstream version 0.8.7 plus upstream staged commits
|
- Update Source to upstream version 0.8.7 plus upstream staged commits
|
||||||
* Previous patches 0011-0016 & 0018-0022 are included in the source tarball
|
* Previous patches 0011-0016 & 0018-0022 are included in the source tarball
|
||||||
|
Loading…
Reference in New Issue
Block a user