device-mapper-multipath-0.8.7-5
Modify 0030-RH-add-mpathconf.patch * fix setting property_blacklist with no blacklist_exceptions section
This commit is contained in:
parent
18d73f2333
commit
81ff4f74fa
@ -14,9 +14,9 @@ Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
|||||||
---
|
---
|
||||||
libmultipath/config.c | 2 +
|
libmultipath/config.c | 2 +
|
||||||
multipath/Makefile | 5 +
|
multipath/Makefile | 5 +
|
||||||
multipath/mpathconf | 556 ++++++++++++++++++++++++++++++++++++++++++
|
multipath/mpathconf | 564 ++++++++++++++++++++++++++++++++++++++++++
|
||||||
multipath/mpathconf.8 | 135 ++++++++++
|
multipath/mpathconf.8 | 135 ++++++++++
|
||||||
4 files changed, 698 insertions(+)
|
4 files changed, 706 insertions(+)
|
||||||
create mode 100644 multipath/mpathconf
|
create mode 100644 multipath/mpathconf
|
||||||
create mode 100644 multipath/mpathconf.8
|
create mode 100644 multipath/mpathconf.8
|
||||||
|
|
||||||
@ -69,10 +69,10 @@ index b9bbb3cf..e720c7f6 100644
|
|||||||
$(RM) core *.o $(EXEC) *.gz
|
$(RM) core *.o $(EXEC) *.gz
|
||||||
diff --git a/multipath/mpathconf b/multipath/mpathconf
|
diff --git a/multipath/mpathconf b/multipath/mpathconf
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 00000000..c00d2555
|
index 00000000..0de6b121
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/multipath/mpathconf
|
+++ b/multipath/mpathconf
|
||||||
@@ -0,0 +1,556 @@
|
@@ -0,0 +1,564 @@
|
||||||
+#!/bin/bash
|
+#!/bin/bash
|
||||||
+#
|
+#
|
||||||
+# Copyright (C) 2010 Red Hat, Inc. All rights reserved.
|
+# Copyright (C) 2010 Red Hat, Inc. All rights reserved.
|
||||||
@ -571,7 +571,15 @@ index 00000000..c00d2555
|
|||||||
+ CHANGED_CONFIG=1
|
+ CHANGED_CONFIG=1
|
||||||
+ fi
|
+ fi
|
||||||
+elif [ "$PROPERTY" = "y" ]; then
|
+elif [ "$PROPERTY" = "y" ]; then
|
||||||
+ if [ -z "$HAVE_PROPERTY" ]; then
|
+ if [ -z "$HAVE_PROPERTY" -a -z "$HAVE_EXCEPTIONS" ]; then
|
||||||
|
+ cat >> $TMPFILE << _EOF_
|
||||||
|
+
|
||||||
|
+blacklist_exceptions {
|
||||||
|
+ property "(SCSI_IDENT_|ID_WWN)"
|
||||||
|
+}
|
||||||
|
+_EOF_
|
||||||
|
+ CHANGED_CONFIG=1
|
||||||
|
+ elif [ -z "$HAVE_PROPERTY" ]; then
|
||||||
+ sed -i '/^blacklist_exceptions[[:space:]]*{/ a\
|
+ sed -i '/^blacklist_exceptions[[:space:]]*{/ a\
|
||||||
+ property "(SCSI_IDENT_|ID_WWN)"
|
+ property "(SCSI_IDENT_|ID_WWN)"
|
||||||
+' $TMPFILE
|
+' $TMPFILE
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
Name: device-mapper-multipath
|
Name: device-mapper-multipath
|
||||||
Version: 0.8.7
|
Version: 0.8.7
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
Summary: Tools to manage multipath devices using device-mapper
|
Summary: Tools to manage multipath devices using device-mapper
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
URL: http://christophe.varoqui.free.fr/
|
URL: http://christophe.varoqui.free.fr/
|
||||||
@ -241,6 +241,10 @@ fi
|
|||||||
%{_pkgconfdir}/libdmmp.pc
|
%{_pkgconfdir}/libdmmp.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 6 2022 Benjamin Marzinski <bmarzins@redhat.com> - 0.8.7-5
|
||||||
|
- Modify 0030-RH-add-mpathconf.patch
|
||||||
|
* fix setting property_blacklist with no blacklist_exceptions section
|
||||||
|
|
||||||
* Mon Dec 13 2021 Benjamin Marzinski <bmarzins@redhat.com> - 0.8.7-4
|
* Mon Dec 13 2021 Benjamin Marzinski <bmarzins@redhat.com> - 0.8.7-4
|
||||||
- Update to the head of the upstream staging branch
|
- Update to the head of the upstream staging branch
|
||||||
* Patches 0013 - 0024 are from the upstream staging branch
|
* Patches 0013 - 0024 are from the upstream staging branch
|
||||||
|
Loading…
Reference in New Issue
Block a user