Fixed build issue on i686 machines.
This commit is contained in:
parent
0499e0d2c4
commit
586aea1acc
@ -1,7 +1,7 @@
|
||||
Summary: Tools to manage multipath devices using device-mapper
|
||||
Name: device-mapper-multipath
|
||||
Version: 0.4.9
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
License: GPL+
|
||||
Group: System Environment/Base
|
||||
URL: http://christophe.varoqui.free.fr/
|
||||
@ -13,7 +13,7 @@ Patch2: queue_without_daemon.patch
|
||||
Patch3: path_checker.patch
|
||||
Patch4: root_init_script.patch
|
||||
Patch5: uninstall.patch
|
||||
Patch6: lib64_multipath.patch
|
||||
Patch6: select_lib.patch
|
||||
Patch7: directio_message_cleanup.patch
|
||||
Patch8: fix_kpartx.patch
|
||||
Patch9: redhatification.patch
|
||||
@ -67,9 +67,7 @@ kpartx manages partition creation and removal for device-mapper devices.
|
||||
%patch3 -p1 -b .path_checker
|
||||
%patch4 -p1 -b .root_init_script
|
||||
%patch5 -p1 -b .uninstall.patch
|
||||
%if %{_lib} == "lib64"
|
||||
%patch6 -p1 -b .lib64_multipath
|
||||
%endif
|
||||
%patch6 -p1 -b .select_lib
|
||||
%patch7 -p1 -b .directio_message_cleanup
|
||||
%patch8 -p1 -b .fix_kpartx
|
||||
%patch9 -p1 -b .redhatification
|
||||
@ -83,7 +81,7 @@ kpartx manages partition creation and removal for device-mapper devices.
|
||||
%define _sbindir /sbin
|
||||
%define _libdir /%{_lib}
|
||||
%define _libmpathdir %{_libdir}/multipath
|
||||
make %{?_smp_mflags}
|
||||
make %{?_smp_mflags} LIB=%{_lib}
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
@ -144,6 +142,9 @@ fi
|
||||
%{_mandir}/man8/kpartx.8.gz
|
||||
|
||||
%changelog
|
||||
* Thu Jul 30 2009 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.9-4
|
||||
- Fixed build issue on i686 machines.
|
||||
|
||||
* Wed Jul 29 2009 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.9-3
|
||||
- Updated to latest upstream 0.4.9 code : multipath-tools-090729.tgz
|
||||
(git commit id: d678c139719d5631194b50e49f16ca97162ecd0f)
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: multipath-tools-090724/libmultipath/hwtable.c
|
||||
Index: multipath-tools/libmultipath/hwtable.c
|
||||
===================================================================
|
||||
--- multipath-tools-090724.orig/libmultipath/hwtable.c
|
||||
+++ multipath-tools-090724/libmultipath/hwtable.c
|
||||
--- multipath-tools.orig/libmultipath/hwtable.c
|
||||
+++ multipath-tools/libmultipath/hwtable.c
|
||||
@@ -589,7 +589,7 @@ static struct hwentry default_hw[] = {
|
||||
.vendor = "IBM",
|
||||
.product = "S/390 DASD ECKD",
|
||||
@ -11,11 +11,11 @@ Index: multipath-tools-090724/libmultipath/hwtable.c
|
||||
.features = "1 queue_if_no_path",
|
||||
.hwhandler = DEFAULT_HWHANDLER,
|
||||
.selector = DEFAULT_SELECTOR,
|
||||
Index: multipath-tools-090724/Makefile.inc
|
||||
Index: multipath-tools/Makefile.inc
|
||||
===================================================================
|
||||
--- multipath-tools-090724.orig/Makefile.inc
|
||||
+++ multipath-tools-090724/Makefile.inc
|
||||
@@ -26,7 +26,7 @@ libudevdir = ${prefix}/lib/udev
|
||||
--- multipath-tools.orig/Makefile.inc
|
||||
+++ multipath-tools/Makefile.inc
|
||||
@@ -28,7 +28,7 @@ libudevdir = ${prefix}/lib/udev
|
||||
multipathdir = $(TOPDIR)/libmultipath
|
||||
mandir = $(prefix)/usr/share/man/man8
|
||||
man5dir = $(prefix)/usr/share/man/man5
|
||||
@ -24,10 +24,10 @@ Index: multipath-tools-090724/Makefile.inc
|
||||
syslibdir = $(prefix)/$(LIB)
|
||||
libdir = $(prefix)/$(LIB)/multipath
|
||||
|
||||
Index: multipath-tools-090724/multipathd/Makefile
|
||||
Index: multipath-tools/multipathd/Makefile
|
||||
===================================================================
|
||||
--- multipath-tools-090724.orig/multipathd/Makefile
|
||||
+++ multipath-tools-090724/multipathd/Makefile
|
||||
--- multipath-tools.orig/multipathd/Makefile
|
||||
+++ multipath-tools/multipathd/Makefile
|
||||
@@ -35,6 +35,7 @@ install:
|
||||
$(INSTALL_PROGRAM) -d $(DESTDIR)$(bindir)
|
||||
$(INSTALL_PROGRAM) -m 755 $(EXEC) $(DESTDIR)$(bindir)
|
||||
@ -36,10 +36,10 @@ Index: multipath-tools-090724/multipathd/Makefile
|
||||
$(INSTALL_PROGRAM) -d $(DESTDIR)$(mandir)
|
||||
$(INSTALL_PROGRAM) -m 644 $(EXEC).8.gz $(DESTDIR)$(mandir)
|
||||
|
||||
Index: multipath-tools-090724/multipath/Makefile
|
||||
Index: multipath-tools/multipath/Makefile
|
||||
===================================================================
|
||||
--- multipath-tools-090724.orig/multipath/Makefile
|
||||
+++ multipath-tools-090724/multipath/Makefile
|
||||
--- multipath-tools.orig/multipath/Makefile
|
||||
+++ multipath-tools/multipath/Makefile
|
||||
@@ -27,6 +27,9 @@ install:
|
||||
$(INSTALL_PROGRAM) -m 644 $(EXEC).8.gz $(DESTDIR)$(mandir)
|
||||
$(INSTALL_PROGRAM) -d $(DESTDIR)$(man5dir)
|
||||
@ -50,10 +50,10 @@ Index: multipath-tools-090724/multipath/Makefile
|
||||
|
||||
uninstall:
|
||||
rm $(DESTDIR)/etc/udev/rules.d/multipath.rules
|
||||
Index: multipath-tools-090724/multipath/multipath.conf.redhat
|
||||
Index: multipath-tools/multipath/multipath.conf.redhat
|
||||
===================================================================
|
||||
--- /dev/null
|
||||
+++ multipath-tools-090724/multipath/multipath.conf.redhat
|
||||
+++ multipath-tools/multipath/multipath.conf.redhat
|
||||
@@ -0,0 +1,97 @@
|
||||
+# This is a basic configuration file with some examples, for device mapper
|
||||
+# multipath.
|
||||
@ -152,10 +152,10 @@ Index: multipath-tools-090724/multipath/multipath.conf.redhat
|
||||
+# path_grouping_policy multibus
|
||||
+# }
|
||||
+#}
|
||||
Index: multipath-tools-090724/kpartx/Makefile
|
||||
Index: multipath-tools/kpartx/Makefile
|
||||
===================================================================
|
||||
--- multipath-tools-090724.orig/kpartx/Makefile
|
||||
+++ multipath-tools-090724/kpartx/Makefile
|
||||
--- multipath-tools.orig/kpartx/Makefile
|
||||
+++ multipath-tools/kpartx/Makefile
|
||||
@@ -20,10 +20,10 @@ $(EXEC): $(OBJS)
|
||||
install: $(EXEC) $(EXEC).8
|
||||
$(INSTALL_PROGRAM) -d $(DESTDIR)$(bindir)
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: multipath-tools-090724/libmultipath/defaults.h
|
||||
Index: multipath-tools/libmultipath/defaults.h
|
||||
===================================================================
|
||||
--- multipath-tools-090724.orig/libmultipath/defaults.h
|
||||
+++ multipath-tools-090724/libmultipath/defaults.h
|
||||
--- multipath-tools.orig/libmultipath/defaults.h
|
||||
+++ multipath-tools/libmultipath/defaults.h
|
||||
@@ -1,6 +1,6 @@
|
||||
#define DEFAULT_GETUID "/lib/udev/scsi_id --whitelisted --device=/dev/%n"
|
||||
#define DEFAULT_UDEVDIR "/dev"
|
||||
@ -10,20 +10,26 @@ Index: multipath-tools-090724/libmultipath/defaults.h
|
||||
#define DEFAULT_SELECTOR "round-robin 0"
|
||||
#define DEFAULT_FEATURES "0"
|
||||
#define DEFAULT_HWHANDLER "0"
|
||||
Index: multipath-tools-090724/Makefile.inc
|
||||
Index: multipath-tools/Makefile.inc
|
||||
===================================================================
|
||||
--- multipath-tools-090724.orig/Makefile.inc
|
||||
+++ multipath-tools-090724/Makefile.inc
|
||||
@@ -13,6 +13,8 @@ ifeq ($(TOPDIR),)
|
||||
--- multipath-tools.orig/Makefile.inc
|
||||
+++ multipath-tools/Makefile.inc
|
||||
@@ -13,6 +13,14 @@ ifeq ($(TOPDIR),)
|
||||
TOPDIR = ..
|
||||
endif
|
||||
|
||||
+ifndef LIB
|
||||
+ ifeq ($(shell test -d /lib64 && echo 1),1)
|
||||
+ LIB=lib64
|
||||
+ else
|
||||
+ LIB=lib
|
||||
+ endif
|
||||
+endif
|
||||
+
|
||||
prefix =
|
||||
exec_prefix = $(prefix)
|
||||
bindir = $(exec_prefix)/sbin
|
||||
@@ -21,14 +23,14 @@ multipathdir = $(TOPDIR)/libmultipath
|
||||
@@ -21,14 +29,14 @@ multipathdir = $(TOPDIR)/libmultipath
|
||||
mandir = $(prefix)/usr/share/man/man8
|
||||
man5dir = $(prefix)/usr/share/man/man5
|
||||
rcdir = $(prefix)/etc/init.d
|
Loading…
Reference in New Issue
Block a user