import device-mapper-multipath-0.8.4-27.el8
This commit is contained in:
parent
895f38e5b0
commit
4fd3b8a3f6
26
SOURCES/0108-multipathd-Add-missing-ctype-include.patch
Normal file
26
SOURCES/0108-multipathd-Add-missing-ctype-include.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Bastian Germann <bage@debian.org>
|
||||||
|
Date: Thu, 14 Oct 2021 00:34:33 +0200
|
||||||
|
Subject: [PATCH] multipathd: Add missing ctype include
|
||||||
|
|
||||||
|
In uxclnt.c, there are isspace calls. Add an explicit include.
|
||||||
|
|
||||||
|
Signed-off-by: Bastian Germann <bage@debian.org>
|
||||||
|
Reviewed-by: Martin Wilck <mwilck@suse.com>
|
||||||
|
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
||||||
|
---
|
||||||
|
multipathd/uxclnt.c | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/multipathd/uxclnt.c b/multipathd/uxclnt.c
|
||||||
|
index a76f8e29..f16a7309 100644
|
||||||
|
--- a/multipathd/uxclnt.c
|
||||||
|
+++ b/multipathd/uxclnt.c
|
||||||
|
@@ -8,6 +8,7 @@
|
||||||
|
#include <stdlib.h>
|
||||||
|
#include <unistd.h>
|
||||||
|
#include <stdarg.h>
|
||||||
|
+#include <ctype.h>
|
||||||
|
#include <fcntl.h>
|
||||||
|
#include <errno.h>
|
||||||
|
#include <sys/ioctl.h>
|
102
SOURCES/0109-multipathd-replace-libreadline-with-libedit.patch
Normal file
102
SOURCES/0109-multipathd-replace-libreadline-with-libedit.patch
Normal file
@ -0,0 +1,102 @@
|
|||||||
|
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Martin Wilck <mwilck@suse.com>
|
||||||
|
Date: Fri, 12 Aug 2022 18:58:15 +0200
|
||||||
|
Subject: [PATCH] multipathd: replace libreadline with libedit
|
||||||
|
|
||||||
|
Linking multipathd with libreadline may cause a license conflict,
|
||||||
|
because libreadline is licensed under GPL-3.0-or-later, and
|
||||||
|
libmultipath contains several files under GPL-2.0.
|
||||||
|
|
||||||
|
See:
|
||||||
|
https://github.com/opensvc/multipath-tools/issues/36
|
||||||
|
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=979095
|
||||||
|
https://www.gnu.org/licenses/gpl-faq.html#AllCompatibility
|
||||||
|
|
||||||
|
Replace the readline functionality with libedit, which comes under
|
||||||
|
a BSD license. The readline library can still be enabled (e.g. for
|
||||||
|
binaries not intended to be distributed) by running
|
||||||
|
"make READLINE=libreadline".
|
||||||
|
|
||||||
|
Signed-off-by: Martin Wilck <mwilck@suse.com>
|
||||||
|
Signed-off-by: Benjamin Marzinski <bmarzins@redhat.com>
|
||||||
|
---
|
||||||
|
Makefile.inc | 5 +++++
|
||||||
|
multipathd/Makefile | 11 ++++++++++-
|
||||||
|
multipathd/cli.c | 5 +++++
|
||||||
|
multipathd/uxclnt.c | 6 ++++++
|
||||||
|
4 files changed, 26 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile.inc b/Makefile.inc
|
||||||
|
index 25c16f4e..d471f045 100644
|
||||||
|
--- a/Makefile.inc
|
||||||
|
+++ b/Makefile.inc
|
||||||
|
@@ -14,6 +14,11 @@
|
||||||
|
#
|
||||||
|
# Uncomment to disable dmevents polling support
|
||||||
|
# ENABLE_DMEVENTS_POLL = 0
|
||||||
|
+#
|
||||||
|
+# Readline library to use, libedit or libreadline
|
||||||
|
+# Caution: Using libreadline may make the multipathd binary undistributable,
|
||||||
|
+# see https://github.com/opensvc/multipath-tools/issues/36
|
||||||
|
+READLINE = libedit
|
||||||
|
|
||||||
|
ifeq ($(TOPDIR),)
|
||||||
|
TOPDIR = ..
|
||||||
|
diff --git a/multipathd/Makefile b/multipathd/Makefile
|
||||||
|
index 835edd93..4874ec3a 100644
|
||||||
|
--- a/multipathd/Makefile
|
||||||
|
+++ b/multipathd/Makefile
|
||||||
|
@@ -15,7 +15,16 @@ CFLAGS += $(BIN_CFLAGS) -I$(multipathdir) -I$(mpathpersistdir) \
|
||||||
|
LDFLAGS += $(BIN_LDFLAGS)
|
||||||
|
LIBDEPS += -L$(multipathdir) -lmultipath -L$(mpathpersistdir) -lmpathpersist \
|
||||||
|
-L$(mpathcmddir) -lmpathcmd -ludev -ldl -lurcu -lpthread \
|
||||||
|
- -ldevmapper -lreadline
|
||||||
|
+ -ldevmapper
|
||||||
|
+
|
||||||
|
+ifeq ($(READLINE),libedit)
|
||||||
|
+CFLAGS += -DUSE_LIBEDIT
|
||||||
|
+LIBDEPS += -ledit
|
||||||
|
+endif
|
||||||
|
+ifeq ($(READLINE),libreadline)
|
||||||
|
+CFLAGS += -DUSE_LIBREADLINE
|
||||||
|
+LIBDEPS += -lreadline
|
||||||
|
+endif
|
||||||
|
|
||||||
|
ifdef SYSTEMD
|
||||||
|
CFLAGS += -DUSE_SYSTEMD=$(SYSTEMD)
|
||||||
|
diff --git a/multipathd/cli.c b/multipathd/cli.c
|
||||||
|
index bdc9fb10..85d73dfb 100644
|
||||||
|
--- a/multipathd/cli.c
|
||||||
|
+++ b/multipathd/cli.c
|
||||||
|
@@ -11,7 +11,12 @@
|
||||||
|
#include "parser.h"
|
||||||
|
#include "util.h"
|
||||||
|
#include "version.h"
|
||||||
|
+#ifdef USE_LIBEDIT
|
||||||
|
+#include <editline/readline.h>
|
||||||
|
+#endif
|
||||||
|
+#ifdef USE_LIBREADLINE
|
||||||
|
#include <readline/readline.h>
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
#include "mpath_cmd.h"
|
||||||
|
#include "cli.h"
|
||||||
|
diff --git a/multipathd/uxclnt.c b/multipathd/uxclnt.c
|
||||||
|
index f16a7309..2c17d8fc 100644
|
||||||
|
--- a/multipathd/uxclnt.c
|
||||||
|
+++ b/multipathd/uxclnt.c
|
||||||
|
@@ -16,8 +16,14 @@
|
||||||
|
#include <sys/socket.h>
|
||||||
|
#include <sys/un.h>
|
||||||
|
#include <poll.h>
|
||||||
|
+
|
||||||
|
+#ifdef USE_LIBEDIT
|
||||||
|
+#include <editline/readline.h>
|
||||||
|
+#endif
|
||||||
|
+#ifdef USE_LIBREADLINE
|
||||||
|
#include <readline/readline.h>
|
||||||
|
#include <readline/history.h>
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
#include "mpath_cmd.h"
|
||||||
|
#include "uxsock.h"
|
@ -1,7 +1,7 @@
|
|||||||
Summary: Tools to manage multipath devices using device-mapper
|
Summary: Tools to manage multipath devices using device-mapper
|
||||||
Name: device-mapper-multipath
|
Name: device-mapper-multipath
|
||||||
Version: 0.8.4
|
Version: 0.8.4
|
||||||
Release: 26%{?dist}
|
Release: 27%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
URL: http://christophe.varoqui.free.fr/
|
URL: http://christophe.varoqui.free.fr/
|
||||||
@ -118,12 +118,15 @@ Patch00104: 0104-libmultipath-use-symbolic-value-for-invalid-pcentry.patch
|
|||||||
Patch00105: 0105-multipathd-handle-fpin-events.patch
|
Patch00105: 0105-multipathd-handle-fpin-events.patch
|
||||||
Patch00106: 0106-multipathd-disallow-changing-to-from-fpin-marginal-p.patch
|
Patch00106: 0106-multipathd-disallow-changing-to-from-fpin-marginal-p.patch
|
||||||
Patch00107: 0107-libmultipath-unset-detect_checker-for-clariion-Unity.patch
|
Patch00107: 0107-libmultipath-unset-detect_checker-for-clariion-Unity.patch
|
||||||
|
Patch00108: 0108-multipathd-Add-missing-ctype-include.patch
|
||||||
|
Patch00109: 0109-multipathd-replace-libreadline-with-libedit.patch
|
||||||
|
|
||||||
# runtime
|
# runtime
|
||||||
Requires: %{name}-libs = %{version}-%{release}
|
Requires: %{name}-libs = %{version}-%{release}
|
||||||
Requires: kpartx = %{version}-%{release}
|
Requires: kpartx = %{version}-%{release}
|
||||||
Requires: device-mapper >= 1.02.96
|
Requires: device-mapper >= 1.02.96
|
||||||
Requires: userspace-rcu
|
Requires: userspace-rcu
|
||||||
|
Requires: libedit
|
||||||
Requires(post): systemd-units
|
Requires(post): systemd-units
|
||||||
Requires(preun): systemd-units
|
Requires(preun): systemd-units
|
||||||
Requires(postun): systemd-units
|
Requires(postun): systemd-units
|
||||||
@ -131,7 +134,7 @@ Requires(postun): systemd-units
|
|||||||
# build/setup
|
# build/setup
|
||||||
BuildRequires: libaio-devel, device-mapper-devel >= 1.02.89
|
BuildRequires: libaio-devel, device-mapper-devel >= 1.02.89
|
||||||
BuildRequires: libselinux-devel, libsepol-devel
|
BuildRequires: libselinux-devel, libsepol-devel
|
||||||
BuildRequires: readline-devel, ncurses-devel
|
BuildRequires: libedit-devel, ncurses-devel
|
||||||
BuildRequires: systemd-units, systemd-devel
|
BuildRequires: systemd-units, systemd-devel
|
||||||
BuildRequires: json-c-devel, perl-interpreter, pkgconfig, gcc
|
BuildRequires: json-c-devel, perl-interpreter, pkgconfig, gcc
|
||||||
BuildRequires: userspace-rcu-devel
|
BuildRequires: userspace-rcu-devel
|
||||||
@ -319,6 +322,12 @@ fi
|
|||||||
%{_pkgconfdir}/libdmmp.pc
|
%{_pkgconfdir}/libdmmp.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Aug 19 2022 Benjamin Marzinski <bmarzins@redhat.com> 0.8.4-27
|
||||||
|
- Add 0108-multipathd-Add-missing-ctype-include.patch
|
||||||
|
- Add 0109-multipathd-replace-libreadline-with-libedit.patch
|
||||||
|
* replace readline with libedit, to avoid license conflicts
|
||||||
|
- Resolves: bz #2119887
|
||||||
|
|
||||||
* Wed Jun 8 2022 Benjamin Marzinski <bmarzins@redhat.com> 0.8.4-26
|
* Wed Jun 8 2022 Benjamin Marzinski <bmarzins@redhat.com> 0.8.4-26
|
||||||
- Add 0107-libmultipath-unset-detect_checker-for-clariion-Unity.patch
|
- Add 0107-libmultipath-unset-detect_checker-for-clariion-Unity.patch
|
||||||
- Resolves: bz #2082205
|
- Resolves: bz #2082205
|
||||||
|
Loading…
Reference in New Issue
Block a user