Fixed Makefile issues.

This commit is contained in:
Benjamin Marzinski 2008-05-20 06:30:55 +00:00
parent 005566c77f
commit 17ed09d594
3 changed files with 6 additions and 4 deletions

View File

@ -1,7 +1,7 @@
Summary: Tools to manage multipath devices using device-mapper Summary: Tools to manage multipath devices using device-mapper
Name: device-mapper-multipath Name: device-mapper-multipath
Version: 0.4.8 Version: 0.4.8
Release: 3%{?dist} Release: 4%{?dist}
License: GPL+ License: GPL+
Group: System Environment/Base Group: System Environment/Base
URL: http://christophe.varoqui.free.fr/ URL: http://christophe.varoqui.free.fr/
@ -103,6 +103,9 @@ fi
%{_mandir}/man8/kpartx.8.gz %{_mandir}/man8/kpartx.8.gz
%changelog %changelog
* Mon May 19 2008 Benjamin Marzinksi <bmarzins@redhat.com> 0.4.8-4
- Fixed Makefile issues.
* Mon May 19 2008 Benjamin Marzinksi <bmarzins@redhat.com> 0.4.8-3 * Mon May 19 2008 Benjamin Marzinksi <bmarzins@redhat.com> 0.4.8-3
- Fixed ownership build error. - Fixed ownership build error.

View File

@ -2,7 +2,7 @@ Index: multipath-tools-080519/libmultipath/Makefile
=================================================================== ===================================================================
--- multipath-tools-080519.orig/libmultipath/Makefile --- multipath-tools-080519.orig/libmultipath/Makefile
+++ multipath-tools-080519/libmultipath/Makefile +++ multipath-tools-080519/libmultipath/Makefile
@@ -23,14 +23,16 @@ endif @@ -23,14 +23,15 @@ endif
all: $(LIBS) all: $(LIBS)
$(LIBS): $(OBJS) $(LIBS): $(OBJS)
@ -14,7 +14,6 @@ Index: multipath-tools-080519/libmultipath/Makefile
+ $(INSTALL_PROGRAM) -m 755 $(LIBS) $(DESTDIR)$(prefix)/lib/$(LIBS) + $(INSTALL_PROGRAM) -m 755 $(LIBS) $(DESTDIR)$(prefix)/lib/$(LIBS)
$(INSTALL_PROGRAM) -m 755 -d $(DESTDIR)$(libdir) $(INSTALL_PROGRAM) -m 755 -d $(DESTDIR)$(libdir)
- $(INSTALL_PROGRAM) -m 755 $(LIBS) $(DESTDIR)$(libdir)/$(LIBS) - $(INSTALL_PROGRAM) -m 755 $(LIBS) $(DESTDIR)$(libdir)/$(LIBS)
+ ldconfig
uninstall: uninstall:
- rm -f $(DESTDIR)$(libdir)/$(LIBS) - rm -f $(DESTDIR)$(libdir)/$(LIBS)

View File

@ -26,7 +26,7 @@ Index: multipath-tools-080519/libmultipath/checkers/Makefile
install: install:
- $(INSTALL_PROGRAM) -o root -g root -m 755 $(LIBS) $(libdir) - $(INSTALL_PROGRAM) -o root -g root -m 755 $(LIBS) $(libdir)
+ $(INSTALL_PROGRAM) -o root -g root -m 755 $(LIBS) $(DESTDIR)$(libdir) + $(INSTALL_PROGRAM) -m 755 $(LIBS) $(DESTDIR)$(libdir)
uninstall: uninstall:
- rm -f $(libdir)/$(LIBS) - rm -f $(libdir)/$(LIBS)