devhelp/devhelp-0.19-xulrunner.patch
2008-02-26 11:26:58 +00:00

752 lines
31 KiB
Diff

diff -up devhelp-0.19/m4/gecko.m4.xl devhelp-0.19/m4/gecko.m4
--- devhelp-0.19/m4/gecko.m4.xl 2007-02-13 09:34:26.000000000 +0100
+++ devhelp-0.19/m4/gecko.m4 2008-02-26 12:10:21.000000000 +0100
@@ -51,22 +51,32 @@ AC_PROG_AWK
AC_MSG_CHECKING([which gecko to use])
AC_ARG_WITH([gecko],
- AS_HELP_STRING([--with-gecko@<:@=mozilla|firefox|seamonkey|xulrunner@:>@],
+ AS_HELP_STRING([--with-gecko@<:@=mozilla|firefox|seamonkey|xulrunner|libxul@:>@],
[Which gecko engine to use (autodetected by default)]))
# Backward compat
AC_ARG_WITH([mozilla],[],[with_gecko=$withval],[])
gecko_cv_gecko=$with_gecko
+if $PKG_CONFIG --exists $with_gecko-xpcom; then
+ gecko_cv_gecko_xpcom=$with_gecko-xpcom
+else
+ gecko_cv_gecko_xpcom=$with_gecko
+fi
# Autodetect gecko
-_geckos="xulrunner firefox mozilla-firefox seamonkey mozilla"
+_geckos="xulrunner firefox mozilla-firefox seamonkey mozilla libxul"
if test -z "$gecko_cv_gecko"; then
for lizard in $_geckos; do
if $PKG_CONFIG --exists $lizard-xpcom; then
gecko_cv_gecko=$lizard
+ gecko_cv_gecko_xpcom=$lizard-xpcom
break;
- fi
+ elif $PKG_CONFIG --exists $lizard; then
+ gecko_cv_gecko=$lizard
+ gecko_cv_gecko_xpcom=$lizard
+ break;
+ fi
done
fi
@@ -93,12 +103,13 @@ mozilla) gecko_cv_gecko_flavour=mozilla
seamonkey) gecko_cv_gecko_flavour=mozilla ;;
*firefox) gecko_cv_gecko_flavour=toolkit ;;
xulrunner) gecko_cv_gecko_flavour=toolkit ;;
+libxul*) gecko_cv_gecko_flavour=toolkit ;;
esac
-_GECKO_INCLUDE_ROOT="`$PKG_CONFIG --variable=includedir ${gecko_cv_gecko}-xpcom`"
-_GECKO_LIBDIR="`$PKG_CONFIG --variable=libdir ${gecko_cv_gecko}-xpcom`"
-_GECKO_HOME="`$PKG_CONFIG --variable=libdir ${gecko_cv_gecko}-xpcom`"
-_GECKO_PREFIX="`$PKG_CONFIG --variable=prefix ${gecko_cv_gecko}-xpcom`"
+_GECKO_INCLUDE_ROOT="`$PKG_CONFIG --variable=includedir ${gecko_cv_gecko_xpcom}`"
+_GECKO_LIBDIR="`$PKG_CONFIG --variable=libdir ${gecko_cv_gecko_xpcom}`"
+_GECKO_HOME="`$PKG_CONFIG --variable=libdir ${gecko_cv_gecko_xpcom}`"
+_GECKO_PREFIX="`$PKG_CONFIG --variable=prefix ${gecko_cv_gecko_xpcom}`"
fi # if gecko_cv_have_gecko
@@ -114,6 +125,7 @@ $1[]_INCLUDE_ROOT=$_GECKO_INCLUDE_ROOT
$1[]_LIBDIR=$_GECKO_LIBDIR
$1[]_HOME=$_GECKO_HOME
$1[]_PREFIX=$_GECKO_PREFIX
+$1[]_XPCOM=$gecko_cv_gecko_xpcom
# **************************************************************
# This is really gcc-only
@@ -359,10 +371,10 @@ _SAVE_CPPFLAGS="$CPPFLAGS"
_SAVE_CXXFLAGS="$CXXFLAGS"
_SAVE_LDFLAGS="$LDFLAGS"
_SAVE_LIBS="$LIBS"
-CPPFLAGS="$CPPFLAGS $_GECKO_EXTRA_CPPFLAGS -I$_GECKO_INCLUDE_ROOT $($PKG_CONFIG --cflags-only-I ${gecko_cv_gecko}-xpcom)"
-CXXFLAGS="$CXXFLAGS $_GECKO_EXTRA_CXXFLAGS $($PKG_CONFIG --cflags-only-other ${gecko_cv_gecko}-xpcom)"
+CPPFLAGS="$CPPFLAGS $_GECKO_EXTRA_CPPFLAGS -I$_GECKO_INCLUDE_ROOT $($PKG_CONFIG --cflags-only-I ${gecko_cv_gecko_xpcom})"
+CXXFLAGS="$CXXFLAGS $_GECKO_EXTRA_CXXFLAGS $($PKG_CONFIG --cflags-only-other ${gecko_cv_gecko_xpcom})"
LDFLAGS="$LDFLAGS $_GECKO_EXTRA_LDFLAGS -Wl,--rpath=$_GECKO_HOME"
-LIBS="$LIBS $($PKG_CONFIG --libs ${gecko_cv_gecko}-xpcom)"
+LIBS="$LIBS $($PKG_CONFIG --libs ${gecko_cv_gecko_xpcom})"
_GECKO_DISPATCH_INCLUDEDIRS="$2"
@@ -595,11 +607,11 @@ fi
AC_DEFUN([GECKO_XPIDL],
[AC_REQUIRE([GECKO_INIT])dnl
-_GECKO_LIBDIR="`$PKG_CONFIG --variable=libdir ${gecko_cv_gecko}-xpcom`"
+_GECKO_LIBDIR="`$PKG_CONFIG --variable=libdir ${gecko_cv_gecko_xpcom}`"
AC_PATH_PROG([XPIDL],[xpidl],[no],[$_GECKO_LIBDIR:$PATH])
-XPIDL_IDLDIR="`$PKG_CONFIG --variable=idldir ${gecko_cv_gecko}-xpcom`"
+XPIDL_IDLDIR="`$PKG_CONFIG --variable=idldir ${gecko_cv_gecko_xpcom}`"
# Older geckos don't have this variable, see
# https://bugzilla.mozilla.org/show_bug.cgi?id=240473
diff -up devhelp-0.19/configure.in.xl devhelp-0.19/configure.in
--- devhelp-0.19/configure.in.xl 2008-02-07 10:18:55.000000000 +0100
+++ devhelp-0.19/configure.in 2008-02-26 12:11:01.000000000 +0100
@@ -73,6 +73,7 @@ AC_SUBST([GECKO_INCLUDE_ROOT])
AC_SUBST([GECKO_HOME])
AC_SUBST([GECKO_PREFIX])
AC_SUBST([GECKO_EXTRA_LIBS])
+AC_SUBST([GECKO_XPCOM])
case "$GECKO" in
mozilla) gecko_min_version=1.7 ;;
@@ -80,9 +81,10 @@ seamonkey) gecko_min_version=1.0 ;;
*firefox) gecko_min_version=1.0 ;;
*thunderbird) gecko_min_version=1.0 ;;
xulrunner) gecko_min_version=1.8 ;;
+libxul*) gecko_min_version=1.9 ;;
esac
-PKG_CHECK_MODULES([GECKO],[$GECKO_EXTRA_PKG_DEPENDENCIES $GECKO-xpcom >= $gecko_min_version])
+PKG_CHECK_MODULES([GECKO],[$GECKO_EXTRA_PKG_DEPENDENCIES $GECKO_XPCOM >= $gecko_min_version])
AC_SUBST([GECKO_CFLAGS])
AC_SUBST([GECKO_LIBS])
diff -up devhelp-0.19/configure.xl devhelp-0.19/configure
--- devhelp-0.19/configure.xl 2008-02-07 13:39:49.000000000 +0100
+++ devhelp-0.19/configure 2008-02-26 12:14:58.000000000 +0100
@@ -940,6 +940,7 @@ GECKO_INCLUDE_ROOT
GECKO_HOME
GECKO_PREFIX
GECKO_EXTRA_LIBS
+GECKO_XPCOM
GECKO_CFLAGS
GECKO_LIBS
GECKO_WARN_CXXFLAGS
@@ -1597,7 +1598,7 @@ Optional Packages:
--with-gconf-source=sourceaddress Config database for installing schema files.
--with-gconf-schema-file-dir=dir Directory for installing schema files.
--with-compile-warnings=no/yes/error Compiler warnings
- --with-gecko[=mozilla|firefox|seamonkey|xulrunner]
+ --with-gecko[=mozilla|firefox|seamonkey|xulrunner|libxul]
Which gecko engine to use (autodetected by default)
--with-zlib=DIR use libz in DIR
@@ -5357,7 +5358,7 @@ linux* | k*bsd*-gnu)
lt_cv_deplibs_check_method=pass_all
;;
-netbsd* | netbsdelf*-gnu)
+netbsd*)
if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
lt_cv_deplibs_check_method='match_pattern /lib[^/]+(\.so\.[0-9]+\.[0-9]+|_pic\.a)$'
else
@@ -5477,7 +5478,7 @@ ia64-*-hpux*)
;;
*-*-irix6*)
# Find out which ABI we are using.
- echo '#line 5480 "configure"' > conftest.$ac_ext
+ echo '#line 5481 "configure"' > conftest.$ac_ext
if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
(eval $ac_compile) 2>&5
ac_status=$?
@@ -5542,6 +5543,7 @@ s390*-*linux*|sparc*-*linux*)
esac
;;
*64-bit*)
+ libsuff=64
case $host in
x86_64-*kfreebsd*-gnu)
LD="${LD-ld} -m elf_x86_64_fbsd"
@@ -7342,11 +7344,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:7345: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:7347: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:7349: \$? = $ac_status" >&5
+ echo "$as_me:7351: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings other than the usual output.
@@ -7632,11 +7634,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:7635: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:7637: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:7639: \$? = $ac_status" >&5
+ echo "$as_me:7641: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings other than the usual output.
@@ -7736,11 +7738,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:7739: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:7741: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:7743: \$? = $ac_status" >&5
+ echo "$as_me:7745: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
@@ -8000,13 +8002,12 @@ EOF
$echo "local: *; };" >> $output_objdir/$libname.ver~
$CC '"$tmp_sharedflag""$tmp_addflag"' $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-version-script ${wl}$output_objdir/$libname.ver -o $lib'
fi
- link_all_deplibs=no
else
ld_shlibs=no
fi
;;
- netbsd* | netbsdelf*-gnu)
+ netbsd*)
if echo __ELF__ | $CC -E - | grep __ELF__ >/dev/null; then
archive_cmds='$LD -Bshareable $libobjs $deplibs $linker_flags -o $lib'
wlarc=
@@ -8550,7 +8551,7 @@ if test -z "$aix_libpath"; then aix_libp
link_all_deplibs=yes
;;
- netbsd* | netbsdelf*-gnu)
+ netbsd*)
if echo __ELF__ | $CC -E - | grep __ELF__ >/dev/null; then
archive_cmds='$LD -Bshareable -o $lib $libobjs $deplibs $linker_flags' # a.out
else
@@ -9245,11 +9246,13 @@ linux* | k*bsd*-gnu)
# Some rework will be needed to allow for fast_install
# before this can be enabled.
hardcode_into_libs=yes
+ sys_lib_search_path_spec="/usr/lib${libsuff} /lib${libsuff} /usr/local/lib${libsuff}"
+ sys_lib_dlsearch_path_spec="/usr/lib${libsuff} /lib${libsuff}"
# Append ld.so.conf contents to the search path
if test -f /etc/ld.so.conf; then
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;/^$/d' | tr '\n' ' '`
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
+ sys_lib_dlsearch_path_spec="$sys_lib_dlsearch_path_spec $lt_ld_extra"
fi
# We used to test for /lib/ld.so.1 and disable shared libraries on
@@ -9261,18 +9264,6 @@ linux* | k*bsd*-gnu)
dynamic_linker='GNU/Linux ld.so'
;;
-netbsdelf*-gnu)
- version_type=linux
- need_lib_prefix=no
- need_version=no
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
- soname_spec='${libname}${release}${shared_ext}$major'
- shlibpath_var=LD_LIBRARY_PATH
- shlibpath_overrides_runpath=no
- hardcode_into_libs=yes
- dynamic_linker='NetBSD ld.elf_so'
- ;;
-
netbsd*)
version_type=sunos
need_lib_prefix=no
@@ -10098,7 +10089,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<EOF
-#line 10101 "configure"
+#line 10092 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
@@ -10198,7 +10189,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<EOF
-#line 10201 "configure"
+#line 10192 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
@@ -11808,7 +11799,7 @@ if test -z "$aix_libpath"; then aix_libp
;;
esac
;;
- netbsd* | netbsdelf*-gnu)
+ netbsd*)
if echo __ELF__ | $CC -E - | grep __ELF__ >/dev/null; then
archive_cmds_CXX='$LD -Bshareable -o $lib $predep_objects $libobjs $deplibs $postdep_objects $linker_flags'
wlarc=
@@ -12509,7 +12500,7 @@ echo $ECHO_N "checking for $compiler opt
;;
esac
;;
- netbsd* | netbsdelf*-gnu)
+ netbsd*)
;;
osf3* | osf4* | osf5*)
case $cc_basename in
@@ -12618,11 +12609,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:12621: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:12612: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:12625: \$? = $ac_status" >&5
+ echo "$as_me:12616: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings other than the usual output.
@@ -12722,11 +12713,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:12725: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:12716: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:12729: \$? = $ac_status" >&5
+ echo "$as_me:12720: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
@@ -12794,9 +12785,6 @@ echo $ECHO_N "checking whether the $comp
cygwin* | mingw*)
export_symbols_cmds_CXX='$NM $libobjs $convenience | $global_symbol_pipe | $SED -e '\''/^[BCDGRS][ ]/s/.*[ ]\([^ ]*\)/\1 DATA/;/^.*[ ]__nm__/s/^.*[ ]__nm__\([^ ]*\)[ ][^ ]*/\1 DATA/;/^I[ ]/d;/^[AITW][ ]/s/.*[ ]//'\'' | sort | uniq > $export_symbols'
;;
- linux* | k*bsd*-gnu)
- link_all_deplibs_CXX=no
- ;;
*)
export_symbols_cmds_CXX='$NM $libobjs $convenience | $global_symbol_pipe | $SED '\''s/.* //'\'' | sort | uniq > $export_symbols'
;;
@@ -13226,11 +13214,13 @@ linux* | k*bsd*-gnu)
# Some rework will be needed to allow for fast_install
# before this can be enabled.
hardcode_into_libs=yes
+ sys_lib_search_path_spec="/usr/lib${libsuff} /lib${libsuff} /usr/local/lib${libsuff}"
+ sys_lib_dlsearch_path_spec="/usr/lib${libsuff} /lib${libsuff}"
# Append ld.so.conf contents to the search path
if test -f /etc/ld.so.conf; then
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;/^$/d' | tr '\n' ' '`
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
+ sys_lib_dlsearch_path_spec="$sys_lib_dlsearch_path_spec $lt_ld_extra"
fi
# We used to test for /lib/ld.so.1 and disable shared libraries on
@@ -13242,18 +13232,6 @@ linux* | k*bsd*-gnu)
dynamic_linker='GNU/Linux ld.so'
;;
-netbsdelf*-gnu)
- version_type=linux
- need_lib_prefix=no
- need_version=no
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
- soname_spec='${libname}${release}${shared_ext}$major'
- shlibpath_var=LD_LIBRARY_PATH
- shlibpath_overrides_runpath=no
- hardcode_into_libs=yes
- dynamic_linker='NetBSD ld.elf_so'
- ;;
-
netbsd*)
version_type=sunos
need_lib_prefix=no
@@ -14299,11 +14277,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:14302: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:14280: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:14306: \$? = $ac_status" >&5
+ echo "$as_me:14284: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings other than the usual output.
@@ -14403,11 +14381,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:14406: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:14384: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:14410: \$? = $ac_status" >&5
+ echo "$as_me:14388: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
@@ -14667,13 +14645,12 @@ EOF
$echo "local: *; };" >> $output_objdir/$libname.ver~
$CC '"$tmp_sharedflag""$tmp_addflag"' $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-version-script ${wl}$output_objdir/$libname.ver -o $lib'
fi
- link_all_deplibs_F77=no
else
ld_shlibs_F77=no
fi
;;
- netbsd* | netbsdelf*-gnu)
+ netbsd*)
if echo __ELF__ | $CC -E - | grep __ELF__ >/dev/null; then
archive_cmds_F77='$LD -Bshareable $libobjs $deplibs $linker_flags -o $lib'
wlarc=
@@ -15197,7 +15174,7 @@ if test -z "$aix_libpath"; then aix_libp
link_all_deplibs_F77=yes
;;
- netbsd* | netbsdelf*-gnu)
+ netbsd*)
if echo __ELF__ | $CC -E - | grep __ELF__ >/dev/null; then
archive_cmds_F77='$LD -Bshareable -o $lib $libobjs $deplibs $linker_flags' # a.out
else
@@ -15840,11 +15817,13 @@ linux* | k*bsd*-gnu)
# Some rework will be needed to allow for fast_install
# before this can be enabled.
hardcode_into_libs=yes
+ sys_lib_search_path_spec="/usr/lib${libsuff} /lib${libsuff} /usr/local/lib${libsuff}"
+ sys_lib_dlsearch_path_spec="/usr/lib${libsuff} /lib${libsuff}"
# Append ld.so.conf contents to the search path
if test -f /etc/ld.so.conf; then
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;/^$/d' | tr '\n' ' '`
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
+ sys_lib_dlsearch_path_spec="$sys_lib_dlsearch_path_spec $lt_ld_extra"
fi
# We used to test for /lib/ld.so.1 and disable shared libraries on
@@ -15856,18 +15835,6 @@ linux* | k*bsd*-gnu)
dynamic_linker='GNU/Linux ld.so'
;;
-netbsdelf*-gnu)
- version_type=linux
- need_lib_prefix=no
- need_version=no
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
- soname_spec='${libname}${release}${shared_ext}$major'
- shlibpath_var=LD_LIBRARY_PATH
- shlibpath_overrides_runpath=no
- hardcode_into_libs=yes
- dynamic_linker='NetBSD ld.elf_so'
- ;;
-
netbsd*)
version_type=sunos
need_lib_prefix=no
@@ -16603,11 +16570,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:16606: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:16573: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:16610: \$? = $ac_status" >&5
+ echo "$as_me:16577: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings other than the usual output.
@@ -16893,11 +16860,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:16896: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:16863: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:16900: \$? = $ac_status" >&5
+ echo "$as_me:16867: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings other than the usual output.
@@ -16997,11 +16964,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:17000: $lt_compile\"" >&5)
+ (eval echo "\"\$as_me:16967: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:17004: \$? = $ac_status" >&5
+ echo "$as_me:16971: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
@@ -17261,13 +17228,12 @@ EOF
$echo "local: *; };" >> $output_objdir/$libname.ver~
$CC '"$tmp_sharedflag""$tmp_addflag"' $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-version-script ${wl}$output_objdir/$libname.ver -o $lib'
fi
- link_all_deplibs_GCJ=no
else
ld_shlibs_GCJ=no
fi
;;
- netbsd* | netbsdelf*-gnu)
+ netbsd*)
if echo __ELF__ | $CC -E - | grep __ELF__ >/dev/null; then
archive_cmds_GCJ='$LD -Bshareable $libobjs $deplibs $linker_flags -o $lib'
wlarc=
@@ -17811,7 +17777,7 @@ if test -z "$aix_libpath"; then aix_libp
link_all_deplibs_GCJ=yes
;;
- netbsd* | netbsdelf*-gnu)
+ netbsd*)
if echo __ELF__ | $CC -E - | grep __ELF__ >/dev/null; then
archive_cmds_GCJ='$LD -Bshareable -o $lib $libobjs $deplibs $linker_flags' # a.out
else
@@ -18454,11 +18420,13 @@ linux* | k*bsd*-gnu)
# Some rework will be needed to allow for fast_install
# before this can be enabled.
hardcode_into_libs=yes
+ sys_lib_search_path_spec="/usr/lib${libsuff} /lib${libsuff} /usr/local/lib${libsuff}"
+ sys_lib_dlsearch_path_spec="/usr/lib${libsuff} /lib${libsuff}"
# Append ld.so.conf contents to the search path
if test -f /etc/ld.so.conf; then
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;/^$/d' | tr '\n' ' '`
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
+ sys_lib_dlsearch_path_spec="$sys_lib_dlsearch_path_spec $lt_ld_extra"
fi
# We used to test for /lib/ld.so.1 and disable shared libraries on
@@ -18470,18 +18438,6 @@ linux* | k*bsd*-gnu)
dynamic_linker='GNU/Linux ld.so'
;;
-netbsdelf*-gnu)
- version_type=linux
- need_lib_prefix=no
- need_version=no
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
- soname_spec='${libname}${release}${shared_ext}$major'
- shlibpath_var=LD_LIBRARY_PATH
- shlibpath_overrides_runpath=no
- hardcode_into_libs=yes
- dynamic_linker='NetBSD ld.elf_so'
- ;;
-
netbsd*)
version_type=sunos
need_lib_prefix=no
@@ -19797,7 +19753,7 @@ fi
fi
if test -n "$PKG_CONFIG"; then
- _pkg_min_version=0.7
+ _pkg_min_version=0.16
{ echo "$as_me:$LINENO: checking pkg-config is at least version $_pkg_min_version" >&5
echo $ECHO_N "checking pkg-config is at least version $_pkg_min_version... $ECHO_C" >&6; }
if $PKG_CONFIG --atleast-pkgconfig-version $_pkg_min_version; then
@@ -21057,13 +21013,23 @@ fi
gecko_cv_gecko=$with_gecko
+if $PKG_CONFIG --exists $with_gecko-xpcom; then
+ gecko_cv_gecko_xpcom=$with_gecko-xpcom
+else
+ gecko_cv_gecko_xpcom=$with_gecko
+fi
# Autodetect gecko
-_geckos="xulrunner firefox mozilla-firefox seamonkey mozilla"
+_geckos="xulrunner firefox mozilla-firefox seamonkey mozilla libxul"
if test -z "$gecko_cv_gecko"; then
for lizard in $_geckos; do
if $PKG_CONFIG --exists $lizard-xpcom; then
gecko_cv_gecko=$lizard
+ gecko_cv_gecko_xpcom=$lizard-xpcom
+ break;
+ elif $PKG_CONFIG --exists $lizard; then
+ gecko_cv_gecko=$lizard
+ gecko_cv_gecko_xpcom=$lizard
break;
fi
done
@@ -21097,12 +21063,13 @@ mozilla) gecko_cv_gecko_flavour=mozilla
seamonkey) gecko_cv_gecko_flavour=mozilla ;;
*firefox) gecko_cv_gecko_flavour=toolkit ;;
xulrunner) gecko_cv_gecko_flavour=toolkit ;;
+libxul*) gecko_cv_gecko_flavour=toolkit ;;
esac
-_GECKO_INCLUDE_ROOT="`$PKG_CONFIG --variable=includedir ${gecko_cv_gecko}-xpcom`"
-_GECKO_LIBDIR="`$PKG_CONFIG --variable=libdir ${gecko_cv_gecko}-xpcom`"
-_GECKO_HOME="`$PKG_CONFIG --variable=libdir ${gecko_cv_gecko}-xpcom`"
-_GECKO_PREFIX="`$PKG_CONFIG --variable=prefix ${gecko_cv_gecko}-xpcom`"
+_GECKO_INCLUDE_ROOT="`$PKG_CONFIG --variable=includedir ${gecko_cv_gecko_xpcom}`"
+_GECKO_LIBDIR="`$PKG_CONFIG --variable=libdir ${gecko_cv_gecko_xpcom}`"
+_GECKO_HOME="`$PKG_CONFIG --variable=libdir ${gecko_cv_gecko_xpcom}`"
+_GECKO_PREFIX="`$PKG_CONFIG --variable=prefix ${gecko_cv_gecko_xpcom}`"
fi # if gecko_cv_have_gecko
@@ -21129,6 +21096,7 @@ GECKO_INCLUDE_ROOT=$_GECKO_INCLUDE_ROOT
GECKO_LIBDIR=$_GECKO_LIBDIR
GECKO_HOME=$_GECKO_HOME
GECKO_PREFIX=$_GECKO_PREFIX
+GECKO_XPCOM=$gecko_cv_gecko_xpcom
# **************************************************************
# This is really gcc-only
@@ -21629,12 +21597,14 @@ GECKO_GLUE_LIBS="$gecko_cv_glue_libs"
+
case "$GECKO" in
mozilla) gecko_min_version=1.7 ;;
seamonkey) gecko_min_version=1.0 ;;
*firefox) gecko_min_version=1.0 ;;
*thunderbird) gecko_min_version=1.0 ;;
xulrunner) gecko_min_version=1.8 ;;
+libxul*) gecko_min_version=1.9 ;;
esac
@@ -21647,12 +21617,12 @@ if test -n "$PKG_CONFIG"; then
pkg_cv_GECKO_CFLAGS="$GECKO_CFLAGS"
else
if test -n "$PKG_CONFIG" && \
- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"\$GECKO_EXTRA_PKG_DEPENDENCIES \$GECKO-xpcom >= \$gecko_min_version\"") >&5
- ($PKG_CONFIG --exists --print-errors "$GECKO_EXTRA_PKG_DEPENDENCIES $GECKO-xpcom >= $gecko_min_version") 2>&5
+ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"\$GECKO_EXTRA_PKG_DEPENDENCIES \$GECKO_XPCOM >= \$gecko_min_version\"") >&5
+ ($PKG_CONFIG --exists --print-errors "$GECKO_EXTRA_PKG_DEPENDENCIES $GECKO_XPCOM >= $gecko_min_version") 2>&5
ac_status=$?
echo "$as_me:$LINENO: \$? = $ac_status" >&5
(exit $ac_status); }; then
- pkg_cv_GECKO_CFLAGS=`$PKG_CONFIG --cflags "$GECKO_EXTRA_PKG_DEPENDENCIES $GECKO-xpcom >= $gecko_min_version" 2>/dev/null`
+ pkg_cv_GECKO_CFLAGS=`$PKG_CONFIG --cflags "$GECKO_EXTRA_PKG_DEPENDENCIES $GECKO_XPCOM >= $gecko_min_version" 2>/dev/null`
else
pkg_failed=yes
fi
@@ -21665,12 +21635,12 @@ if test -n "$PKG_CONFIG"; then
pkg_cv_GECKO_LIBS="$GECKO_LIBS"
else
if test -n "$PKG_CONFIG" && \
- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"\$GECKO_EXTRA_PKG_DEPENDENCIES \$GECKO-xpcom >= \$gecko_min_version\"") >&5
- ($PKG_CONFIG --exists --print-errors "$GECKO_EXTRA_PKG_DEPENDENCIES $GECKO-xpcom >= $gecko_min_version") 2>&5
+ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"\$GECKO_EXTRA_PKG_DEPENDENCIES \$GECKO_XPCOM >= \$gecko_min_version\"") >&5
+ ($PKG_CONFIG --exists --print-errors "$GECKO_EXTRA_PKG_DEPENDENCIES $GECKO_XPCOM >= $gecko_min_version") 2>&5
ac_status=$?
echo "$as_me:$LINENO: \$? = $ac_status" >&5
(exit $ac_status); }; then
- pkg_cv_GECKO_LIBS=`$PKG_CONFIG --libs "$GECKO_EXTRA_PKG_DEPENDENCIES $GECKO-xpcom >= $gecko_min_version" 2>/dev/null`
+ pkg_cv_GECKO_LIBS=`$PKG_CONFIG --libs "$GECKO_EXTRA_PKG_DEPENDENCIES $GECKO_XPCOM >= $gecko_min_version" 2>/dev/null`
else
pkg_failed=yes
fi
@@ -21689,14 +21659,14 @@ else
_pkg_short_errors_supported=no
fi
if test $_pkg_short_errors_supported = yes; then
- GECKO_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "$GECKO_EXTRA_PKG_DEPENDENCIES $GECKO-xpcom >= $gecko_min_version"`
+ GECKO_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "$GECKO_EXTRA_PKG_DEPENDENCIES $GECKO_XPCOM >= $gecko_min_version"`
else
- GECKO_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "$GECKO_EXTRA_PKG_DEPENDENCIES $GECKO-xpcom >= $gecko_min_version"`
+ GECKO_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "$GECKO_EXTRA_PKG_DEPENDENCIES $GECKO_XPCOM >= $gecko_min_version"`
fi
# Put the nasty error message in config.log where it belongs
echo "$GECKO_PKG_ERRORS" >&5
- { { echo "$as_me:$LINENO: error: Package requirements ($GECKO_EXTRA_PKG_DEPENDENCIES $GECKO-xpcom >= $gecko_min_version) were not met:
+ { { echo "$as_me:$LINENO: error: Package requirements ($GECKO_EXTRA_PKG_DEPENDENCIES $GECKO_XPCOM >= $gecko_min_version) were not met:
$GECKO_PKG_ERRORS
@@ -21707,7 +21677,7 @@ Alternatively, you may set the environme
and GECKO_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
" >&5
-echo "$as_me: error: Package requirements ($GECKO_EXTRA_PKG_DEPENDENCIES $GECKO-xpcom >= $gecko_min_version) were not met:
+echo "$as_me: error: Package requirements ($GECKO_EXTRA_PKG_DEPENDENCIES $GECKO_XPCOM >= $gecko_min_version) were not met:
$GECKO_PKG_ERRORS
@@ -21781,10 +21751,10 @@ _SAVE_CPPFLAGS="$CPPFLAGS"
_SAVE_CXXFLAGS="$CXXFLAGS"
_SAVE_LDFLAGS="$LDFLAGS"
_SAVE_LIBS="$LIBS"
-CPPFLAGS="$CPPFLAGS $_GECKO_EXTRA_CPPFLAGS -I$_GECKO_INCLUDE_ROOT $($PKG_CONFIG --cflags-only-I ${gecko_cv_gecko}-xpcom)"
-CXXFLAGS="$CXXFLAGS $_GECKO_EXTRA_CXXFLAGS $($PKG_CONFIG --cflags-only-other ${gecko_cv_gecko}-xpcom)"
+CPPFLAGS="$CPPFLAGS $_GECKO_EXTRA_CPPFLAGS -I$_GECKO_INCLUDE_ROOT $($PKG_CONFIG --cflags-only-I ${gecko_cv_gecko_xpcom})"
+CXXFLAGS="$CXXFLAGS $_GECKO_EXTRA_CXXFLAGS $($PKG_CONFIG --cflags-only-other ${gecko_cv_gecko_xpcom})"
LDFLAGS="$LDFLAGS $_GECKO_EXTRA_LDFLAGS -Wl,--rpath=$_GECKO_HOME"
-LIBS="$LIBS $($PKG_CONFIG --libs ${gecko_cv_gecko}-xpcom)"
+LIBS="$LIBS $($PKG_CONFIG --libs ${gecko_cv_gecko_xpcom})"
_GECKO_DISPATCH_INCLUDEDIRS="content"
@@ -21888,10 +21858,10 @@ _SAVE_CPPFLAGS="$CPPFLAGS"
_SAVE_CXXFLAGS="$CXXFLAGS"
_SAVE_LDFLAGS="$LDFLAGS"
_SAVE_LIBS="$LIBS"
-CPPFLAGS="$CPPFLAGS $_GECKO_EXTRA_CPPFLAGS -I$_GECKO_INCLUDE_ROOT $($PKG_CONFIG --cflags-only-I ${gecko_cv_gecko}-xpcom)"
-CXXFLAGS="$CXXFLAGS $_GECKO_EXTRA_CXXFLAGS $($PKG_CONFIG --cflags-only-other ${gecko_cv_gecko}-xpcom)"
+CPPFLAGS="$CPPFLAGS $_GECKO_EXTRA_CPPFLAGS -I$_GECKO_INCLUDE_ROOT $($PKG_CONFIG --cflags-only-I ${gecko_cv_gecko_xpcom})"
+CXXFLAGS="$CXXFLAGS $_GECKO_EXTRA_CXXFLAGS $($PKG_CONFIG --cflags-only-other ${gecko_cv_gecko_xpcom})"
LDFLAGS="$LDFLAGS $_GECKO_EXTRA_LDFLAGS -Wl,--rpath=$_GECKO_HOME"
-LIBS="$LIBS $($PKG_CONFIG --libs ${gecko_cv_gecko}-xpcom)"
+LIBS="$LIBS $($PKG_CONFIG --libs ${gecko_cv_gecko_xpcom})"
_GECKO_DISPATCH_INCLUDEDIRS=""
@@ -25056,6 +25026,7 @@ GECKO_INCLUDE_ROOT!$GECKO_INCLUDE_ROOT$a
GECKO_HOME!$GECKO_HOME$ac_delim
GECKO_PREFIX!$GECKO_PREFIX$ac_delim
GECKO_EXTRA_LIBS!$GECKO_EXTRA_LIBS$ac_delim
+GECKO_XPCOM!$GECKO_XPCOM$ac_delim
GECKO_CFLAGS!$GECKO_CFLAGS$ac_delim
GECKO_LIBS!$GECKO_LIBS$ac_delim
GECKO_WARN_CXXFLAGS!$GECKO_WARN_CXXFLAGS$ac_delim
@@ -25078,7 +25049,6 @@ POFILES!$POFILES$ac_delim
POSUB!$POSUB$ac_delim
MKINSTALLDIRS!$MKINSTALLDIRS$ac_delim
PYTHON!$PYTHON$ac_delim
-PYTHON_VERSION!$PYTHON_VERSION$ac_delim
_ACEOF
if test `sed -n "s/.*$ac_delim\$/X/p" conf$$subs.sed | grep -c X` = 97; then
@@ -25120,6 +25090,7 @@ _ACEOF
ac_delim='%!_!# '
for ac_last_try in false false false false false :; do
cat >conf$$subs.sed <<_ACEOF
+PYTHON_VERSION!$PYTHON_VERSION$ac_delim
PYTHON_PREFIX!$PYTHON_PREFIX$ac_delim
PYTHON_EXEC_PREFIX!$PYTHON_EXEC_PREFIX$ac_delim
PYTHON_PLATFORM!$PYTHON_PLATFORM$ac_delim
@@ -25131,7 +25102,7 @@ LIBOBJS!$LIBOBJS$ac_delim
LTLIBOBJS!$LTLIBOBJS$ac_delim
_ACEOF
- if test `sed -n "s/.*$ac_delim\$/X/p" conf$$subs.sed | grep -c X` = 9; then
+ if test `sed -n "s/.*$ac_delim\$/X/p" conf$$subs.sed | grep -c X` = 10; then
break
elif $ac_last_try; then
{ { echo "$as_me:$LINENO: error: could not make $CONFIG_STATUS" >&5