- Add patch for RH bug #230837 (initialize GThread).
This commit is contained in:
parent
17708e462c
commit
db3c7ca100
11
devhelp-0.13-initialize-gthread.patch
Normal file
11
devhelp-0.13-initialize-gthread.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- devhelp-0.13/src/dh-main.c.initialize-gthread 2007-04-23 15:05:15.000000000 -0400
|
||||||
|
+++ devhelp-0.13/src/dh-main.c 2007-04-23 15:05:31.000000000 -0400
|
||||||
|
@@ -112,6 +112,8 @@
|
||||||
|
bind_textdomain_codeset (GETTEXT_PACKAGE, "UTF-8");
|
||||||
|
textdomain (PACKAGE);
|
||||||
|
|
||||||
|
+ g_thread_init (NULL);
|
||||||
|
+
|
||||||
|
if (!gtk_init_with_args (&argc, &argv, NULL, options, GETTEXT_PACKAGE, &error)) {
|
||||||
|
g_printerr ("%s\n", error->message);
|
||||||
|
return 1;
|
11
devhelp.spec
11
devhelp.spec
@ -4,7 +4,7 @@
|
|||||||
|
|
||||||
Name: devhelp
|
Name: devhelp
|
||||||
Version: 0.13
|
Version: 0.13
|
||||||
Release: 6%{?dist}
|
Release: 7%{?dist}
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
Summary: API document browser
|
Summary: API document browser
|
||||||
@ -12,6 +12,11 @@ URL: http://developer.imendio.com/projects/devhelp
|
|||||||
Source: http://ftp.gnome.org/pub/GNOME/sources/devhelp/%{version}/devhelp-%{version}.tar.bz2
|
Source: http://ftp.gnome.org/pub/GNOME/sources/devhelp/%{version}/devhelp-%{version}.tar.bz2
|
||||||
BuildRoot: %{_tmppath}/devhelp-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/devhelp-%{version}-%{release}-root
|
||||||
|
|
||||||
|
### Patch ###
|
||||||
|
|
||||||
|
# RH bug #230837 / GNOME bug #414221
|
||||||
|
Patch1: devhelp-0.13-initialize-gthread.patch
|
||||||
|
|
||||||
### Dependencies ###
|
### Dependencies ###
|
||||||
|
|
||||||
Requires(pre): GConf2 >= 2.14
|
Requires(pre): GConf2 >= 2.14
|
||||||
@ -47,6 +52,7 @@ Library of Devhelp for embedding into other applications
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n devhelp-%{version}
|
%setup -q -n devhelp-%{version}
|
||||||
|
%patch1 -p1 -b .initialize-gthread
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-static
|
%configure --disable-static
|
||||||
@ -127,6 +133,9 @@ fi
|
|||||||
%{_libdir}/pkgconfig/*
|
%{_libdir}/pkgconfig/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 23 2007 Matthew Barnes <mbarnes@redhat.com> - 0.13-7.fc7
|
||||||
|
- Add patch for RH bug #230837 (initialize GThread).
|
||||||
|
|
||||||
* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 0.13-6
|
* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 0.13-6
|
||||||
- Don't install INSTALL
|
- Don't install INSTALL
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user