parent
ad40f62be5
commit
c448447729
@ -1,33 +0,0 @@
|
||||
Index: src/dh-parser.c
|
||||
===================================================================
|
||||
--- src/dh-parser.c (revision 1263)
|
||||
+++ src/dh-parser.c (working copy)
|
||||
@@ -66,6 +66,7 @@
|
||||
{
|
||||
gint i;
|
||||
gint line, col;
|
||||
+ gchar *tmp_base;
|
||||
const gchar *title = NULL;
|
||||
const gchar *base = NULL;
|
||||
const gchar *name = NULL;
|
||||
@@ -126,11 +127,18 @@
|
||||
}
|
||||
|
||||
if (base) {
|
||||
- parser->base = g_strdup (base);
|
||||
+ tmp_base = g_strdup (base);
|
||||
} else {
|
||||
- parser->base = g_path_get_dirname (parser->path);
|
||||
+ tmp_base = g_path_get_dirname (parser->path);
|
||||
}
|
||||
+ parser->base = g_filename_to_uri (tmp_base, NULL, NULL);
|
||||
|
||||
+ /* In case the conversion didn't work */
|
||||
+ if (parser->base)
|
||||
+ g_free (tmp_base);
|
||||
+ else
|
||||
+ parser->base = tmp_base;
|
||||
+
|
||||
link = dh_link_new (DH_LINK_TYPE_BOOK,
|
||||
parser->base,
|
||||
name,
|
11
devhelp.spec
11
devhelp.spec
@ -6,7 +6,7 @@
|
||||
|
||||
Name: devhelp
|
||||
Version: 0.23.1
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Development/Tools
|
||||
Summary: API documention browser
|
||||
@ -14,11 +14,6 @@ URL: http://developer.imendio.com/projects/devhelp
|
||||
Source: http://download.gnome.org/sources/devhelp/0.23/devhelp-%{version}.tar.bz2
|
||||
BuildRoot: %{_tmppath}/devhelp-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
### Patches ###
|
||||
|
||||
# RH bug #572022
|
||||
Patch0: devhelp-load-uris.patch
|
||||
|
||||
### Dependencies ###
|
||||
|
||||
Requires(pre): GConf2 >= 2.14
|
||||
@ -55,7 +50,6 @@ into other applications such as IDEs.
|
||||
|
||||
%prep
|
||||
%setup -q -n devhelp-%{version}
|
||||
%patch0 -p0 -b .uris
|
||||
|
||||
# force regeneration
|
||||
rm data/devhelp.schemas
|
||||
@ -142,6 +136,9 @@ fi
|
||||
%{_libdir}/pkgconfig/*
|
||||
|
||||
%changelog
|
||||
* Fri Aug 21 2009 Matthew Barnes <mbarnes@redhat.com> - 0.23.1-2
|
||||
- Remove patch for GNOME bug #572022 to help fix RH bug #518481.
|
||||
|
||||
* Wed Aug 12 2009 Matthew Barnes <mbarnes@redhat.com> - 0.23.1-1
|
||||
- Update to 0.23.1
|
||||
- Remove patch for GNOME bug #588655 (fixed upstream).
|
||||
|
Loading…
Reference in New Issue
Block a user