- Update to 0.17
- Remove patch for GNOME bug #499050 (fixed upstream).
This commit is contained in:
parent
c2379af3c6
commit
569d63b8f1
@ -1 +1 @@
|
||||
devhelp-0.16.1.tar.bz2
|
||||
devhelp-0.17.tar.bz2
|
||||
|
@ -1,30 +0,0 @@
|
||||
diff -up devhelp-0.16.1/src/Yelper.cpp.xl devhelp-0.16.1/src/Yelper.cpp
|
||||
--- devhelp-0.16.1/src/Yelper.cpp.xl 2007-05-28 09:42:20.000000000 +0200
|
||||
+++ devhelp-0.16.1/src/Yelper.cpp 2007-11-22 13:00:28.000000000 +0100
|
||||
@@ -41,7 +41,9 @@
|
||||
#include <nsIDOMWindow.h>
|
||||
#include <nsIInterfaceRequestorUtils.h>
|
||||
#include <nsIPrefService.h>
|
||||
+#ifndef HAVE_GECKO_1_9
|
||||
#include <nsIPrintSettings.h>
|
||||
+#endif
|
||||
#include <nsISelectionController.h>
|
||||
#include <nsITypeAheadFind.h>
|
||||
#include <nsIWebBrowser.h>
|
||||
@@ -169,16 +171,9 @@ Yelper::Find (const char *aSearchString)
|
||||
|
||||
nsresult rv;
|
||||
PRUint16 found = nsITypeAheadFind::FIND_NOTFOUND;
|
||||
-#ifdef HAVE_GECKO_1_9
|
||||
- rv = mFinder->Find (NS_ConvertUTF8toUTF16 (aSearchString),
|
||||
- PR_FALSE /* links only? */,
|
||||
- mHasFocus,
|
||||
- &found);
|
||||
-#else
|
||||
rv = mFinder->Find (NS_ConvertUTF8toUTF16 (aSearchString),
|
||||
PR_FALSE /* links only? */,
|
||||
&found);
|
||||
-#endif
|
||||
|
||||
return NS_SUCCEEDED (rv) && (found == nsITypeAheadFind::FIND_FOUND || found == nsITypeAheadFind::FIND_WRAPPED);
|
||||
}
|
11
devhelp.spec
11
devhelp.spec
@ -5,15 +5,13 @@
|
||||
### Abstract ###
|
||||
|
||||
Name: devhelp
|
||||
Version: 0.16.1
|
||||
Release: 5%{?dist}
|
||||
Version: 0.17
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Development/Tools
|
||||
Summary: API document browser
|
||||
URL: http://developer.imendio.com/projects/devhelp
|
||||
Source: http://download.gnome.org/sources/devhelp/0.16/devhelp-%{version}.tar.bz2
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=499050
|
||||
Patch: devhelp-0.16.1-xulrunner.patch
|
||||
BuildRoot: %{_tmppath}/devhelp-%{version}-%{release}-root
|
||||
|
||||
### Dependencies ###
|
||||
@ -51,7 +49,6 @@ Library of Devhelp for embedding into other applications
|
||||
|
||||
%prep
|
||||
%setup -q -n devhelp-%{version}
|
||||
%patch -p1 -b .xl
|
||||
|
||||
%build
|
||||
%configure --disable-static --with-gecko=xulrunner
|
||||
@ -131,6 +128,10 @@ fi
|
||||
%{_libdir}/pkgconfig/*
|
||||
|
||||
%changelog
|
||||
* Mon Jan 07 2008 Matthew Barnes <mbarnes@redhat.com> - 0.17.fc9
|
||||
- Update to 0.17
|
||||
- Remove patch for GNOME bug #499050 (fixed upstream).
|
||||
|
||||
* Mon Dec 31 2007 Jeremy Katz <katzj@redhat.com> - 0.16.1-5
|
||||
- Rebuild against newer xulrunner
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user