- Add patch for GNOME bug #588655 (work around GLib deprecations).
This commit is contained in:
parent
35ef208b74
commit
2a80498fe7
15
devhelp-0.23-deprecation-workaround.patch
Normal file
15
devhelp-0.23-deprecation-workaround.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
diff -up devhelp-0.23/src/dh-assistant-view.c.deprecation-workaround devhelp-0.23/src/dh-assistant-view.c
|
||||||
|
--- devhelp-0.23/src/dh-assistant-view.c.deprecation-workaround 2008-11-28 10:56:04.000000000 -0500
|
||||||
|
+++ devhelp-0.23/src/dh-assistant-view.c 2009-07-15 09:47:19.000000000 -0400
|
||||||
|
@@ -340,7 +340,11 @@ assistant_view_set_link (DhAssistantView
|
||||||
|
webkit_web_view_open (WEBKIT_WEB_VIEW (view), "about:blank");
|
||||||
|
}
|
||||||
|
|
||||||
|
+#if GLIB_CHECK_VERSION(2,21,3)
|
||||||
|
+ g_mapped_file_unref (file);
|
||||||
|
+#else
|
||||||
|
g_mapped_file_free (file);
|
||||||
|
+#endif
|
||||||
|
g_free (filename);
|
||||||
|
}
|
||||||
|
|
17
devhelp.spec
17
devhelp.spec
@ -6,7 +6,7 @@
|
|||||||
|
|
||||||
Name: devhelp
|
Name: devhelp
|
||||||
Version: 0.23
|
Version: 0.23
|
||||||
Release: 7%{?dist}
|
Release: 8%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
Summary: API documention browser
|
Summary: API documention browser
|
||||||
@ -14,6 +14,14 @@ URL: http://developer.imendio.com/projects/devhelp
|
|||||||
Source: http://download.gnome.org/sources/devhelp/0.23/devhelp-%{version}.tar.bz2
|
Source: http://download.gnome.org/sources/devhelp/0.23/devhelp-%{version}.tar.bz2
|
||||||
BuildRoot: %{_tmppath}/devhelp-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/devhelp-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
|
### Patches ###
|
||||||
|
|
||||||
|
# RH bug #572022
|
||||||
|
Patch0: devhelp-load-uris.patch
|
||||||
|
|
||||||
|
# GNOME bug #588655
|
||||||
|
Patch1: devhelp-0.23-deprecation-workaround.patch
|
||||||
|
|
||||||
### Dependencies ###
|
### Dependencies ###
|
||||||
|
|
||||||
Requires(pre): GConf2 >= 2.14
|
Requires(pre): GConf2 >= 2.14
|
||||||
@ -30,9 +38,6 @@ BuildRequires: gtk2-devel
|
|||||||
BuildRequires: WebKit-gtk-devel
|
BuildRequires: WebKit-gtk-devel
|
||||||
BuildRequires: GConf2-devel
|
BuildRequires: GConf2-devel
|
||||||
|
|
||||||
# http://bugzilla.gnome.org/show_bug.cgi?id=572022
|
|
||||||
Patch0: devhelp-load-uris.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Devhelp is an API documentation browser for the GNOME desktop.
|
Devhelp is an API documentation browser for the GNOME desktop.
|
||||||
It works natively with API documentation generated by gtk-doc.
|
It works natively with API documentation generated by gtk-doc.
|
||||||
@ -54,6 +59,7 @@ into other applications such as IDEs.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n devhelp-%{version}
|
%setup -q -n devhelp-%{version}
|
||||||
%patch0 -p0 -b .uris
|
%patch0 -p0 -b .uris
|
||||||
|
%patch1 -p1 -b .deprecation-workaround
|
||||||
|
|
||||||
# force regeneration
|
# force regeneration
|
||||||
rm data/devhelp.schemas
|
rm data/devhelp.schemas
|
||||||
@ -140,6 +146,9 @@ fi
|
|||||||
%{_libdir}/pkgconfig/*
|
%{_libdir}/pkgconfig/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jul 15 2009 Matthew Barnes <mbarnes@redhat.com> - 0.23-8
|
||||||
|
- Add patch for GNOME bug #588655 (work around GLib deprecations).
|
||||||
|
|
||||||
* Thu Jul 2 2009 Matthias Clasen <mclasen@redhat.com> - 0.23-7
|
* Thu Jul 2 2009 Matthias Clasen <mclasen@redhat.com> - 0.23-7
|
||||||
- Shrink GConf schemas
|
- Shrink GConf schemas
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user