Rebase to 1.21.2
Add support for ppc64le and aarch64 Enable the test suite Modify ports: Some CI systems complain about the usage of the 8888 port. Improve the way PPC64LE support is enabled. Resolves: RHEL-22820
This commit is contained in:
parent
be1404c5e5
commit
6e84149db8
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
|||||||
SOURCES/delve-1.9.1.tar.gz
|
SOURCES/delve-1.9.1.tar.gz
|
||||||
/delve-1.9.1.tar.gz
|
/delve-1.9.1.tar.gz
|
||||||
/delve-1.20.2.tar.gz
|
/delve-1.20.2.tar.gz
|
||||||
|
/delve-1.21.2.tar.gz
|
||||||
|
23
delve.spec
23
delve.spec
@ -1,5 +1,9 @@
|
|||||||
|
%ifarch ppc64le
|
||||||
|
%global exp "-tags=exp.linuxppc64le"
|
||||||
|
%endif
|
||||||
|
|
||||||
Name: delve
|
Name: delve
|
||||||
Version: 1.20.2
|
Version: 1.21.2
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A debugger for the Go programming language
|
Summary: A debugger for the Go programming language
|
||||||
|
|
||||||
@ -15,6 +19,8 @@ BuildRequires: lsof
|
|||||||
|
|
||||||
Provides: dlv = %{version}
|
Provides: dlv = %{version}
|
||||||
|
|
||||||
|
Patch0001: modify-ports.patch
|
||||||
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Delve is a debugger for the Go programming language. The goal of the project
|
Delve is a debugger for the Go programming language. The goal of the project
|
||||||
@ -26,6 +32,7 @@ much as possible.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%autopatch -p1
|
||||||
|
|
||||||
rm -rf go.mod
|
rm -rf go.mod
|
||||||
mv vendor %{_builddir}/src
|
mv vendor %{_builddir}/src
|
||||||
@ -38,7 +45,7 @@ mv %{_builddir}/src %{_builddir}/%{name}-%{version}/_build/src
|
|||||||
%build
|
%build
|
||||||
export GO111MODULE=off
|
export GO111MODULE=off
|
||||||
export GOPATH="%{_builddir}/%{name}-%{version}/_build"
|
export GOPATH="%{_builddir}/%{name}-%{version}/_build"
|
||||||
%gobuild -o bin/dlv github.com/go-delve/delve/cmd/dlv
|
%gobuild %{?exp} -o bin/dlv github.com/go-delve/delve/cmd/dlv
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -51,8 +58,8 @@ install -Dpm 0755 bin/dlv %{buildroot}%{_bindir}/dlv
|
|||||||
export GO111MODULE=off
|
export GO111MODULE=off
|
||||||
export GOPATH="%{_builddir}/%{name}-%{version}/_build"
|
export GOPATH="%{_builddir}/%{name}-%{version}/_build"
|
||||||
cd "_build/src/github.com/go-delve/%{name}"
|
cd "_build/src/github.com/go-delve/%{name}"
|
||||||
for d in $(go list ./... | grep -v cmd | grep -v scripts); do
|
for d in $(go list %{?exp} ./... | grep -v cmd | grep -v scripts); do
|
||||||
go test ${d}
|
go test %{?exp} ${d}
|
||||||
done
|
done
|
||||||
|
|
||||||
|
|
||||||
@ -64,6 +71,14 @@ done
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 26 2024 Alejandro Sáez <asm@redhat.com> - 1.21.2-1
|
||||||
|
- Rebase to 1.21.2
|
||||||
|
- Add support for ppc64le and aarch64
|
||||||
|
- Enable the test suite
|
||||||
|
- Modify ports: Some CI systems complain about the usage of the 8888 port.
|
||||||
|
- Improve the way PPC64LE support is enabled.
|
||||||
|
- Resolves: RHEL-22820
|
||||||
|
|
||||||
* Fri May 26 2023 Alejandro Sáez <asm@redhat.com> - 1.20.2-1
|
* Fri May 26 2023 Alejandro Sáez <asm@redhat.com> - 1.20.2-1
|
||||||
- Rebase to 1.20.2
|
- Rebase to 1.20.2
|
||||||
- Resolves: rhbz#2186495
|
- Resolves: rhbz#2186495
|
||||||
|
64
modify-ports.patch
Normal file
64
modify-ports.patch
Normal file
@ -0,0 +1,64 @@
|
|||||||
|
From 1ba9183936e11839811cf27472677d44ea4eb1a2 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?=C3=81lex=20S=C3=A1ez?= <asm@redhat.com>
|
||||||
|
Date: Wed, 24 Jan 2024 13:10:29 +0100
|
||||||
|
Subject: [PATCH] Modify tests
|
||||||
|
|
||||||
|
Some tests are not working properly with the build system so we need to
|
||||||
|
adapt them, like changing the ports they used.
|
||||||
|
---
|
||||||
|
_fixtures/notify-v2.go | 2 +-
|
||||||
|
pkg/proc/proc_test.go | 6 ++++++
|
||||||
|
pkg/terminal/command_test.go | 2 +-
|
||||||
|
3 files changed, 8 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/_fixtures/notify-v2.go b/_fixtures/notify-v2.go
|
||||||
|
index eb80526b..0f562c27 100644
|
||||||
|
--- a/_fixtures/notify-v2.go
|
||||||
|
+++ b/_fixtures/notify-v2.go
|
||||||
|
@@ -19,5 +19,5 @@ func main() {
|
||||||
|
}()
|
||||||
|
})
|
||||||
|
|
||||||
|
- log.Fatalln(http.ListenAndServe("127.0.0.1:8888", nil))
|
||||||
|
+ log.Fatalln(http.ListenAndServe("127.0.0.1:8889", nil))
|
||||||
|
}
|
||||||
|
diff --git a/pkg/proc/proc_test.go b/pkg/proc/proc_test.go
|
||||||
|
index 714a4d1d..ae9f0bd9 100644
|
||||||
|
--- a/pkg/proc/proc_test.go
|
||||||
|
+++ b/pkg/proc/proc_test.go
|
||||||
|
@@ -2512,6 +2512,9 @@ func TestStepConcurrentDirect(t *testing.T) {
|
||||||
|
}
|
||||||
|
|
||||||
|
func TestStepConcurrentPtr(t *testing.T) {
|
||||||
|
+ if runtime.GOARCH == "ppc64le" {
|
||||||
|
+ t.Skipf("Skipping due to CI issues")
|
||||||
|
+ }
|
||||||
|
protest.AllowRecording(t)
|
||||||
|
withTestProcess("teststepconcurrent", t, func(p *proc.Target, grp *proc.TargetGroup, fixture protest.Fixture) {
|
||||||
|
setFileBreakpoint(p, t, fixture.Source, 24)
|
||||||
|
@@ -6080,6 +6083,9 @@ func TestEscapeCheckUnreadable(t *testing.T) {
|
||||||
|
}
|
||||||
|
|
||||||
|
func TestStepShadowConcurrentBreakpoint(t *testing.T) {
|
||||||
|
+ if runtime.GOARCH == "ppc64le" {
|
||||||
|
+ t.Skipf("Skipping due to CI issues")
|
||||||
|
+ }
|
||||||
|
// Checks that a StepBreakpoint can not shadow a concurrently hit user breakpoint
|
||||||
|
withTestProcess("stepshadow", t, func(p *proc.Target, grp *proc.TargetGroup, fixture protest.Fixture) {
|
||||||
|
break2 := setFunctionBreakpoint(p, t, "main.stacktraceme2")
|
||||||
|
diff --git a/pkg/terminal/command_test.go b/pkg/terminal/command_test.go
|
||||||
|
index 57b62105..f6e3a3d9 100644
|
||||||
|
--- a/pkg/terminal/command_test.go
|
||||||
|
+++ b/pkg/terminal/command_test.go
|
||||||
|
@@ -695,7 +695,7 @@ func TestIssue827(t *testing.T) {
|
||||||
|
withTestTerminal("notify-v2", t, func(term *FakeTerminal) {
|
||||||
|
go func() {
|
||||||
|
time.Sleep(1 * time.Second)
|
||||||
|
- resp, err := http.Get("http://127.0.0.1:8888/test")
|
||||||
|
+ resp, err := http.Get("http://127.0.0.1:8889/test")
|
||||||
|
if err == nil {
|
||||||
|
resp.Body.Close()
|
||||||
|
}
|
||||||
|
--
|
||||||
|
2.43.0
|
||||||
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (delve-1.20.2.tar.gz) = c48027d200257d0a979fbf2ea3a65f6dc645d1c231264023b10c216de1e3d80db86ac775cdb02f4dcd261756c8e26bbdce598cce709eb2aa4c9853f2e0cf6cf8
|
SHA512 (delve-1.21.2.tar.gz) = 78953099b1ba79d04136b037d1fd45dc2f9013428a9eed77bb0bba7c43a00370d701d0576e9c1367e5e45f236ceb4bcdfc1c3366db95999dbe9e758e54225541
|
||||||
|
Loading…
Reference in New Issue
Block a user