Update to 1.21.2
Switch to bundled dependencies to simplify the process. Add bundle-deps.sh like rpms/golang has. Remove 0001-Skip-TestCgoStacktrace2.patch
This commit is contained in:
parent
5956211b2b
commit
2b207cbf27
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
/delve-1.20.1.tar.gz
|
||||
/delve-1.20.2.tar.gz
|
||||
/delve-1.21.0.tar.gz
|
||||
/delve-1.21.2.tar.gz
|
||||
|
@ -1,24 +0,0 @@
|
||||
From dff6a7871debe62db762eea34a1356f11fda305c Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?=C3=81lex=20S=C3=A1ez?= <asm@redhat.com>
|
||||
Date: Mon, 31 Jul 2023 14:46:54 +0200
|
||||
Subject: [PATCH] Skip TestCgoStacktrace2
|
||||
|
||||
---
|
||||
pkg/proc/proc_test.go | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/pkg/proc/proc_test.go b/pkg/proc/proc_test.go
|
||||
index 0cb84f6b..88db4c43 100644
|
||||
--- a/pkg/proc/proc_test.go
|
||||
+++ b/pkg/proc/proc_test.go
|
||||
@@ -4606,6 +4606,7 @@ func TestCgoStacktrace2(t *testing.T) {
|
||||
skipOn(t, "upstream issue", "windows")
|
||||
skipOn(t, "broken", "386")
|
||||
skipOn(t, "broken", "arm64")
|
||||
+ skipOn(t, "broken", "amd64")
|
||||
protest.MustHaveCgo(t)
|
||||
// If a panic happens during cgo execution the stacktrace should show the C
|
||||
// function that caused the problem.
|
||||
--
|
||||
2.41.0
|
||||
|
22
bundled-deps.sh
Executable file
22
bundled-deps.sh
Executable file
@ -0,0 +1,22 @@
|
||||
#! /bin/bash
|
||||
# Copyright (C) 2021 Jakub Čajka jcajka@redhat.com
|
||||
#
|
||||
# This program is free software; you can redistribute it and/or
|
||||
# modify it under the terms of the GNU General Public License
|
||||
# as published by the Free Software Foundation; either version 2
|
||||
# of the License, or (at your option) any later version.
|
||||
#
|
||||
# This program is distributed in the hope that it will be useful,
|
||||
# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
# GNU General Public License for more details.
|
||||
#
|
||||
# You should have received a copy of the GNU General Public License
|
||||
# along with this program; if not, write to the Free Software
|
||||
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
|
||||
|
||||
provides=""
|
||||
for bundle in $(find -name modules.txt); do
|
||||
provides="$provides\n$(cat "$bundle" | grep "^# " | grep -v "# explicit" | sed -r s/"^#.* => "// | sed -r "s/# //" | sed -r "s:(.*) v(.*):Provides\: bundled(golang(\1)) = \2:")"
|
||||
done
|
||||
echo -e "$provides" | sed 's/-/./g' | sort -u
|
67
delve.spec
67
delve.spec
@ -3,7 +3,7 @@
|
||||
|
||||
# https://github.com/go-delve/delve
|
||||
%global goipath github.com/go-delve/delve
|
||||
Version: 1.21.0
|
||||
Version: 1.21.2
|
||||
|
||||
%global common_description %{expand:
|
||||
Delve is a debugger for the Go programming language. The goal of the project
|
||||
@ -27,56 +27,51 @@ License: MIT
|
||||
URL: %{gourl}
|
||||
Source0: %{gosource}
|
||||
|
||||
# RHEL builds with vendored dependencies
|
||||
%if %{undefined rhel}
|
||||
# This dependencies are only in use in x86_64
|
||||
%ifarch x86_64
|
||||
BuildRequires: golang(github.com/cilium/ebpf)
|
||||
BuildRequires: golang(github.com/cilium/ebpf/link)
|
||||
BuildRequires: golang(github.com/cilium/ebpf/ringbuf)
|
||||
%endif
|
||||
BuildRequires: golang(github.com/cosiner/argv)
|
||||
BuildRequires: golang(github.com/creack/pty)
|
||||
BuildRequires: golang(github.com/derekparker/trie)
|
||||
BuildRequires: golang(github.com/go-delve/liner)
|
||||
BuildRequires: golang(github.com/google/go-dap)
|
||||
BuildRequires: golang(github.com/hashicorp/golang-lru/simplelru)
|
||||
BuildRequires: golang(github.com/mattn/go-isatty)
|
||||
BuildRequires: golang(github.com/sirupsen/logrus)
|
||||
BuildRequires: golang(github.com/spf13/cobra)
|
||||
BuildRequires: golang(github.com/spf13/cobra/doc)
|
||||
BuildRequires: golang(golang.org/x/arch/arm64/arm64asm)
|
||||
BuildRequires: golang(golang.org/x/arch/ppc64/ppc64asm)
|
||||
BuildRequires: golang(golang.org/x/arch/x86/x86asm)
|
||||
BuildRequires: golang(golang.org/x/sys/unix)
|
||||
BuildRequires: golang(golang.org/x/tools/go/packages)
|
||||
BuildRequires: golang(gopkg.in/yaml.v2)
|
||||
BuildRequires: golang(go.starlark.net/resolve)
|
||||
BuildRequires: golang(go.starlark.net/starlark)
|
||||
BuildRequires: golang(go.starlark.net/syntax)
|
||||
%endif
|
||||
BuildRequires: lsof
|
||||
BuildRequires: git
|
||||
|
||||
Patch1: 0001-Skip-TestCgoStacktrace2.patch
|
||||
# Bundled/Vendored provides generated by bundled-deps.sh based on the in tree module data
|
||||
# - in version filed substituted with . per versioning guidelines
|
||||
Provides: bundled(golang(github.com/cilium/ebpf)) = 0.11.0
|
||||
Provides: bundled(golang(github.com/cosiner/argv)) = 0.1.0
|
||||
Provides: bundled(golang(github.com/cpuguy83/go.md2man/v2)) = 2.0.0
|
||||
Provides: bundled(golang(github.com/creack/pty)) = 1.1.9
|
||||
Provides: bundled(golang(github.com/derekparker/trie)) = 0.0.0.20221213183930.4c74548207f4
|
||||
Provides: bundled(golang(github.com/go.delve/liner)) = 1.2.3.0.20220127212407.d32d89dd2a5d
|
||||
Provides: bundled(golang(github.com/google/go.dap)) = 0.9.1
|
||||
Provides: bundled(golang(github.com/hashicorp/golang.lru)) = 0.5.4
|
||||
Provides: bundled(golang(github.com/inconshreveable/mousetrap)) = 1.0.0
|
||||
Provides: bundled(golang(github.com/konsorten/go.windows.terminal.sequences)) = 1.0.3
|
||||
Provides: bundled(golang(github.com/mattn/go.colorable)) = 0.0.9
|
||||
Provides: bundled(golang(github.com/mattn/go.isatty)) = 0.0.3
|
||||
Provides: bundled(golang(github.com/mattn/go.runewidth)) = 0.0.13
|
||||
Provides: bundled(golang(github.com/rivo/uniseg)) = 0.2.0
|
||||
Provides: bundled(golang(github.com/russross/blackfriday/v2)) = 2.0.1
|
||||
Provides: bundled(golang(github.com/shurcooL/sanitized_anchor_name)) = 1.0.0
|
||||
Provides: bundled(golang(github.com/sirupsen/logrus)) = 1.6.0
|
||||
Provides: bundled(golang(github.com/spf13/cobra)) = 1.1.3
|
||||
Provides: bundled(golang(github.com/spf13/pflag)) = 1.0.5
|
||||
Provides: bundled(golang(github.com/stretchr/testify)) = 1.7.0
|
||||
Provides: bundled(golang(golang.org/x/arch)) = 0.0.0.20190927153633.4e8777c89be4
|
||||
Provides: bundled(golang(golang.org/x/exp)) = 0.0.0.20230224173230.c95f2b4c22f2
|
||||
Provides: bundled(golang(golang.org/x/mod)) = 0.12.0
|
||||
Provides: bundled(golang(golang.org/x/sys)) = 0.12.0
|
||||
Provides: bundled(golang(golang.org/x/tools)) = 0.13.0
|
||||
Provides: bundled(golang(gopkg.in/yaml.v2)) = 2.4.0
|
||||
Provides: bundled(golang(go.starlark.net)) = 0.0.0.20220816155156.cfacd8902214
|
||||
|
||||
%description
|
||||
%{common_description}
|
||||
|
||||
%prep
|
||||
echo "=== Start prep ==="
|
||||
%if %{defined rhel}
|
||||
%goprep -k
|
||||
# unpack vendored dependencies to GOPATH
|
||||
tar c -C vendor/ . | tar x -C %{gobuilddir}/src
|
||||
%autopatch -v -p1
|
||||
%else
|
||||
%goprep
|
||||
%autopatch -v -p1
|
||||
|
||||
%generate_buildrequires
|
||||
%go_generate_buildrequires
|
||||
%endif
|
||||
|
||||
%build
|
||||
echo "=== Start build ==="
|
||||
@ -106,7 +101,7 @@ popd
|
||||
%endif
|
||||
|
||||
%files
|
||||
%license LICENSE %{?rhel:vendor/modules.txt}
|
||||
%license LICENSE vendor/modules.txt
|
||||
%doc CONTRIBUTING.md CHANGELOG.md
|
||||
%doc Documentation/*
|
||||
%{_bindir}/dlv
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (delve-1.21.0.tar.gz) = 2b2249b14d5565fbb59408251a1272db8e092ab7ac7cb65d33b810b89f1352d3b487a8d582dde8f1102d0362ee142e6106c98cd217c5031c9a09497d20a0cdde
|
||||
SHA512 (delve-1.21.2.tar.gz) = 78953099b1ba79d04136b037d1fd45dc2f9013428a9eed77bb0bba7c43a00370d701d0576e9c1367e5e45f236ceb4bcdfc1c3366db95999dbe9e758e54225541
|
||||
|
Loading…
Reference in New Issue
Block a user