Update Delve to 1.24.1
Resolves: RHEL-61262
This commit is contained in:
parent
05b83f61f2
commit
0929f23d8d
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@
|
||||
/delve-1.21.2.tar.gz
|
||||
/delve-1.22.0.tar.gz
|
||||
/delve-1.22.1.tar.gz
|
||||
/delve-1.24.1.tar.gz
|
||||
|
@ -1,37 +0,0 @@
|
||||
From 73c738dcddaf9771c1ef5ab48b34c259cac4653c Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?=C3=81lex=20S=C3=A1ez?= <asm@redhat.com>
|
||||
Date: Fri, 2 Feb 2024 14:14:34 +0100
|
||||
Subject: [PATCH] Skipping due issues with the go version in Fedora
|
||||
|
||||
If the Go package gets an update, Koschei will trigger a Delve build
|
||||
that will fail because Delve is not supporting the newer version of Go.
|
||||
|
||||
Skipping these tests is not ideal but gore returns an error if the go
|
||||
version is missing.
|
||||
---
|
||||
pkg/proc/proc_test.go | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/pkg/proc/proc_test.go b/pkg/proc/proc_test.go
|
||||
index d39d516b..5992e9e8 100644
|
||||
--- a/pkg/proc/proc_test.go
|
||||
+++ b/pkg/proc/proc_test.go
|
||||
@@ -3188,6 +3188,7 @@ func TestShadowedFlag(t *testing.T) {
|
||||
func TestDebugStripped(t *testing.T) {
|
||||
// Currently only implemented for Linux ELF and macOS Mach-O executables.
|
||||
// TODO(derekparker): Add support for PE.
|
||||
+ skipOn(t, "not working on Fedora CI", "linux")
|
||||
skipOn(t, "not working on windows", "windows")
|
||||
skipOn(t, "not working on freebsd", "freebsd")
|
||||
skipOn(t, "not working on linux/386", "linux", "386")
|
||||
@@ -3205,6 +3206,7 @@ func TestDebugStripped(t *testing.T) {
|
||||
func TestDebugStripped2(t *testing.T) {
|
||||
// Currently only implemented for Linux ELF executables.
|
||||
// TODO(derekparker): Add support for PE.
|
||||
+ skipOn(t, "not working on Fedora CI", "linux")
|
||||
skipOn(t, "not working on windows", "windows")
|
||||
skipOn(t, "not working on freebsd", "freebsd")
|
||||
skipOn(t, "not working on linux/386", "linux", "386")
|
||||
--
|
||||
2.43.0
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff --git a/pkg/terminal/command_test.go b/pkg/terminal/command_test.go
|
||||
index d97d0bc..a71e34b 100644
|
||||
--- a/pkg/terminal/command_test.go
|
||||
+++ b/pkg/terminal/command_test.go
|
||||
@@ -690,6 +690,7 @@ func TestRestart(t *testing.T) {
|
||||
}
|
||||
|
||||
func TestIssue827(t *testing.T) {
|
||||
+ t.Skip("port 8888 might already be in use")
|
||||
// switching goroutines when the current thread isn't running any goroutine
|
||||
// causes nil pointer dereference.
|
||||
withTestTerminal("notify-v2", t, func(term *FakeTerminal) {
|
27
delve.spec
27
delve.spec
@ -8,7 +8,7 @@
|
||||
|
||||
# https://github.com/go-delve/delve
|
||||
%global goipath github.com/go-delve/delve
|
||||
Version: 1.22.1
|
||||
Version: 1.24.1
|
||||
|
||||
%global common_description %{expand:
|
||||
Delve is a debugger for the Go programming language. The goal of the project
|
||||
@ -39,11 +39,11 @@ BuildRequires: git
|
||||
# - in version filed substituted with . per versioning guidelines
|
||||
Provides: bundled(golang(github.com/cilium/ebpf)) = 0.11.0
|
||||
Provides: bundled(golang(github.com/cosiner/argv)) = 0.1.0
|
||||
Provides: bundled(golang(github.com/cpuguy83/go.md2man/v2)) = 2.0.2
|
||||
Provides: bundled(golang(github.com/cpuguy83/go.md2man/v2)) = 2.0.6
|
||||
Provides: bundled(golang(github.com/creack/pty)) = 1.1.20
|
||||
Provides: bundled(golang(github.com/derekparker/trie)) = 0.0.0.20230829180723.39f4de51ef7d
|
||||
Provides: bundled(golang(github.com/go.delve/liner)) = 1.2.3.0.20231231155935.4726ab1d7f62
|
||||
Provides: bundled(golang(github.com/google/go.dap)) = 0.11.0
|
||||
Provides: bundled(golang(github.com/google/go.dap)) = 0.12.0
|
||||
Provides: bundled(golang(github.com/hashicorp/golang.lru)) = 1.0.2
|
||||
Provides: bundled(golang(github.com/inconshreveable/mousetrap)) = 1.1.0
|
||||
Provides: bundled(golang(github.com/mattn/go.colorable)) = 0.1.13
|
||||
@ -51,22 +51,18 @@ Provides: bundled(golang(github.com/mattn/go.isatty)) = 0.0.20
|
||||
Provides: bundled(golang(github.com/mattn/go.runewidth)) = 0.0.13
|
||||
Provides: bundled(golang(github.com/rivo/uniseg)) = 0.2.0
|
||||
Provides: bundled(golang(github.com/russross/blackfriday/v2)) = 2.1.0
|
||||
Provides: bundled(golang(github.com/sirupsen/logrus)) = 1.9.3
|
||||
Provides: bundled(golang(github.com/spf13/cobra)) = 1.7.0
|
||||
Provides: bundled(golang(github.com/spf13/pflag)) = 1.0.5
|
||||
Provides: bundled(golang(github.com/stretchr/testify)) = 1.8.4
|
||||
Provides: bundled(golang(golang.org/x/arch)) = 0.6.0
|
||||
Provides: bundled(golang(github.com/spf13/cobra)) = 1.9.1
|
||||
Provides: bundled(golang(github.com/spf13/pflag)) = 1.0.6
|
||||
Provides: bundled(golang(golang.org/x/arch)) = 0.11.0
|
||||
Provides: bundled(golang(golang.org/x/exp)) = 0.0.0.20230224173230.c95f2b4c22f2
|
||||
Provides: bundled(golang(golang.org/x/mod)) = 0.14.0
|
||||
Provides: bundled(golang(golang.org/x/sys)) = 0.13.0
|
||||
Provides: bundled(golang(golang.org/x/mod)) = 0.20.0
|
||||
Provides: bundled(golang(golang.org/x/sync)) = 0.8.0
|
||||
Provides: bundled(golang(golang.org/x/sys)) = 0.26.0
|
||||
Provides: bundled(golang(golang.org/x/telemetry)) = 0.0.0.20241106142447.58a1122356f5
|
||||
Provides: bundled(golang(golang.org/x/tools)) = 0.14.0
|
||||
Provides: bundled(golang(gopkg.in/yaml.v2)) = 2.4.0
|
||||
Provides: bundled(golang(gopkg.in/yaml.v3)) = 3.0.1
|
||||
Provides: bundled(golang(go.starlark.net)) = 0.0.0.20231101134539.556fd59b42f6
|
||||
|
||||
Patch0001: 0001-Skipping-due-issues-with-the-go-version-in-Fedora.patch
|
||||
Patch0002: 0002-Skipping-due-issues-with-network-access.patch
|
||||
|
||||
%description
|
||||
%{common_description}
|
||||
|
||||
@ -75,7 +71,6 @@ echo "=== Start prep ==="
|
||||
%goprep -k
|
||||
# unpack vendored dependencies to GOPATH
|
||||
tar c -C vendor/ . | tar x -C %{gobuilddir}/src
|
||||
%autopatch -v -p1
|
||||
|
||||
%build
|
||||
%gobuild %{?exp} -o %{gobuilddir}/bin/dlv %{goipath}/cmd/dlv
|
||||
@ -99,7 +94,7 @@ cp -r pkg/proc/internal/ebpf $delvepath/pkg/proc/internal/
|
||||
|
||||
pushd $delvepath
|
||||
for d in $(go list %{?exp} ./... | grep -v cmd | grep -v scripts); do
|
||||
go test %{?exp} ${d}
|
||||
go test %{?exp} ${d} -skip TestGuessSubstitutePath
|
||||
done
|
||||
rm -rf $delvepath
|
||||
popd
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (delve-1.22.1.tar.gz) = 73b6e7f5c88ffe3c3197a33106c2d10349bb622f10ec54e3dd0b045ed5717a341d48c5415f6b56b3a927afa6d994ff30dced802f82ed14d149f202f46c7a6b44
|
||||
SHA512 (delve-1.24.1.tar.gz) = 7308339af2ef0da14b3d1860d99a602f6fdf3861afd12fd25930c2587bec3099905d3c74ae3d93a193d9aebc77bea4eb4fe3878e3a84c45616ea9926d6b6ba27
|
||||
|
Loading…
Reference in New Issue
Block a user