diff --git a/.cvsignore b/.cvsignore
index 53c6fae..7fa7530 100644
--- a/.cvsignore
+++ b/.cvsignore
@@ -1 +1 @@
-dejavu-sfd-2.6.tar.gz
+dejavu-sfd-20060608-938.tar.gz
diff --git a/dejavu-arabic-override.conf b/dejavu-arabic-override.conf
new file mode 100644
index 0000000..3a0950d
--- /dev/null
+++ b/dejavu-arabic-override.conf
@@ -0,0 +1,34 @@
+
+
+
+
+
+ ar
+ DejaVu Sans
+
+ KacstQura
+
+
+
+ ar
+ DejaVu Serif
+
+ KacstQura
+
+
+
+ ar
+ DejaVu Sans Mono
+
+ KacstQuraFixed
+
+
+
diff --git a/dejavu-fonts-register.xsl b/dejavu-fonts-register.xsl
index f7a11b5..e6ef492 100644
--- a/dejavu-fonts-register.xsl
+++ b/dejavu-fonts-register.xsl
@@ -46,50 +46,29 @@
-
+
DejaVu Serif
-
-
-
-
-
- DejaVu Serif
-
-
+
DejaVu Sans
-
-
-
-
-
- DejaVu Sans
-
-
+
DejaVu Sans Mono
-
-
-
-
-
- DejaVu Sans Mono
-
diff --git a/dejavu-fonts.spec b/dejavu-fonts.spec
index c797b04..b745a51 100644
--- a/dejavu-fonts.spec
+++ b/dejavu-fonts.spec
@@ -1,7 +1,8 @@
%define archivename dejavu-sfd
# This macro has the same value as %{version}, except when testing pre-release snapshots
-%define archiveversion 2.6
+%define archiveversion 20060608-938
%define fontdir %{_datadir}/fonts/%{name}
+%define fontconfdir %{_sysconfdir}/fonts
%define xsldir %{_datadir}/xml/%{name}
# Let the perl Maintainer worry about Unicode.org data files (updates, licensing)
@@ -9,14 +10,16 @@
%define UnicodeData %(eval "$(%{__perl} -V:privlibexp)"; echo $privlibexp)/unicore/UnicodeData.txt
Name: dejavu-fonts
-Version: 2.6.0
-Release: 1%{?dist}
+Version: 2.7.0
+Release: 0.3%{?dist}
Summary: DejaVu fonts
Group: User Interface/X
License: Redistributable, with restrictions
URL: http://dejavu.sf.net/
Source: http://prdownloads.sourceforge.net/dejavu/%{archivename}-%{archiveversion}.tar.gz
Source1: dejavu-fonts-register.xsl
+Source2: dejavu-persian-override.conf
+Source3: dejavu-arabic-override.conf
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: fontforge
# The CPAN sources do not declare perl(Font::TTF)
@@ -31,7 +34,9 @@ Conflicts: fontconfig < 2.3.93
The DejaVu fonts are a font family based on the Bitstream Vera Fonts release
1.10. Its purpose is to provide a wider range of characters (see Current status
page for more information) while maintaining the original look and feel through
-the process of collaborative develop
+the process of collaborative develop.
+
+This package includes the typefaces the DejaVu project considers mature.
%package experimental
@@ -52,11 +57,35 @@ Group: User Interface/X
Summary: Files needed to register DejaVu fonts in fontconfig aliases
Requires: %{name} = %{version}-%{release}
# Needed for fontconfig alias registration
-Requires: %{_bindir}/xsltproc, /bin/mktemp, %{_sysconfdir}/fonts/fonts.conf
+Requires: %{_bindir}/xsltproc, /bin/mktemp, %{fontconfdir}/fonts.conf
%description fontconfig
+
This package will add DejaVu fonts to fontconfig aliases and keep them there.
+It will make DejaVu fonts the first choice if they're not already listed in
+the aliases, and keep their current rank otherwise.
+
+
+%package block
+Group: User Interface/X
+Summary: Files needed to block DejaVu use with some scripts
+Requires: %{fontconfdir}/conf.d
+
+
+%description block
+The DejaVu fonts are a font family based on the Bitstream Vera Fonts release
+1.10. While their glyph coverage and quality is improving every release, they
+may not yet be suitable for intensive use for some scripts.
+
+This package will force substitution of DejaVu by other fonts when rendering
+one of these scripts. If you need to install it, you probably have
+some enhancement suggestions to make at
+https://bugs.freedesktop.org/enter_bug.cgi?product=DejaVu or
+dejavu-fonts at lists.sourceforge.net
+
+Requests for enhancements or fixes of the blocking code should go to
+https://bugzilla.redhat.com/bugzilla/enter_bug.cgi?product=Fedora%20Extras
%prep
@@ -91,7 +120,11 @@ install -m 0644 generated/*.ttf %{buildroot}%{fontdir}
#xsl
install -d -m 755 %{buildroot}%{xsldir}
-install -p -m 644 %{SOURCE1} %{buildroot}%{xsldir}/register-%{name}.xsl
+install -p -m 644 %{SOURCE1} %{buildroot}%{xsldir}/
+
+# Fontconfig overrides for some scripts
+install -d -m 0755 %{buildroot}%{fontconfdir}/conf.d
+install -m 0644 %{SOURCE2} %{SOURCE3} %{buildroot}%{fontconfdir}/conf.d
%clean
@@ -125,15 +158,15 @@ if [ "$1" = "0" ]; then
fi
fi
+### Triggers yes I know I'm mad
-# UGLY but safe and I hope won't be necessary soonish
-%triggerin fontconfig -- fontconfig, %{_sysconfdir}/fonts/fonts.conf
-
-if [ -x %{_sysconfdir}/fonts/fonts.conf ] ; then
+# I hope this won't be necessary by FC6T1 time
+%triggerin fontconfig -- fontconfig, %{fontconfdir}/fonts.conf
+if [ -w %{fontconfdir}/fonts.conf ] ; then
TMPFILE=$(/bin/mktemp -q /tmp/fonts.conf.XXXXXX) && \
%{_bindir}/xsltproc --novalid --output $TMPFILE \
- %{xsldir}/register-%{name}.xsl %{_sysconfdir}/fonts/fonts.conf && \
- /bin/cat $TMPFILE > %{_sysconfdir}/fonts/fonts.conf && /bin/rm $TMPFILE
+ %{xsldir}/%{name}-register.xsl %{fontconfdir}/fonts.conf && \
+ /bin/cat $TMPFILE > %{fontconfdir}/fonts.conf && /bin/rm $TMPFILE
fi
@@ -157,10 +190,21 @@ fi
%files fontconfig
%defattr(0644,root,root,0755)
%dir %{xsldir}
-%{xsldir}/register-%{name}.xsl
+%{xsldir}/%{name}-register.xsl
+
+
+%files block
+%defattr(0644,root,root,0755)
+%{fontconfdir}/conf.d/*.conf
%changelog
+* Thu Jun 09 2006 Nicolas Mailhot - 2.7.0-0.1
+- preparation to 2.7.0 based on the current dejavu snapshot
+- addition of fontconfig blocking for Arabic and Persian
+- tweak of the fontconfig aliasing to make DejaVu fonts the highest prio
+ instead of following Vera ranking
+
* Mon May 15 2006 Nicolas Mailhot - 2.6.0-1
- 2.6.0
diff --git a/dejavu-persian-override.conf b/dejavu-persian-override.conf
new file mode 100644
index 0000000..e52331a
--- /dev/null
+++ b/dejavu-persian-override.conf
@@ -0,0 +1,34 @@
+
+
+
+
+
+ ar
+ DejaVu Sans
+
+ Roya
+
+
+
+ ar
+ DejaVu Serif
+
+ Nazli
+
+
+
+ ar
+ DejaVu Sans Mono
+
+ Terafik
+
+
+
diff --git a/sources b/sources
index 794f6c4..62f02a8 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-aae0e562be59e57e791cd1a7273bfb8c dejavu-sfd-2.6.tar.gz
+1c83f56c9905d6e85de85dda14196413 dejavu-sfd-20060608-938.tar.gz