lots and lots of experimental changes (Makefile, lgc generation, new fontforge...)

This commit is contained in:
nim 2007-10-21 20:55:29 +00:00
parent bf31eac531
commit 5c4fee64ea
5 changed files with 502 additions and 30 deletions

View File

@ -1 +1 @@
dejavu-sfd-2.20.tar.bz2 dejavu-sfd-20071014-2016.tar.bz2

View File

@ -0,0 +1,180 @@
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/conf.d/25-dejavu-lgc-fonts.conf -->
<fontconfig>
<!-- Alias Bitstream Vera -->
<match>
<test name="family">
<string>Bitstream Vera Sans</string>
</test>
<edit name="family" mode="append" binding="same">
<string>DejaVu LGC Sans</string>
</edit>
</match>
<match>
<test name="family">
<string>Bitstream Vera Serif</string>
</test>
<edit name="family" mode="append" binding="same">
<string>DejaVu LGC Serif</string>
</edit>
</match>
<match>
<test name="family">
<string>Bitstream Vera Sans Mono</string>
</test>
<edit name="family" mode="append" binding="same">
<string>DejaVu LGC Sans Mono</string>
</edit>
</match>
<!-- Alias DejaVu -->
<match>
<test name="family">
<string>DejaVu Sans</string>
</test>
<edit name="family" mode="append" binding="same">
<string>DejaVu LGC Sans</string>
</edit>
</match>
<match>
<test name="family">
<string>DejaVu Serif</string>
</test>
<edit name="family" mode="append" binding="same">
<string>DejaVu LGC Serif</string>
</edit>
</match>
<match>
<test name="family">
<string>DejaVu Sans Mono</string>
</test>
<edit name="family" mode="append" binding="same">
<string>DejaVu LGC Sans Mono</string>
</edit>
</match>
<match>
<test name="family">
<string>DejaVu Sans Light</string>
</test>
<edit name="family" mode="append" binding="same">
<string>DejaVu LGC Sans Light</string>
</edit>
</match>
<match>
<test name="family">
<string>DejaVu Sans Condensed</string>
</test>
<edit name="family" mode="append" binding="same">
<string>DejaVu LGC Sans Condensed</string>
</edit>
</match>
<match>
<test name="family">
<string>DejaVu Serif Condensed</string>
</test>
<edit name="family" mode="append" binding="same">
<string>DejaVu LGC Serif Condensed</string>
</edit>
</match>
<!-- Assign generic name -->
<alias>
<family>DejaVu LGC Sans</family>
<family>DejaVu LGC Sans Condensed</family>
<default>
<family>sans-serif</family>
</default>
</alias>
<alias>
<family>DejaVu LGC Serif</family>
<family>DejaVu LGC Serif Condensed</family>
<default>
<family>serif</family>
</default>
</alias>
<alias>
<family>DejaVu LGC Sans Mono</family>
<default>
<family>monospace</family>
</default>
</alias>
<!-- Alias generic names -->
<alias>
<family>sans-serif</family>
<prefer>
<family>DejaVu LGC Sans</family>
</prefer>
</alias>
<alias>
<family>serif</family>
<prefer>
<family>DejaVu LGC Serif</family>
</prefer>
</alias>
<alias>
<family>monospace</family>
<prefer>
<family>DejaVu LGC Sans Mono</family>
</prefer>
</alias>
<!-- Turn off hinting at small sizes -->
<match target="font">
<test name="family">
<string>DejaVu LGC Sans</string>
</test>
<test name="pixelsize" compare="less">
<double>7.5</double>
</test>
<edit name="hinting">
<bool>false</bool>
</edit>
</match>
<match target="font">
<test name="family">
<string>DejaVu LGC Serif</string>
</test>
<test name="pixelsize" compare="less">
<double>7.5</double>
</test>
<edit name="hinting">
<bool>false</bool>
</edit>
</match>
<match target="font">
<test name="family">
<string>DejaVu LGC Sans Mono</string>
</test>
<test name="pixelsize" compare="less">
<double>7.5</double>
</test>
<edit name="hinting">
<bool>false</bool>
</edit>
</match>
<match target="font">
<test name="family">
<string>DejaVu LGC Sans Condensed</string>
</test>
<test name="pixelsize" compare="less">
<double>7.5</double>
</test>
<edit name="hinting">
<bool>false</bool>
</edit>
</match>
<match target="font">
<test name="family">
<string>DejaVu LGC Serif Condensed</string>
</test>
<test name="pixelsize" compare="less">
<double>7.5</double>
</test>
<edit name="hinting">
<bool>false</bool>
</edit>
</match>
</fontconfig>

246
dejavu-fonts-makefile.patch Normal file
View File

@ -0,0 +1,246 @@
diff -uNr dejavu-sfd-20071014-2016.orig/generate.pe dejavu-sfd-20071014-2016/generate.pe
--- dejavu-sfd-20071014-2016.orig/generate.pe 2007-10-14 05:57:03.000000000 +0200
+++ dejavu-sfd-20071014-2016/generate.pe 2007-10-21 22:36:13.000000000 +0200
@@ -37,7 +37,7 @@
if (Strcasestr ($fontname, "ExtraLight") > -1)
gen_flags = exp_gen_flags
endif
- Generate("generated/" + $fontname + ".ttf", "", gen_flags)
+ Generate( $curfont + ".ttf", "", gen_flags)
Close()
i++
endloop
diff -uNr dejavu-sfd-20071014-2016.orig/Makefile dejavu-sfd-20071014-2016/Makefile
--- dejavu-sfd-20071014-2016.orig/Makefile 1970-01-01 01:00:00.000000000 +0100
+++ dejavu-sfd-20071014-2016/Makefile 2007-10-21 22:35:52.000000000 +0200
@@ -0,0 +1,230 @@
+.PHONY: all full sans lgc ttf full-ttf sans-ttf lgc-ttf dist src-dist full-dist sans-dist lgc-dist check full-check sans-check lgc-check clean
+
+# Release version
+VERSION = 2.21
+# Initial source directory, assumed read-only
+SRCDIR = ./
+# Directory where temporary files live
+TMPDIR = tmp/
+# Directory where final files are created
+BUILDDIR = build/
+# Directory where final archives are created
+DISTDIR = dist/
+
+OLDSTATUS = ./status.txt
+BLOCKS = ./Blocks.txt
+UNICODEDATA = ./UnicodeData.txt
+FC-LANG = ./fc-lang
+
+GENERATE = ./generate.pe
+TTPOSTPROC = ./ttpostproc.pl
+LGC = ./lgc.pe
+UNICOVER = ./unicover.pl
+LANGCOVER = ./langcover.pl
+STATUS = ./status.pl
+PROBLEMS = ./problems.pl
+
+SRC := $(wildcard $(SRCDIR)*.sfd)
+FULLSFD := $(patsubst $(SRCDIR)%.sfd, $(TMPDIR)%.sfd, $(SRC))
+LGCSFD := $(patsubst $(SRCDIR)DejaVu%.sfd, $(TMPDIR)DejaVuLGC%.sfd, $(SRC))
+FULLTTF := $(patsubst $(TMPDIR)%.sfd, $(BUILDDIR)%.ttf, $(FULLSFD))
+LGCTTF := $(patsubst $(TMPDIR)%.sfd, $(BUILDDIR)%.ttf, $(LGCSFD))
+
+all : full sans lgc
+
+$(TMPDIR)%.sfd: $(SRCDIR)%.sfd
+ @echo "➊ $< ❱❱❱ $@"
+ install -d $(dir $@)
+ sed "s@\(Version:\? \)\(0\.[0-9]\+\.[0-9]\+\|[1-9][0-9]*\.[0-9]\+\)@\1$(VERSION)@" $< > $@
+
+$(TMPDIR)DejaVuLGC%.sfd: $(TMPDIR)DejaVu%.sfd
+ @echo "➋ $< ❱❱❱ $@"
+ sed -e 's,FontName: DejaVu,FontName: DejaVuLGC,'\
+ -e 's,FullName: DejaVu,FullName: DejaVu LGC,'\
+ -e 's,FamilyName: DejaVu,FamilyName: DejaVu LGC,'\
+ -e 's,"DejaVu \(\(Sans\|Serif\)*\( Condensed\| Mono\)*\( Bold\)*\( Oblique\|Italic\)*\)","DejaVu LGC \1",g' < $< > $@
+ @echo "Stripping unwanted glyphs from $@"
+ $(LGC) $@
+
+$(BUILDDIR)%.ttf: $(TMPDIR)%.sfd
+ @echo "➌ $< ❱❱❱ $@"
+ install -d $(dir $@)
+ $(GENERATE) $<
+ mv $<.ttf $@
+ $(TTPOSTPROC) $@
+ $(RM) $@~
+
+$(BUILDDIR)status.txt: $(FULLSFD)
+ @echo "➍ ❱❱❱ $@"
+ install -d $(dir $@)
+ $(STATUS) $(VERSION) $(OLDSTATUS) $(FULLSFD) > $@
+
+$(BUILDDIR)unicover.txt: $(TMPDIR)DejaVuSans.sfd $(TMPDIR)DejaVuSerif.sfd $(TMPDIR)DejaVuMonoSans.sfd
+ @echo "➎ ❱❱❱ $@"
+ install -d $(dir $@)
+ $(UNICOVER) $(UNICODEDATA) $(BLOCKS) \
+ $(TMPDIR)DejaVuSans.sfd "Sans" \
+ $(TMPDIR)DejaVuSerif.sfd "Serif" \
+ $(TMPDIR)DejaVuMonoSans.sfd "Sans Mono" > $@
+
+$(BUILDDIR)unicover-sans.txt: $(TMPDIR)DejaVuSans.sfd
+ @echo "➎ ❱❱❱ $@"
+ install -d $(dir $@)
+ $(UNICOVER) $(UNICODEDATA) $(BLOCKS) \
+ $(TMPDIR)DejaVuSans.sfd "Sans" > $@
+
+$(BUILDDIR)unicover-lgc.txt: $(TMPDIR)DejaVuLGCSans.sfd $(TMPDIR)DejaVuLGCSerif.sfd $(TMPDIR)DejaVuLGCMonoSans.sfd
+ @echo "➎ ❱❱❱ $@"
+ install -d $(dir $@)
+ $(UNICOVER) $(UNICODEDATA) $(BLOCKS) \
+ $(TMPDIR)DejaVuLGCSans.sfd "Sans" \
+ $(TMPDIR)DejaVuLGCSerif.sfd "Serif" \
+ $(TMPDIR)DejaVuLGCMonoSans.sfd "Sans Mono" > $@
+
+$(BUILDDIR)langcover.txt: $(TMPDIR)DejaVuSans.sfd $(TMPDIR)DejaVuSerif.sfd $(TMPDIR)DejaVuMonoSans.sfd
+ @echo "➏ ❱❱❱ $@"
+ install -d $(dir $@)
+ifeq "$(FC-LANG)" ""
+ touch $@
+else
+ $(LANGCOVER) $(FC-LANG) \
+ $(TMPDIR)DejaVuSans.sfd "Sans" \
+ $(TMPDIR)DejaVuSerif.sfd "Serif" \
+ $(TMPDIR)DejaVuMonoSans.sfd "Sans Mono" > $@
+endif
+
+$(BUILDDIR)langcover-sans.txt: $(TMPDIR)DejaVuSans.sfd
+ @echo "➏ ❱❱❱ $@"
+ install -d $(dir $@)
+ifeq "$(FC-LANG)" ""
+ touch $@
+else
+ $(LANGCOVER) $(FC-LANG) \
+ $(TMPDIR)DejaVuSans.sfd "Sans" > $@
+endif
+
+$(BUILDDIR)langcover-lgc.txt: $(TMPDIR)DejaVuLGCSans.sfd $(TMPDIR)DejaVuLGCSerif.sfd $(TMPDIR)DejaVuLGCMonoSans.sfd
+ @echo "➏ ❱❱❱ $@"
+ install -d $(dir $@)
+ifeq "$(FC-LANG)" ""
+ touch $@
+else
+ $(LANGCOVER) $(FC-LANG) \
+ $(TMPDIR)DejaVuLGCSans.sfd "Sans" \
+ $(TMPDIR)DejaVuLGCSerif.sfd "Serif" \
+ $(TMPDIR)DejaVuLGCMonoSans.sfd "Sans Mono" > $@
+endif
+
+$(TMPDIR)dejavu-fonts-$(VERSION)/: $(BUILDDIR)unicover.txt $(BUILDDIR)langcover.txt
+ @echo "➐ ❱❱❱ $@"
+ install -d -m 0755 $@
+ install -p -m 0755 $(GENERATE) $(TTPOSTPROC) $(LGC) \
+ $(UNICOVER) $(LANGCOVER) $(STATUS) $(PROBLEMS) \
+ $@
+ install -p -m 0644 Makefile $(FULLSFD) \
+ $(BUILDDIR)unicover.txt \
+ $(BUILDDIR)langcover.txt \
+ $(BUILDDIR)status.txt \
+ AUTHORS BUGS LICENSE NEWS README \
+ $@
+
+$(TMPDIR)dejavu-fonts-ttf-$(VERSION)/: full
+ @echo "➐ ❱❱❱ $@"
+ install -d -m 0755 $@/{doc,ttf}
+ install -p -m 0644 $(FULLTTF) $@/ttf
+ install -p -m 0644 $(BUILDDIR)unicover.txt \
+ $(BUILDDIR)langcover.txt \
+ $(BUILDDIR)status.txt \
+ AUTHORS BUGS LICENSE NEWS README \
+ $@/doc
+
+$(TMPDIR)dejavu-sans-ttf-$(VERSION)/: sans
+ @echo "➐ ❱❱❱ $@"
+ install -d -m 0755 $@/{doc,ttf}
+ install -p -m 0644 $(BUILDDIR)DejaVuSans.ttf $@/ttf
+ install -p -m 0644 $(BUILDDIR)unicover-sans.txt \
+ $(BUILDDIR)langcover-sans.txt \
+ AUTHORS BUGS LICENSE NEWS README \
+ $@/doc
+
+$(TMPDIR)dejavu-lgc-fonts-ttf-$(VERSION)/: lgc
+ @echo "➐ ❱❱❱ $@"
+ install -d -m 0755 $@/{doc,ttf}
+ install -p -m 0644 $(LGCTTF) $@/ttf
+ install -p -m 0644 $(BUILDDIR)unicover-lgc.txt \
+ $(BUILDDIR)langcover-lgc.txt \
+ AUTHORS BUGS LICENSE NEWS README \
+ $@/doc
+
+$(DISTDIR)%.zip: $(TMPDIR)%
+ @echo "➑ ❱❱❱ $@"
+ install -d $(dir $@)
+ (cd $(TMPDIR); zip -rv $(abspath $@) $(notdir $<))
+
+$(DISTDIR)%.tar.bz2: $(TMPDIR)%
+ @echo "➑ ❱❱❱ $@"
+ install -d $(dir $@)
+ (cd $(TMPDIR); tar cjvf $(abspath $@) $(notdir $<))
+
+%.md5: %
+ @echo "➒ ❱❱❱ $@"
+ (cd $(dir $<); md5sum -b $(notdir $<) > $(abspath $@))
+
+%.sha512: %
+ @echo "➒ ❱❱❱ $@"
+ (cd $(dir $<); sha512sum -b $(notdir $<) > $(abspath $@))
+
+full : $(FULLTTF) $(BUILDDIR)unicover.txt $(BUILDDIR)langcover.txt $(BUILDDIR)status.txt
+
+sans : $(BUILDDIR)DejaVuSans.ttf $(BUILDDIR)unicover-sans.txt $(BUILDDIR)langcover-sans.txt
+
+lgc : $(LGCTTF) $(BUILDDIR)unicover-lgc.txt $(BUILDDIR)langcover-lgc.txt
+
+ttf : full-ttf sans-ttf lgc-ttf
+
+full-ttf : $(FULLTTF)
+
+sans-ttf: $(BUILDDIR)DejaVuSans.ttf
+
+lgc-ttf : $(LGCTTF)
+
+dist : src-dist full-dist sans-dist lgc-dist
+
+src-dist : $(DISTDIR)dejavu-fonts-$(VERSION).zip \
+ $(DISTDIR)dejavu-fonts-$(VERSION).zip.md5 \
+ $(DISTDIR)dejavu-fonts-$(VERSION).zip.sha512 \
+ $(DISTDIR)dejavu-fonts-$(VERSION).tar.bz2 \
+ $(DISTDIR)dejavu-fonts-$(VERSION).tar.bz2.md5 \
+ $(DISTDIR)dejavu-fonts-$(VERSION).tar.bz2.sha512
+
+full-dist : $(DISTDIR)dejavu-fonts-ttf-$(VERSION).zip \
+ $(DISTDIR)dejavu-fonts-ttf-$(VERSION).zip.md5 \
+ $(DISTDIR)dejavu-fonts-ttf-$(VERSION).zip.sha512 \
+ $(DISTDIR)dejavu-fonts-ttf-$(VERSION).tar.bz2 \
+ $(DISTDIR)dejavu-fonts-ttf-$(VERSION).tar.bz2.md5 \
+ $(DISTDIR)dejavu-fonts-ttf-$(VERSION).tar.bz2.sha512
+
+sans-dist: $(DISTDIR)dejavu-sans-ttf-$(VERSION).zip \
+ $(DISTDIR)dejavu-sans-ttf-$(VERSION).zip.md5 \
+ $(DISTDIR)dejavu-sans-ttf-$(VERSION).zip.sha512
+
+lgc-dist : $(DISTDIR)dejavu-lgc-fonts-ttf-$(VERSION).zip \
+ $(DISTDIR)dejavu-lgc-fonts-ttf-$(VERSION).zip.md5 \
+ $(DISTDIR)dejavu-lgc-fonts-ttf-$(VERSION).zip.sha512 \
+ $(DISTDIR)dejavu-lgc-fonts-ttf-$(VERSION).tar.bz2 \
+ $(DISTDIR)dejavu-lgc-fonts-ttf-$(VERSION).tar.bz2.md5 \
+ $(DISTDIR)dejavu-lgc-fonts-ttf-$(VERSION).tar.bz2.sha512
+
+check : full-check
+
+full-check : $(FULLSFD)
+ $(PROBLEMS) $<
+
+sans-check : $(TMPDIR)DejaVuSans.sfd
+ $(PROBLEMS) $<
+
+lgc-check : $(LGCSFD)
+ $(PROBLEMS) $<
+
+clean :
+ $(RM) -r $(TMPDIR) $(BUILDDIR) $(DISTDIR)

View File

@ -4,11 +4,11 @@
%define archivename %{fontname}-sfd-%{archiveversion} %define archivename %{fontname}-sfd-%{archiveversion}
#define alphatag .20070616svn1889 %define alphatag .20071014svn2016
#define alphatag .rc1 #define alphatag .rc1
#define archiveversion 20070627-1922 %define archiveversion 20071014-2016
%define archiveversion %{version} #define archiveversion %{version}
# Let the perl maintainer worry about Unicode.org data files # Let the perl maintainer worry about Unicode.org data files
@ -16,9 +16,9 @@
%define UnicodeData %(eval "$(%{__perl} -V:privlibexp)"; echo $privlibexp)/unicore/UnicodeData.txt %define UnicodeData %(eval "$(%{__perl} -V:privlibexp)"; echo $privlibexp)/unicore/UnicodeData.txt
Name: %{fontname}-fonts Name: %{fontname}-fonts
Version: 2.20 Version: 2.21
Release: 1%{?alphatag}%{?dist} Release: 0.1%{?alphatag}%{?dist}
Summary: DejaVu fonts Summary: DejaVu fonts, mature typefaces
Group: User Interface/X Group: User Interface/X
License: Modifiable & redistributable, with naming restrictions License: Modifiable & redistributable, with naming restrictions
@ -31,6 +31,10 @@ Source2: %{name}-fontconfig-unhint-small.conf
# DejaVu fontconfig setup (experimental families) # DejaVu fontconfig setup (experimental families)
Source3: %{name}-experimental-fontconfig.conf Source3: %{name}-experimental-fontconfig.conf
Source4: %{name}-experimental-fontconfig-unhint-small.conf Source4: %{name}-experimental-fontconfig-unhint-small.conf
# DejaVu LGC setup
Source5: %{name}-lgc-fontconfig.conf
Patch0: %{name}-makefile.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
# Older fontforge versions will not work due to sfd format changes # Older fontforge versions will not work due to sfd format changes
@ -50,41 +54,47 @@ This package includes the typefaces the DejaVu project considers mature.
%package experimental %package experimental
Group: User Interface/X Group: User Interface/X
Summary: Experimental DejaVu typefaces Summary: DejaVu fonts, experimental typefaces
# Does not really make sense without the core typefaces # Does not really make sense without the core typefaces
Requires: %{name} = %{version}-%{release} Requires: %{name} = %{version}-%{release}
%description experimental %description experimental
The DejaVu fonts are a font family based on the "Bitstream Vera" fonts release The DejaVu fonts are a font family based on the "Bitstream Vera" fonts release
1.10. 1.10. Its purpose is to provide a wider range of characters while maintaining
the original look and feel through the process of collaborative development.
This package includes the typefaces the DejaVu project considers experimental. This package includes the typefaces the DejaVu project considers experimental.
%package -n %{fontname}-lgc-fonts
Group: User Interface/X
Summary: DejaVu fonts, Latin Greek Cyrillic subset
# Could possibly conflict with the main package, as there's really no sense to
# install both
#Conflicts: %{name} <= %{version}-%{release}
%description -n %{fontname}-lgc-fonts
The DejaVu fonts are a font family based on the "Bitstream Vera" fonts release
1.10. Its purpose is to provide a wider range of characters while maintaining
the original look and feel through the process of collaborative development.
This package includes a subset of DejaVu typefaces limited to Latin, Greek and
Cyrillic glyphs.
%prep %prep
%setup -q -n %{archivename} %setup -q -n %{archivename}
%patch0 -p1 -b .make
%build %build
./generate.sh make %{?_smp_mflags} VERSION=%{version} FC-LANG="" \
./status.pl %{version} status.txt *.sfd > status.txt.new BLOCKS=%{Blocks} UNICODEDATA=%{UnicodeData}
mv status.txt.new status.txt
./unicover.pl %{UnicodeData} %{Blocks} \
DejaVuSans.sfd Sans \
DejaVuSerif.sfd Serif \
DejaVuMonoSans.sfd "Sans Mono" > unicover.txt
# We should probably also regenerate langcover.txt
# but it requires resolution of
# https://bugs.freedesktop.org/show_bug.cgi?id=6316
# Remove mes files or they end in %doc
rm mes*.txt
%check %check
# Current upstream files are full of "problems" make check
# Do not panic if the output is long
./problems.pl *.sfd
%install %install
@ -92,7 +102,7 @@ rm -fr %{buildroot}
# Fonts # Fonts
install -m 0755 -d %{buildroot}%{fontdir} install -m 0755 -d %{buildroot}%{fontdir}
install -m 0644 -p generated/*.ttf %{buildroot}%{fontdir} install -m 0644 -p build/*.ttf %{buildroot}%{fontdir}
# Fontconfig tweaks # Fontconfig tweaks
install -m 0755 -d %{buildroot}%{fontconfdir} install -m 0755 -d %{buildroot}%{fontconfdir}
@ -100,6 +110,7 @@ install -m 0644 -p %{SOURCE1} %{buildroot}%{fontconfdir}57-%{fontname}.conf
install -m 0644 -p %{SOURCE2} %{buildroot}%{fontconfdir}20-unhint-small-%{fontname}.conf install -m 0644 -p %{SOURCE2} %{buildroot}%{fontconfdir}20-unhint-small-%{fontname}.conf
install -m 0644 -p %{SOURCE3} %{buildroot}%{fontconfdir}61-%{fontname}-experimental.conf install -m 0644 -p %{SOURCE3} %{buildroot}%{fontconfdir}61-%{fontname}-experimental.conf
install -m 0644 -p %{SOURCE4} %{buildroot}%{fontconfdir}20-unhint-small-%{fontname}-experimental.conf install -m 0644 -p %{SOURCE4} %{buildroot}%{fontconfdir}20-unhint-small-%{fontname}-experimental.conf
install -m 0644 -p %{SOURCE5} %{buildroot}%{fontconfdir}59-%{fontname}-lgc.conf
%clean %clean
@ -134,9 +145,25 @@ if [ "$1" = "0" ]; then
fi fi
%post -n %{fontname}-lgc-fonts
if [ -x %{_bindir}/fc-cache ]; then
%{_bindir}/fc-cache %{fontdir}
fi
%postun -n %{fontname}-lgc-fonts
if [ "$1" = "0" ]; then
if [ -x %{_bindir}/fc-cache ]; then
%{_bindir}/fc-cache %{fontdir}
fi
fi
%files %files
%defattr(0644,root,root,0755) %defattr(0644,root,root,0755)
%doc *.txt AUTHORS BUGS LICENSE NEWS README %doc AUTHORS BUGS LICENSE NEWS README
%doc build/unicover.txt build/langcover.txt build/status.txt
%config(noreplace) %{fontconfdir}20-unhint-small-%{fontname}.conf %config(noreplace) %{fontconfdir}20-unhint-small-%{fontname}.conf
%config(noreplace) %{fontconfdir}57-%{fontname}.conf %config(noreplace) %{fontconfdir}57-%{fontname}.conf
@ -145,7 +172,8 @@ fi
%{fontdir}/*.ttf %{fontdir}/*.ttf
%exclude %{fontdir}/DejaVu*Condensed*.ttf %exclude %{fontdir}/DejaVu*Condensed*.ttf
%exclude %{fontdir}/DejaVu*ExtraLight*.ttf %exclude %{fontdir}/DejaVu*ExtraLight*.ttf
%exclude %{fontdir}/DejaVuSerif-*Italic.ttf %exclude %{fontdir}/DejaVuSerif*Italic.ttf
%exclude %{fontdir}/DejaVuLGC*.ttf
%files experimental %files experimental
@ -156,10 +184,28 @@ fi
%{fontdir}/DejaVu*Condensed*.ttf %{fontdir}/DejaVu*Condensed*.ttf
%{fontdir}/DejaVu*ExtraLight*.ttf %{fontdir}/DejaVu*ExtraLight*.ttf
%{fontdir}/DejaVuSerif-*Italic.ttf %{fontdir}/DejaVuSerif*Italic.ttf
%files -n %{fontname}-lgc-fonts
%defattr(0644,root,root,0755)
%doc AUTHORS BUGS LICENSE NEWS README
%doc build/unicover-lgc.txt build/langcover-lgc.txt
%config(noreplace) %{fontconfdir}59-%{fontname}-lgc.conf
%dir %{fontdir}
%{fontdir}/DejaVuLGC*.ttf
%changelog %changelog
* Sun Oct 21 2007 <nicolas.mailhot at laposte.net>
2.21-0.1.20071014svn2016
Very experimental version to test major changes:
new fontforge version
use of a real makefile at last
replacing standalone lgc package with subpackage generated with the rest
* Tue Sep 18 2007 Nicolas Mailhot <nicolas.mailhot at laposte.net> * Tue Sep 18 2007 Nicolas Mailhot <nicolas.mailhot at laposte.net>
2.20-1 2.20-1
2.20 final 2.20 final

View File

@ -1 +1 @@
9633569289671481b328becd09f0e72b dejavu-sfd-2.20.tar.bz2 c4c2b5a8f61af0ac9385575226aa40c1 dejavu-sfd-20071014-2016.tar.bz2