patch fixed to be apply-able

This commit is contained in:
Honza Horák 2012-05-14 18:41:04 +02:00
parent a30074db5a
commit c425c83021

View File

@ -1,8 +1,7 @@
diff --git a/ChangeLog b/ChangeLog diff -U0 dejagnu-1.5/ChangeLog.gfortran dejagnu-1.5/ChangeLog
index 2b5d566..3866395 100644 --- dejagnu-1.5/ChangeLog.gfortran 2011-03-09 05:29:16.000000000 +0100
--- a/ChangeLog +++ dejagnu-1.5/ChangeLog 2012-05-14 18:38:36.316469119 +0200
+++ b/ChangeLog @@ -0,0 +1,8 @@
@@ -1,3 +1,11 @@
+2011-06-30 Tom Tromey <tromey@redhat.com> +2011-06-30 Tom Tromey <tromey@redhat.com>
+ +
+ * doc/ref.xml: Document find_gfortran. + * doc/ref.xml: Document find_gfortran.
@ -11,14 +10,10 @@ index 2b5d566..3866395 100644
+ (default_target_compile): Likewise. + (default_target_compile): Likewise.
+ * lib/libgloss.exp (find_gfortran): New proc. + * lib/libgloss.exp (find_gfortran): New proc.
+ +
2011-06-30 Ben Elliston <bje@gnu.org> diff -up dejagnu-1.5/doc/dejagnu.texi.gfortran dejagnu-1.5/doc/dejagnu.texi
--- dejagnu-1.5/doc/dejagnu.texi.gfortran 2011-03-08 01:26:30.000000000 +0100
* Makefile.am (all-local): New rule. +++ dejagnu-1.5/doc/dejagnu.texi 2012-05-14 18:38:36.317469122 +0200
diff --git a/doc/dejagnu.texi b/doc/dejagnu.texi @@ -6548,6 +6548,7 @@ executable image for an embedded systems
index 904cb99..3d616c5 100644
--- a/doc/dejagnu.texi
+++ b/doc/dejagnu.texi
@@ -6548,6 +6548,7 @@ executable image for an embedded systems.
* Find_gcj Procedure: find_gcj procedure. * Find_gcj Procedure: find_gcj procedure.
* Find_g++ Procedure: find_g++ procedure. * Find_g++ Procedure: find_g++ procedure.
* Find_g77 Procedure: find_g77 procedure. * Find_g77 Procedure: find_g77 procedure.
@ -26,7 +21,7 @@ index 904cb99..3d616c5 100644
* Process_multilib_options Procedure: process_multilib_options procedure. * Process_multilib_options Procedure: process_multilib_options procedure.
* Add_multilib_option Procedure: add_multilib_option procedure. * Add_multilib_option Procedure: add_multilib_option procedure.
* Find_gas Procedure: find_gas procedure. * Find_gas Procedure: find_gas procedure.
@@ -6752,7 +6753,7 @@ executable image for an embedded systems. @@ -6752,7 +6753,7 @@ executable image for an embedded systems
@t{@b{find_g++}(@i{});} @t{@b{find_g++}(@i{});}
@end quotation @end quotation
@ -35,7 +30,7 @@ index 904cb99..3d616c5 100644
@subsubsection Find_g77 Procedure @subsubsection Find_g77 Procedure
@@ -6761,7 +6762,16 @@ executable image for an embedded systems. @@ -6761,7 +6762,16 @@ executable image for an embedded systems
@t{@b{find_g77}(@i{});} @t{@b{find_g77}(@i{});}
@end quotation @end quotation
@ -53,10 +48,9 @@ index 904cb99..3d616c5 100644
@subsubsection Process_multilib_options Procedure @subsubsection Process_multilib_options Procedure
diff --git a/doc/ref.xml b/doc/ref.xml diff -up dejagnu-1.5/doc/ref.xml.gfortran dejagnu-1.5/doc/ref.xml
index 570fbc0..b54d2ff 100644 --- dejagnu-1.5/doc/ref.xml.gfortran 2011-03-03 22:38:25.000000000 +0100
--- a/doc/ref.xml +++ dejagnu-1.5/doc/ref.xml 2012-05-14 18:38:36.333469167 +0200
+++ b/doc/ref.xml
@@ -4146,6 +4146,19 @@ @@ -4146,6 +4146,19 @@
</funcsynopsis> </funcsynopsis>
</sect4> </sect4>
@ -77,10 +71,9 @@ index 570fbc0..b54d2ff 100644
<sect4 id="processmultiliboptions" xreflabel="process_multilib_options <sect4 id="processmultiliboptions" xreflabel="process_multilib_options
procedure"> procedure">
<title>Process_multilib_options Procedure</title> <title>Process_multilib_options Procedure</title>
diff --git a/lib/libgloss.exp b/lib/libgloss.exp diff -up dejagnu-1.5/lib/libgloss.exp.gfortran dejagnu-1.5/lib/libgloss.exp
index e651eb6..77150cb 100644 --- dejagnu-1.5/lib/libgloss.exp.gfortran 2011-03-03 10:58:56.000000000 +0100
--- a/lib/libgloss.exp +++ dejagnu-1.5/lib/libgloss.exp 2012-05-14 18:38:36.364469259 +0200
+++ b/lib/libgloss.exp
@@ -1,5 +1,5 @@ @@ -1,5 +1,5 @@
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001 # Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001
-# 2002, 2003, 2005, 2006, 2007, 2008, 2009, 2010 Free Software Foundation, Inc. -# 2002, 2003, 2005, 2006, 2007, 2008, 2009, 2010 Free Software Foundation, Inc.
@ -88,10 +81,11 @@ index e651eb6..77150cb 100644
# #
# This file is part of DejaGnu. # This file is part of DejaGnu.
# #
@@ -702,6 +702,25 @@ proc find_g77 {} { @@ -701,6 +701,25 @@ proc find_g77 {} {
}
return $CC return $CC
} }
+
+proc find_gfortran {} { +proc find_gfortran {} {
+ global tool_root_dir + global tool_root_dir
+ +
@ -110,14 +104,12 @@ index e651eb6..77150cb 100644
+ } + }
+ return $CC + return $CC
+} +}
+
proc find_gnatmake {} { proc find_gnatmake {} {
global tool_root_dir global tool_root_dir
diff -up dejagnu-1.5/lib/target.exp.gfortran dejagnu-1.5/lib/target.exp
diff --git a/lib/target.exp b/lib/target.exp --- dejagnu-1.5/lib/target.exp.gfortran 2011-03-03 10:58:56.000000000 +0100
index c9fde2c..ec9fff2 100644 +++ dejagnu-1.5/lib/target.exp 2012-05-14 18:38:36.399469362 +0200
--- a/lib/target.exp
+++ b/lib/target.exp
@@ -1,5 +1,5 @@ @@ -1,5 +1,5 @@
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001 # Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001
-# 2002, 2003, 2005, 2006, 2007, 2008, 2009, 2010 Free Software Foundation, Inc. -# 2002, 2003, 2005, 2006, 2007, 2008, 2009, 2010 Free Software Foundation, Inc.
@ -125,7 +117,7 @@ index c9fde2c..ec9fff2 100644
# #
# This file is part of DejaGnu. # This file is part of DejaGnu.
# #
@@ -367,6 +367,18 @@ proc default_target_compile {source destfile type options} { @@ -367,6 +367,18 @@ proc default_target_compile {source dest
} }
} }
@ -144,7 +136,7 @@ index c9fde2c..ec9fff2 100644
if {[regexp "^dest=" $i]} { if {[regexp "^dest=" $i]} {
regsub "^dest=" $i "" tmp regsub "^dest=" $i "" tmp
if {[board_info $tmp exists name]} { if {[board_info $tmp exists name]} {
@@ -420,6 +432,7 @@ proc default_target_compile {source destfile type options} { @@ -420,6 +432,7 @@ proc default_target_compile {source dest
global CC_FOR_TARGET global CC_FOR_TARGET
global CXX_FOR_TARGET global CXX_FOR_TARGET
global F77_FOR_TARGET global F77_FOR_TARGET
@ -152,7 +144,7 @@ index c9fde2c..ec9fff2 100644
global GNATMAKE_FOR_TARGET global GNATMAKE_FOR_TARGET
if {[info exists GNATMAKE_FOR_TARGET]} { if {[info exists GNATMAKE_FOR_TARGET]} {
@@ -446,6 +459,12 @@ proc default_target_compile {source destfile type options} { @@ -446,6 +459,12 @@ proc default_target_compile {source dest
} }
} }