5.0-8 - Add 0001-find-debuginfo-Prefix-install_dir-to-PATH.patch

This commit is contained in:
Mark Wielaard 2023-06-30 17:39:47 +02:00
parent e06e7b2e92
commit b23c6c74d0
2 changed files with 58 additions and 1 deletions

View File

@ -0,0 +1,53 @@
From 7f8e83cad517db081e1e0369b758d0279e0a6e1b Mon Sep 17 00:00:00 2001
From: Mark Wielaard <mark@klomp.org>
Date: Thu, 29 Jun 2023 14:26:39 +0200
Subject: [PATCH] find-debuginfo: Prefix install_dir to PATH
Some distros install a symlink to find-debuginfo[.sh] under the
old /usr/lib/rpm/ path. But don't have symlinks there for other
helper tools like debugedit and sepdebugcrcfix. So those tools
are then not under the install_dir as find-debuginfo calculates
it. So instead of invoking those helper tools with a full install
dir path, prefix the install dir to the PATH so the tools can be
found there (or anywhere else on the PATH).
Signed-off-by: Mark Wielaard <mark@klomp.org>
---
scripts/find-debuginfo.in | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/scripts/find-debuginfo.in b/scripts/find-debuginfo.in
index e7ac095..f87b777 100755
--- a/scripts/find-debuginfo.in
+++ b/scripts/find-debuginfo.in
@@ -101,7 +101,9 @@ EOF
}
# Figure out where we are installed so we can call other helper scripts.
+# Prefix to PATH to prefer tools from install dir.
install_dir="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )"
+PATH=${install_dir}:$PATH
# With -g arg, pass it to strip on libraries or executables.
strip_g=false
@@ -457,7 +459,7 @@ do_file()
if [ "$no_recompute_build_id" = "true" ]; then
no_recompute="-n"
fi
- id=$(${install_dir}/debugedit -b "$debug_base_name" -d "$debug_dest_name" \
+ id=$(debugedit -b "$debug_base_name" -d "$debug_dest_name" \
$no_recompute -i \
${build_id_seed:+--build-id-seed="$build_id_seed"} \
-l "$SOURCEFILE" "$f") || exit
@@ -619,7 +621,7 @@ if $run_dwz \
# dwz invalidates .gnu_debuglink CRC32 in the main files.
cat "$ELFBINSFILE" |
(cd "$RPM_BUILD_ROOT"; \
- tr '\n' '\0' | xargs -0 ${install_dir}/sepdebugcrcfix usr/lib/debug)
+ tr '\n' '\0' | xargs -0 sepdebugcrcfix usr/lib/debug)
fi
fi
--
2.40.1

View File

@ -1,6 +1,6 @@
Name: debugedit Name: debugedit
Version: 5.0 Version: 5.0
Release: 7%{?dist} Release: 8%{?dist}
Summary: Tools for debuginfo creation Summary: Tools for debuginfo creation
License: GPLv3+ and GPLv2+ and LGPLv2+ License: GPLv3+ and GPLv2+ and LGPLv2+
URL: https://sourceware.org/debugedit/ URL: https://sourceware.org/debugedit/
@ -47,6 +47,7 @@ Patch3: 0001-find-debuginfo-Pass-j-down-to-dwz.patch
Patch4: 0002-configure.ac-Use-AC_LINK_IFELSE-for-gz-none-check.patch Patch4: 0002-configure.ac-Use-AC_LINK_IFELSE-for-gz-none-check.patch
Patch5: 0003-configure.ac-Use-AC_LANG_PROGRAM-for-AC_LINK_IFELSE-.patch Patch5: 0003-configure.ac-Use-AC_LANG_PROGRAM-for-AC_LINK_IFELSE-.patch
Patch6: 0004-scripts-find-debuginfo.in-Add-q-quiet.patch Patch6: 0004-scripts-find-debuginfo.in-Add-q-quiet.patch
Patch7: 0001-find-debuginfo-Prefix-install_dir-to-PATH.patch
%description %description
The debugedit project provides programs and scripts for creating The debugedit project provides programs and scripts for creating
@ -88,6 +89,9 @@ make check %{?_smp_mflags}
%{_mandir}/man1/find-debuginfo.1* %{_mandir}/man1/find-debuginfo.1*
%changelog %changelog
* Fri Jun 30 2023 Mark Wielaard <mjw@fedoraproject.org> - 5.0-8
- Add 0001-find-debuginfo-Prefix-install_dir-to-PATH.patch
* Fri Jan 27 2023 Mark Wielaard <mjw@fedoraproject.org> - 5.0-2 * Fri Jan 27 2023 Mark Wielaard <mjw@fedoraproject.org> - 5.0-2
- Refresh 0001-tests-Handle-zero-directory-entry-in-.debug_line-DWA.patch - Refresh 0001-tests-Handle-zero-directory-entry-in-.debug_line-DWA.patch
- Add new upstream patches: - Add new upstream patches: