Update to the latest version
* .gitignore: Remove old records, add /ddiskit-d857c7726fd55e613bbd7af6c842ddfc80a9fdc8.tar.bz2 * 0001-kabi-stablelists.patch: Remove, present upstream in commit 15ec1277e249 "templates/spec: use "stablelist" on RHEL 9+". * 0002-kernel-version-re-fix.patch: Refresh the patch. * ddiskit.spec (%forgeurl): Change the URL to https://gitlab.com/redhat/centos-stream/src/dup/ddiskit. (%commit): Change to d857c7726fd55e613bbd7af6c842ddfc80a9fdc8. (%forgesource, %topdir): New variables, added explicitly due to inability of the version of forge.lua present in RHEL 9.6 to handle nested gitlab project URLs. (Release): Bump top 17. (Patch0001): Remove. (%prep): Remove %patch0001. (%check): Remove, there are no tests present as of right now. (%changelog): Add a record. Resolves: RHEL-77191 Signed-off-by: Eugene Syromiatnikov <esyr@redhat.com>
This commit is contained in:
parent
ae4e61a629
commit
a837cc5fc4
3
.gitignore
vendored
3
.gitignore
vendored
@ -1,2 +1 @@
|
||||
/ddiskit-3.6.tar.gz
|
||||
/ddiskit-de1f6847223085dcdd177e02a7298c835fae12a3.tar.gz
|
||||
/ddiskit-d857c7726fd55e613bbd7af6c842ddfc80a9fdc8.tar.bz2
|
||||
|
@ -1,42 +0,0 @@
|
||||
Index: ddiskit-de1f6847223085dcdd177e02a7298c835fae12a3/templates/spec
|
||||
===================================================================
|
||||
--- ddiskit-de1f6847223085dcdd177e02a7298c835fae12a3.orig/templates/spec 2019-07-11 06:00:36.000000000 +0200
|
||||
+++ ddiskit-de1f6847223085dcdd177e02a7298c835fae12a3/templates/spec 2022-02-15 01:18:40.875578229 +0100
|
||||
@@ -21,12 +21,19 @@
|
||||
%endif
|
||||
|
||||
%if "%{kmod_dist_build_deps}" == ""
|
||||
+%if (0%{?rhel} > 8) || (0%{?centos} > 8)
|
||||
+%define abi_list stablelist
|
||||
+%define kmod_dist_build_deps redhat-rpm-config kernel-abi-stablelists elfutils-libelf-devel kernel-rpm-macros kmod
|
||||
+%else
|
||||
%if (0%{?rhel} > 7) || (0%{?centos} > 7)
|
||||
+%define abi_list whitelist
|
||||
%define kmod_dist_build_deps redhat-rpm-config kernel-abi-whitelists elfutils-libelf-devel kernel-rpm-macros kmod
|
||||
%else
|
||||
+%define abi_list whitelist
|
||||
%define kmod_dist_build_deps redhat-rpm-config kernel-abi-whitelists
|
||||
%endif
|
||||
%endif
|
||||
+%endif
|
||||
|
||||
Source0: %{kmod_name}-%{kmod_vendor}-%{kmod_driver_version}.tar.bz2
|
||||
%{SOURCE_PATCHES}
|
||||
@@ -210,7 +217,7 @@
|
||||
# mark modules executable so that strip-to-file can strip them
|
||||
find obj/%{kmod_kbuild_dir} -name "*.ko" -type f -exec chmod u+x '{}' +
|
||||
|
||||
-whitelist="/lib/modules/kabi-current/kabi_whitelist_%{_target_cpu}"
|
||||
+kabilist="/lib/modules/kabi-current/kabi_%{abi_list}_%{_target_cpu}"
|
||||
for modules in $( find obj/%{kmod_kbuild_dir} -name "*.ko" -type f -printf "%{findpat}\n" | sed 's|\.ko$||' | sort -u ) ; do
|
||||
# update depmod.conf
|
||||
module_weak_path=$(echo "$modules" | sed 's/[\/]*[^\/]*$//')
|
||||
@@ -227,7 +234,7 @@
|
||||
|
||||
# update greylist
|
||||
nm -u obj/%{kmod_kbuild_dir}/$modules.ko | sed 's/.*U //' | sed 's/^\.//' | sort -u | while read -r symbol; do
|
||||
- grep -q "^\s*$symbol\$" $whitelist || echo "$symbol" >> source/greylist
|
||||
+ grep -q "^\s*$symbol\$" $kabilist || echo "$symbol" >> source/greylist
|
||||
done
|
||||
done
|
||||
sort -u source/greylist | uniq > source/greylist.txt
|
@ -9,6 +9,6 @@ Index: ddiskit-de1f6847223085dcdd177e02a7298c835fae12a3/ddiskit.config
|
||||
+kernel_dist_re = (?P<rpm_dist>\.el([6-9]|[1-9][0-9])(_(0|[1-9][0-9]*))?)
|
||||
+kernel_flex_version_re = {kernel_nvr_re}(?P<rpm_release_aux>(\.[0-9]{1,3})*){kernel_dist_re}
|
||||
+
|
||||
[rpm_gpg_check]
|
||||
## Some initial assumption about the keyring dir
|
||||
keyring_dir = {defaults.res_dir}/keyrings/{defaults.profile}
|
||||
## Path to the spec file
|
||||
spec_path = rpm/SPECS/{spec_file.rpm_name}.spec
|
||||
|
||||
|
18
ddiskit.spec
18
ddiskit.spec
@ -1,24 +1,27 @@
|
||||
# Use the forge macros to simplify packaging.
|
||||
# See https://fedoraproject.org/wiki/Forge-hosted_projects_packaging_automation
|
||||
%global forgeurl https://github.com/orosp/ddiskit
|
||||
%global forgeurl https://gitlab.com/redhat/centos-stream/src/dup/ddiskit
|
||||
# When we no longer need to build against a git commit,
|
||||
# Simply remove the commit variable and update the Version
|
||||
# Then forge will pick up the release
|
||||
%global commit de1f6847223085dcdd177e02a7298c835fae12a3
|
||||
%global commit d857c7726fd55e613bbd7af6c842ddfc80a9fdc8
|
||||
# Old versions of forge.lua incorrectly generate source archive name
|
||||
# for the nested project URLs.
|
||||
%global forgesource ddiskit-%{commit}.tar.bz2
|
||||
%global topdir ddiskit-%{commit}
|
||||
|
||||
Name: ddiskit
|
||||
Version: 3.6
|
||||
|
||||
%forgemeta
|
||||
|
||||
Release: 16%{?dist}
|
||||
Release: 17%{?dist}
|
||||
Summary: Tool for Red Hat Enterprise Linux Driver Update Disk creation
|
||||
|
||||
License: GPLv3
|
||||
URL: %{forgeurl}
|
||||
Source0: %{forgesource}
|
||||
|
||||
Patch0001: 0001-kabi-stablelists.patch
|
||||
Patch0002: 0002-kernel-version-re-fix.patch
|
||||
|
||||
BuildArch: noarch
|
||||
@ -39,7 +42,6 @@ kernel modules.
|
||||
%prep
|
||||
%forgesetup
|
||||
|
||||
%patch0001 -p1
|
||||
%patch0002 -p1
|
||||
|
||||
%build
|
||||
@ -49,9 +51,6 @@ kernel modules.
|
||||
%py3_install
|
||||
find %{buildroot} -size 0 -delete
|
||||
|
||||
%check
|
||||
%{__python3} setup.py test
|
||||
|
||||
%files -n %{name}
|
||||
%doc README
|
||||
%license COPYING
|
||||
@ -74,6 +73,9 @@ find %{buildroot} -size 0 -delete
|
||||
%config(noreplace) /etc/ddiskit.config
|
||||
|
||||
%changelog
|
||||
* Thu Feb 06 2025 Eugene Syromiatnikov <esyr@redhat.com> - 3.6-17
|
||||
- Update to the latest version (RHEL-77191).
|
||||
|
||||
* Mon Jul 11 2022 Eugene Syromiatnikov <esyr@redhat.com> - 3.6-16
|
||||
- Update kernel version RE for RHEL 9 idiosyncrasies (#2101634).
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (ddiskit-de1f6847223085dcdd177e02a7298c835fae12a3.tar.gz) = 1b3d7dc10ab85c4b3a876cf6afb530baf0d5dd260cfdb51a3ef3b2906f3f163f86c40f3c2d05114cf3fb0bf79120d446aff8c4589e321ac9b9fafc015104a006
|
||||
SHA512 (ddiskit-d857c7726fd55e613bbd7af6c842ddfc80a9fdc8.tar.bz2) = 26495400e943b8cee2c14bcf0b25318622514f244de0bdf85adedfdf48054288b06ea8e6f642f43ae19c9775ab5e1cd371ad86fa509c782d0ad116e8d777e303
|
||||
|
Loading…
Reference in New Issue
Block a user