new upstream tarball with unchanged version number
RCS id 1.461 instead of 1.458, obsoletes lcms2 patch
This commit is contained in:
parent
1f39aeb7ec
commit
0b5723a784
@ -1,59 +0,0 @@
|
|||||||
From 789b763bff1701ef31bd077ae49671dfe1c82a51 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Nils Philippsen <nils@redhat.com>
|
|
||||||
Date: Wed, 4 Sep 2013 17:13:49 +0200
|
|
||||||
Subject: [PATCH] Add support for LCMS version 2.x.
|
|
||||||
|
|
||||||
---
|
|
||||||
dcraw.c | 21 ++++++++++++++++++++-
|
|
||||||
1 file changed, 20 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/dcraw.c b/dcraw.c
|
|
||||||
index 96e3d1f..4b280b5 100644
|
|
||||||
--- a/dcraw.c
|
|
||||||
+++ b/dcraw.c
|
|
||||||
@@ -80,7 +80,13 @@ typedef unsigned long long UINT64;
|
|
||||||
#include <jpeglib.h> /* Decode compressed Kodak DC120 photos */
|
|
||||||
#endif /* and Adobe Lossy DNGs */
|
|
||||||
#ifndef NO_LCMS
|
|
||||||
-#include <lcms.h> /* Support color profiles */
|
|
||||||
+#ifdef USE_LCMS2
|
|
||||||
+#include <lcms2.h> /* Support color profiles */
|
|
||||||
+#else
|
|
||||||
+#undef USE_LCMS1
|
|
||||||
+#define USE_LCMS1
|
|
||||||
+#include <lcms.h>
|
|
||||||
+#endif
|
|
||||||
#endif
|
|
||||||
#ifdef LOCALEDIR
|
|
||||||
#include <libintl.h>
|
|
||||||
@@ -8581,6 +8587,15 @@ notraw:
|
|
||||||
}
|
|
||||||
|
|
||||||
#ifndef NO_LCMS
|
|
||||||
+#ifdef USE_LCMS2
|
|
||||||
+static void lcms2_error_show_handler (cmsContext ContextID,
|
|
||||||
+ cmsUInt32Number ErrorCode,
|
|
||||||
+ const char *Text)
|
|
||||||
+{
|
|
||||||
+ fprintf (stderr, "lcms2: Error #%d; %s\n", ErrorCode, Text);
|
|
||||||
+}
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
void CLASS apply_profile (const char *input, const char *output)
|
|
||||||
{
|
|
||||||
char *prof;
|
|
||||||
@@ -8589,7 +8604,11 @@ void CLASS apply_profile (const char *input, const char *output)
|
|
||||||
FILE *fp;
|
|
||||||
unsigned size;
|
|
||||||
|
|
||||||
+#ifdef USE_LCMS2
|
|
||||||
+ cmsSetLogErrorHandler (lcms2_error_show_handler);
|
|
||||||
+#else
|
|
||||||
cmsErrorAction (LCMS_ERROR_SHOW);
|
|
||||||
+#endif
|
|
||||||
if (strcmp (input, "embed"))
|
|
||||||
hInProfile = cmsOpenProfileFromFile (input, "r");
|
|
||||||
else if (profile_length) {
|
|
||||||
--
|
|
||||||
1.8.3.1
|
|
||||||
|
|
13
dcraw.spec
13
dcraw.spec
@ -1,13 +1,12 @@
|
|||||||
Summary: Tool for decoding raw image data from digital cameras
|
Summary: Tool for decoding raw image data from digital cameras
|
||||||
Name: dcraw
|
Name: dcraw
|
||||||
Version: 9.20
|
Version: 9.20
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Group: Applications/Multimedia
|
Group: Applications/Multimedia
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://cybercom.net/~dcoffin/dcraw
|
URL: http://cybercom.net/~dcoffin/dcraw
|
||||||
Source0: http://cybercom.net/~dcoffin/dcraw/archive/dcraw-%{version}.tar.gz
|
Source0: http://cybercom.net/~dcoffin/dcraw/archive/dcraw-%{version}.tar.gz
|
||||||
Patch0: dcraw-9.19-lcms2.patch
|
Patch0: dcraw-9.19-CVE-2013-1438.patch
|
||||||
Patch1: dcraw-9.19-CVE-2013-1438.patch
|
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
BuildRequires: libjpeg-devel
|
BuildRequires: libjpeg-devel
|
||||||
BuildRequires: lcms2-devel
|
BuildRequires: lcms2-devel
|
||||||
@ -20,13 +19,11 @@ downloaded from digital cameras.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n dcraw
|
%setup -q -n dcraw
|
||||||
%patch0 -p1 -b .lcms2
|
%patch0 -p1 -b .CVE-2013-1438
|
||||||
%patch1 -p1 -b .CVE-2013-1438
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
gcc %optflags \
|
gcc %optflags \
|
||||||
-lm -ljpeg -llcms2 -ljasper \
|
-lm -ljpeg -llcms2 -ljasper \
|
||||||
-DUSE_LCMS2 \
|
|
||||||
-DLOCALEDIR="\"%{_datadir}/locale\"" \
|
-DLOCALEDIR="\"%{_datadir}/locale\"" \
|
||||||
-o dcraw dcraw.c
|
-o dcraw dcraw.c
|
||||||
# build language catalogs
|
# build language catalogs
|
||||||
@ -73,6 +70,10 @@ rm -rf %buildroot
|
|||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Apr 26 2014 Nils Philippsen <nils@redhat.com> - 9.20-2
|
||||||
|
- new upstream tarball with unchanged version number (RCS id 1.461 instead of
|
||||||
|
1.458), obsoletes lcms2 patch
|
||||||
|
|
||||||
* Wed Jan 15 2014 Nils Philippsen <nils@redhat.com> - 9.20-1
|
* Wed Jan 15 2014 Nils Philippsen <nils@redhat.com> - 9.20-1
|
||||||
- version 9.20
|
- version 9.20
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user